Introductory Example

Example of coupled flow and heat transfer problem using EImerGUI

ElmerGLI postprocessor
File Edit View Help

:| Surfaces | Wectors Isocontours Isosurfaces | Streamlnes | Colorbar | Text | Preferences  Redraw

XYZQui@Es? Geometry XYZQ110s ? Geometry
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Problem Outline
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Mesh

Using GMSH

Units in dm (0.1m)

Bottom up strategy E
Create Points

Construct lines from
points

Construct surfaces
from lines

B Apply smaller (1 mm)
mesh size around and

in pipe
® Apply larger (1 cm) 0.45
mesh size around 0.40
B If in doubt, just run the
. 0.35
*.geo file

XYz Q11Hs ? Geometry
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Mesh

B After construction of
geometry, choose Mesh in
the main menu

® Then click on 2D

rﬂ] GIMsh @W

File Tools Help

§ T

Define

Inspect

Edit

1D

2D

3D

First order

Second order

Optimize quality

Save
- 4 XYZQ11EHS? Geometry &
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EimerGUI

B After launching
ElmerGUI, open
Mesh -> Configure

® Change the
elmergrid-string to
the value given in the
r.h.s. Picture

B Explanation:

" -autoclean clears up
unused entities in
GMSH output

= -scale0.10.11.0
brings us back from
10! m units into the
S| world
® |n File -> Open
choose
periodiccyl.msh

Configure
Preterred generator
tetlib (.5t .smesh .poly off .ply .mesh]
@ nglib (in2d .stl .brep step .stp .iges igs)
elmergrid {.grd .FOMET .msh .mphtxt .unv)
tetlib
String:
nglib
Max H: 1000000
Fineness: | 0.5

Bgmesh:

&lmergrid

String: -relh 1.0 -autoclean -scale 0.1 0.1 1.0

Element codes (for solver):

Codes:

& Apply

C5C



http://www.csc.fi/suomi/info/index.phtml.fi

Alternative mesh import

® Qutside ElmerGUI
® |n the comand line:
ElmerGrid 14 3 periodiccyl.msh -autoclean -scale 0.1 0.1 1.0
B This directly creates the mesh in EImerSolver format:
mesh. {header, nodes, elements, boundary}
B Import into EImerGUI: File -> Load Mesh

B Possibility to create an EImerPost readable format (checking the
boundaries):

ElmerGrid 14 2 periodiccyl.msh -autoclean -scale 0.1 0.1 1.0

® This creates the file periodiccyl.ep that can be opened within
ElmerPost

B Existing meshes (EImerSolver format) are imported via File ->
Load Mesh

-

C5C



http://www.csc.fi/suomi/info/index.phtml.fi

EimerGUI main window

(ElmerGUl EHEE

. Menu bar ile Mesh Meodel View Sif Bun Help
" "Chronological | = <) QA ([> B 7 S @ & s & » (5
" order (from
left to right)

® Tool bar

" Quick access
to most
important
menu options 4

® Display
* Enables some
interaction
(selection of

bodies/
boundaries)

o i

@)

Y AT
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EiImerGUI Setup

In Model -> Setup

Change Simulation
Type to Transient

Add 100to
Timestep
intervals

Choose Timestep
sizes to 0.1

For the remaining
options the defaults
can be adopted

Click Apply

Header

v Check keywords warn
MeshDE
Inzlude path

Results directory

Simulation

Setup

Max. output level [4

:] Steady state max. iter | 1

Coordinate system [ Cartesian

:] Timestepping method [BDF

Coordinate mapping |12 3

BDF order [1

4k L13

Simulation type ITransient

:] Timestep intervals 100

Output intervals 1

Solver input file case.sif
Post file case.ep
Constants

Gravity 0-109.82

Stefan Boltzmann | 5.67e-08

Vacuum permittivity | 8.8542e-12

Boltzmann 1.3807e-23

Unitcharge 1.602e-19

Timestep sizes 0.1
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ElmerGUI Equation

E _Equation [3@|®
| In MOdEI -> Equation peilan l Heat Equation Mavier-Stokes Mesh Update B
| PreSS Add Activate for this equation set
Active v

B Toggle Body Property 1
(the part of the domain

Give Execution priority

filled with fluid) ;&1 100
B Activate Tab Navier- Convect 2
Stokes H
B Toggle Active
® |nsert 100 in Priority
® Toggle Convect
O

Then press Edit Solver
Settings:

" In this case we can go
with the default options |

Apply fo bodies:

| Body Property 1 Body Property 2

-'f’i,‘. Edit Solver Settings |

Mame: | Equation 1

| IE:a'ﬂvarw || %7 Update || W¥ 0K || == Remove | L

C5C
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ElmerGUI Equation ctd.

Activate Tab Heat Equation
Toggle Active

Insert 1 in Priority (lower
than 100 for Navier-Stokes!)

Select Convection
Computed

Toggle Body Property 1
(the part of the domain filled
with fluid)

Then press Edit Solver
Settings:

* We only have a linear
problem, thus setting
Nonlinear system -> Max.
Iterations to 1

Click Update (Add+ in later
ElmerGUI versions)

Equation

S]]

psilon Heat Equation Mavier-Stokes | Mesh Update E]

Activate for this equation set

Active W
Give Execution priority

Pricrity [
Options

Phase Change Model [ None

Convection

Convection [ Computed

Apply fo bodies:

| Body Property 1 Body Property 2

-'f’i,‘. Edit Solver Settings

Mame: | Equation 1

© New || % Update || W OK

| | &= Remove |

C5C



http://www.csc.fi/suomi/info/index.phtml.fi

ElmerGUI Equation ctd.

Click New (to get a 2nd set of
Equations)

Toggle Body Property 2 (the
solid part of the domain)

Activate Tab Heat Equation
Toggle Active

No Priority needed (as only
equation)

Select Convection to None

Then press Edit Solver Settings:

= Same settings as before
= NB.: settings apply to all equation
sets (=bodies) the solver is part of
Click OK (also in still open
Equation windows)

Equation [3 @|@
relasticity l K-Epsilon | HeatEguation | MNavier-Stokes EIB
Activate for this equation set
Active W

Give Execution priority

Pricrity

Options
Phase Change Model [ None =]

Convection

Convection [ Mone =

Apply fo bodies:

Body Property 1 |v| Body Property 2

| :‘D,‘ Edit Sclver Settings |

Mame: | Equation 2

| IE:a'ﬂvarw || %7 Update || W¥ 0K || == Remove | L

C5C
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ElmerGUI Material

In Model -> Material
Press Add

Toggle Body Property 1
(the part of the domain
filled with fluid)

Then press Material
library:
" Choose from list: Water
(room temperature)

Click Update
Click New

E Material

General Helmholtz Equation Linearelastici’q.rl K-Ep ]E]

Properties
Density [998.3
Heat Capacity |4183.0

Specific Heat Ratio
Reference Temperature |
Reference Pressure

Heatexpansion Coeff. [0.207e-3

Apply fo bodies:

| Body Property 1 Body Property 2

| ‘\ Material library |

Mame: | 'Water (room temperature)

| [ ONew || @Pupdae || oK

| | &= Remove |

==
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ElmerGUI Material ctd.

| Material S[EIE)
. Toggle BOdy Property 2 General | Helmholtz Equation Linear elasticity l K—Ep. E]
(the solid part of the) —
® Then press Material LA (7925.0
|ib|"ary' Heat Capacity |460.0
: . Specific Heat Ratio |
" Choose from list: Steel i
(stainless - generic) reemre e [
[ | CIle OK Heatexpansion Coeff. :_'1;1'.95':;5"

Apply fo bodies:

Body Property 1 |v| Body Property 2

| 3,‘ Material library |

Name: | Steel (stainless - generic)

| IE:a'ﬂvarw || %7 Update || W¥ 0K || == Remove | L
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EimerGUI Initial Condition

2 s

® |n Model -> Initial
Condition

® Press Add

B Toggle Body Property 1
(the part of the domain
filled with fluid)

B Select Tab Navier-
Stokes:

" Set value according to
r.h.s. picture

B Click Update

[itialen ik

HEE)

r&lasticity

Variables
Velocity 1
Velocity 2
Velocity 3

Pressure

K-Epsilon l Heat Equation

0.0
0.05
0.0
0.0

Mavier-Stokes EB

Apply fo bodies:

| Body Property 1 Body Property 2

Mame: | Initial Condition 1

| iEﬁ.ﬂaw

o Updas || &P OK

|| &= Remove |

C5C
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EiImerGUI Initial Condition ctd

N Se|eCt Tab Heat E InitialCondition E]@E]
Equation: relasticity | K-Epsilon | HeatEquation | Navier-Stokes EE]

" Set value according to Variables
rhs picture Temperaturs _EU

® Click Update
¥ Click New

Apply fo bodies:

| Body Property 1 Body Property 2

Mame: Initial Condition 1 |

%" Update || &’ CK || == Remove | I

| E'h:.ﬂva'«l'.'

C5C
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EiImerGUI Initial Condition ctd.

B Toggle Body Property 2
(the solid part of the domain)
B Select Tab Heat Equation:

= Set value according to r.h.s.
picture

B Click OK (=Update + Close)

B NB.: You might want to save
the stuff from time to time
(you never know ...). Use this

button and choose a new
folder for your project
>

“quation l Linear elasticity l K-Epsilan

Variables

| Heat Equation EE

Temperature |90

1
1

Apply fo bodies:
Body Property 1 |v| Body Property 2

Mame: |[ Initial Condition 2

| [ ONew || @PUpdae || oK

|| &= Remove | I

C5C
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ElImerGUI Boundary Condition

® Numbering of boundaries
(see r.h.s. picture)

B First time Add, thereafter
Update + New

B Boundary 1-5: Navier-Stokes
+ Heat Equation

B Boundary 6: Heat Equation
only

Boundary:

1. "Inflow”
= Vityelocl] =0.0
Velocity 2 = 0.05
* Temperature = 20
1. "Outflow”

* Natural boundary conditions (=
set nothing)

1. "left”: nothing

2. "right”: periodic of left (see next
slide)
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EiImerGUI Boundary Condition ctd.

® |n Model -> Boundary BoundaryCondition
Condition -Generai_!_l_-_lﬁ.?_l_: Equation | Helmholtz Equation | KEpsion | L~ #
® Press Add Periodic boundary conditions
® Toggle Boundary 4 (the i |
right side of the domain) e | |
¥ [nsert Periodic Eptatencit | |
Boundary ID 3
" This links boundary 4 to
boundary 3
Apply to boundaries: =
Boundary 1 Eoundary 2 3
Boundary 3 Boundary 4 &
Mame: |BoundaryCondition 4 |

[ © plaw ] [ %" Update ] [ W K ] [ &= Remove ]

C5C
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EiImerGUI Boundary Condition ctd.

® Click Tab Navier-Stokes BoundaryCondition =1
" Togg le all Variables in K-Epsilon |  Linear elasticity __ Mesh Update I Navier-StnE_I 4
PeriOdiC BC'S Pressure 2 Q=

® Click Update e

Surface Tension Coefficient

Slip Coefficient 1

Slip Coefficient 2

| |
| |
| |
Surface Tension Expansion Coefficient [ [
| |
| |
| |

Slip Coefficient 3

Periodic BCs
Melocity 1 periodic
welocity 2 periodic
welocity 3 periodic
Prassure petiodic B
e
A
Apply to boundaries:
Boundary 1 Boundary 2 3
Boundary 3 Eoundary 4 &

Mame: | BoundaryCondition ¢ |

[ © plaw ] [ %" Update ] [ W 0K ] [ &= Remove ]

C5C
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EiImerGUI Boundary Condition ctd.

® Click Tab Heat Equation

" Toggle all Variables in
Periodic BC’s

® Click Update
¥ Click New

BoundaryCondition

| Gereral | HeatEquation | Helmholtz Equation K-Epsilon L %5k

Latent heat of phase change |

Fhase Change i |

Heat Gap
Heak Gap |:|

Radiation Settings

Radiation |Mone |

Ernissiviby | [

Radiation Boundary Open

Radiation Boundary | |

Radiation Target Body | |

Periodic houndary condition

Temperature petiodic

Apply to boundaries;
Boundary 1 Boundary 2

Boundary 3 Eoundary 4 &

Mame: | BoundaryCondition ¢ |

[ © plaw ] [ %" Update ] [ W K ] [ &= Remove ]

C5C



http://www.csc.fi/suomi/info/index.phtml.fi

EiImerGUI Boundary Condition ctd.

BoundaryCondition

® Toggle Boundary 5 (the |
O ute r Cyl | n d e r Wa I I ) Mormal-Tangential Coordinate System

. Act i Vate Ta b N aVi e r_ Iz normal-tangential coordinate system [
Sto ke S Dirichlet Conditions

B Toggle Noslip wall BC Nosip wall BC
| Heat Equat|0n natural BC Welocity 1

Change of variables

Melocity 2

| |

_ | |
® (Click Update velocity 3 | |
H Cll Ck N ew yelocity 1 Condition : :
| |

Melocity 2 Condition

Melocity 3 Condition

Traction boundary conditions |

_ il

»

Apply to boundaries;
Boundary 1 Boundary 2
Boundary 3 Boundary ¢

Mame: | BoundaryCondition S |

[ © plaw ] [ %" Update ] [ W K ] [ &= Remove ]

C5C
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EiImerGUI Boundary Condition ctd.

BoundaryCondition

| Togg Ie Bou nda ry 6 (the '__Eﬁj_n_eral ! Heat Equation -i Helmholtz Equation | : K—_El:u_sln_lj_t _I. *
|nner Cyllnder Wa”) Dirichlet Conditions &l
B Activate Tab Heat TRpEse 2 |

Ternperature Condition | |

E q u at i on Heat Flux conditions
® Temperature = 90 Heat Fux | |
B Nothing for Navier-Stokes e : :

( S O I | d b 0 d y) Latent heat of phase change =
[ | C I | C k o K Phase Change il

Heat Gap
Heak Gap |:|

Radiation Settings

<

| |.

Apply to boundaries;
Boundary 1 Boundary 2

Boundary 3 Boundary ¢

<

Mame: | BoundaryCondition & |

[ © plaw ] [ %" Update ] [ W K ] [ &= Remove ]

C5C
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ElImerGUI Starting the run

® Do a Sif -> Generate

B Save the project first!
= either by File -> Save Projec*
" or by pressing the symbol
" The earlier given location (folder) will be suggested: confirm with OK

.:}

B Check your settings: Model -> Summary ...

® [aunch the run by @

" Either pressing the symbol
" Or by Run -> Start Solver
= The symbol should change its color @

C5C
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ElmerGUI Starting the run ctd.

Solver log

File  Edit
— R 7 |l |88
IO O eSS S SO UOTe
® A Solver log and a Convergen 3
FlowSalve: Dirichlet conditions done
h H t H d H I I ComputeChange: N5 (ITER=1) (NRM,RELC): { 035711 352E-01 0, 73369060E-04 1 11 navier-stokes
I S o ry W I n OW W I OCC u r siker: 1 Assembly: {s) 0,02 0,09
riker: 1 5Salver () 0.03 0.03
. : Result Morm ¢ 3.571135235814792666E-002
[ | If somet h in g a p p arent I y g oes ¢ Relative Change :  7.336301595206891 265E-005
-
.
wrong: Run -> Kill Solve T
: Starting Assembly...
: Assembly done
: Dirichlet conditions done
ComputeChange: M3 (ITER=2) (MRM,RELC): { 0.35720259E-01 0,24936739E-03 ) i1 navier-stokes
FlowSalve: iter: 2 Assembly: (s) 0.11 0.20
A Snlye: | H Ol'w'f
Convergence monitor
File  ‘View
Convergence history (time=2.5)
Lt : 2 : : | = M5{navier-stokes
’ = M5/heat equation
1
g 0.01 . o
=
= j
E y
@ 0.0001 | /
= ‘
e A
% | f
g [} h
L oyons | 1
1e-08 ! 1 B | $ o ¥
110 ; ;
I T T T T T T T T T T T T T 1
0 10 20 30 40 50 60 70 80 90 100 110 120 130 140
Tteration step
Ready

C5C
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ElmerGUI Postprocessing

m Upon getting a converged result 1
« Either launch ElmerPost by clicking the symbol t }
t
« Or Run -> Start Postprocessor S |
m Then ElmerPost launches ‘; ¥
« ElmerPost will render the t value of the velocity by i ]
default i
« NB: in case of transient runs, unfortunately EImerGUI lets 1 i
ElmerPost only load the first timestep t {
« Remedy: reload with (in EImerPost) File -> Read and press f i
the All buton + OK thereafter t i
tf
I:|T
fod
11'1
1yl
fs 1 i
BE N1 @ AF
Jr .
0 0.0025 0.005 0.0075 0.01
E A =
Velocity _abs
1 —
C5C
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ElImerGUI Postprocessing ctd.

File Edit Display Help Modules

Read Model File
Status: [MNot Done

Options:

[v Generate Surface Element Sides
I Generate Yolume Element Sides

I Generate Yolume Element Edges

File Information:

Modes:
Elements:

Timestps:
DOFS:

Wector  Velocity

- Scalar  Pressure
Scalar  Temperature
Selecttimesteps:

First: |1 Last: [100  Increment |1 ﬂ

Select file:

Model file: |case.ep Browse...

Fiead header | FRead file | OF | Close
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ElmerGUI Postprocessing VTK

® ElmerGUI VTK based built-

in postprocessor e =
= Run Postprocessor
(VTK)
® Then the VTK postprocessor
launches

= No variable by default

= NB: in case of transient
runs, unfortunately
ElmerGUI lets the VTK
postprocessor only load
the first timestep

* Remedy: reload with (in
ElmerPost) File -> Read
and press the All buton +
OK thereafter

C5C
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ElmerGUI Postprocessing VTK

B Special Feature:
Streamlines

Streamlines

Contrals

Vector: i\felocity

Max, kime: i_lD.D_
Threads: |21 o
(%) Use surface mesh

) Use volume mesh

Step length: |

Inteq. length: |0.005

Integrate Forwards

[ 1ntearate backwards

Calar

Calar !Null vi

Mir: ;U—| Max: ’D—|
[ keep limits

Appearance

(%) Draw lines Line width: C:]

) Draw ribbons

Ribbon width: |5 &

Source bype
() sphere source

@ Line source

Sphere source

Cenker ID.D
Cenker ¥ iD.D

Center Z;

Line source

Stark X

Skark ¥

Skark 2

Paints;

Draw source ling

ElmerGUI postprocessor
File Edit View Help

| Surfaces | Vectors Isocontours Isosurfaces | Streamiines | Colorbar | Text | Preferences | Redraw

(3 Pick source point (p%

Paints: 1 2
End Z: 0.0

Source ling width:

Apply

H @ cancel H W Ok ]

C5C
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Exercises

® Change into steady state run

B Change the heat transfer through boundary 6:
1. Heat transfer coefficient
2. Heat flux

® |ncrease inflow velocity - how far can you go? Check the Reynolds
number

C5C
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