Subject: Re: Stupid NAT tricks and how to stop them.

From: [email-masked]
Date: Fri, 07 Apr 2006 15:48:55 +0000

Anthony G. Atkielski wrote:

> AT&T used to charge for any telephone color other than black, even 
> though the cost of producing a telephone was the same no matter what 
> color it was.

AT&T also  used to charge for additional private IP addresses.  I remember one company had a bussiness package with them and was also leasing a router that came locked down and configured to use 192.168.0.0/27 on the LAN.  When this company wanted more IP's internally AT&T wanted to charge them more to "upgrade" them to a 192.168.0.0/24
----------------

John-

I agree that no IPv6 solution involving customers  giving up the (percieved?) freedom of NAT for a construct that has them suckling from their ISP's tit again is really going to go over well.

One small note also about the ISP supplied modem - at least in my experience in Los Angeles - the basic modems I've seen act solely as a pass-through (they have no configuration menus -etc).  I know today modem/home networking in a box devices are being pushed (because the ISP's charge extra for it), but the basic end user is getting no bells and whistles -(at least with SBC, Verizon, and Comcast).

FWIW-(which isn't much), IMO people like NAT because it lets them do what they want without paying more or getting permission.  Cause I think thats really all they want from any solution.

nick

_______________________________________________
Ietf mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ietf

---

From: Peter Sherbin <[email-masked]>
Date: Fri, 7 Apr 2006 11:13:07 -0700 (PDT)

> FWIW-(which isn't much), IMO people like NAT because
> it lets them do what they want without paying more
> or getting permission.  Cause I think thats really
> all they want from any solution.

ISP fees for additional addresses just leveraging an
opportunity to extract a few more dollars. The
opportunity stems out of:
1) a notion of leased addresses, i.e. addresses have
to be returned back when a customer leaves ISP
2) a percieved scarcity of IPv4 addresses.
Overall it goes all the way back to IANA allocation
policy preserving the internet hierarchy.

In theory IPv6 provides enough addresses for everyone.
How to make sure that addresses are not wasted?
Immediate answer - get addresses through your LIR.
Apparently quite a lot of people would want to become
LIR for themselves. At some point we may start
considering e.g. UN sponsored IP address registrars
allocating x-amount of IP addresses to each individual
and establishment on the planet and managing such
allocation.

Peter Sherbin,
[email-masked]

--- [email-masked] wrote:

> AT&T also  used to charge for additional private IP
> addresses.  I remember one company had a bussiness
> package with them and was also leasing a router that
> came locked down and configured to use
> 192.168.0.0/27 on the LAN.  When this company wanted
> more IP's internally AT&T wanted to charge them more
> to "upgrade" them to a 192.168.0.0/24
> ----------------
> 
> John-
> 
> I agree that no IPv6 solution involving customers 
> giving up the (percieved?) freedom of NAT for a
> construct that has them suckling from their ISP's
> tit again is really going to go over well.
> 
> One small note also about the ISP supplied modem -
> at least in my experience in Los Angeles - the basic
> modems I've seen act solely as a pass-through (they
> have no configuration menus -etc).  I know today
> modem/home networking in a box devices are being
> pushed (because the ISP's charge extra for it), but
> the basic end user is getting no bells and whistles
> -(at least with SBC, Verizon, and Comcast).
> 
> FWIW-(which isn't much), IMO people like NAT because
> it lets them do what they want without paying more
> or getting permission.  Cause I think thats really
> all they want from any solution.
> 
> nick>
> https://www1.ietf.org/mailman/listinfo/ietf

__________________________________________________
Do You Yahoo!?
Tired of spam?  Yahoo! Mail has the best spam
protection around 
http://mail.yahoo.com 

__________________________________________________
Do You Yahoo!?
Tired of spam?  Yahoo! Mail has the best spam protection around 
http://mail.yahoo.com