Subject: Existing use of IP protocol 114 (any 0-hop protocol)

From: "Eric Vyncke (evyncke)" <[email-masked]>
Date: Thu, 19 Sep 2019 15:06:04 +0000

The authors of https://tools.ietf.org/id/draft-zhu-intarea-gma-03.txt would like to use IP protocol 114 as it is described as “Any 0-hop protocol” on the IANA page[1]. Alas, on the IANA page, there is no reference to this “Any 0-hop protocol”.

Obviously, we all understand that this must be a protocol using hop limit = 0 (or TTL=0 for the legacy protocol).

When there is no reference for a IANA number, this means that this number was assigned _before_ IANA, possibly by J. Postel and nobody at IANA and in the IESG know more. Hence, my questions to the community:

Q1) does anyone know about a more formal reference / specification for this protocol 114

Q2) does anyone know about a RFC or a protocol using this protocol 114 ?

Please note that I do not ask for comments/reviews on the draft itself (they are welcome though on the [email-masked]<mailto:[email-masked]> mailing list even if this is not a WG document). And it is also mostly obvious that only one transport layer can exist on the top of this protocol.

Regards,

-éric (INT AD)

[1] https://www.iana.org/assignments/protocol-numbers/protocol-numbers.xhtml

---

From: Fernando Gont <[email-masked]>
Date: Thu, 19 Sep 2019 19:53:33 +0300

On 19/9/19 18:06, Eric Vyncke (evyncke) wrote:
> The authors of https://tools.ietf.org/id/draft-zhu-intarea-gma-03.txt
> would like to use IP protocol 114 as it is described as “Any 0-hop
> protocol” on the IANA page[1]. Alas, on the IANA page, there is no
> reference to this “Any 0-hop protocol”.
> 
>  
> 
> Obviously, we all understand that this must be a protocol using hop
> limit = 0 (or TTL=0 for the legacy protocol).

Just a (mostly side) comment:

The hop limit thins is tricky:
Some 0-hop (non-routable?) protocols actually use a high (e.g. 255) TTL,
such that it can be enforced ("''''security''''-wise") that the parties
are actually on the same network segment.

Others (was it mld?) employ small hop limit values, such that you can
control how far packets can leak out.

So the protocol might actually use small or large hop limit, depending
on whether you want to make sure that packets cannot be injected, or
that packets cannot leak out.

Thanks!

Cheers,
-- 
Fernando Gont
SI6 Networks
e-mail: [email-masked]
PGP Fingerprint: 6666 31C6 D484 63B2 8FB1 E3C4 AE25 0D55 1D4E 7492

---

From: Masataka Ohta <[email-masked]>
Date: Fri, 20 Sep 2019 06:05:42 +0900

Eric Vyncke (evyncke) wrote:

> When there is no reference for a IANA number, this means that this
> number was assigned _before_ IANA, possibly by J. Postel and nobody
> at IANA and in the IESG know more.

As 114 is not an assigned protocol number in rfc1700, it should
have been assigned after rfc1700 was published (Oct. 1994).

> And it is also mostly obvious that only one
> transport layer can exist on the top of this protocol.

In theory, like 9 for IGP, transport protocol for 114 can be
different link by link, though not practical.

						Masataka Ohta

---

From: Erik Kline <[email-masked]>
Date: Thu, 19 Sep 2019 14:28:17 -0700

Where do they want to use this, and why not request a new protocol value?

(What did [email-masked] say?)

On Thu, 19 Sep 2019 at 08:07, Eric Vyncke (evyncke) <[email-masked]>
wrote:

> When there is no reference for a IANA number, this means that this number
> was assigned _*before*_ IANA, possibly by J. Postel and nobody at IANA
> and in the IESG know more. Hence, my questions to the community:
>
>
>
> Please note that I do not ask for comments/reviews on the draft itself
> (they are welcome though on the [email-masked] mailing list even if
> this is not a WG document). And it is also mostly obvious that only one
> [1]
> https://www.iana.org/assignments/protocol-numbers/protocol-numbers.xhtml
> _______________________________________________
> Int-area mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/int-area
>

---

From: "Andrew G. Malis" <[email-masked]>
Date: Thu, 19 Sep 2019 17:37:13 -0400

Erik,

IP Protocol numbers are a scarce resource and the allocation policy is
"IESG Approval or Standards Action". They aren't interested in the latter,
so they would need the former. So if they can legitimately reuse 114, it
makes everyone's life easier.

Cheers,
Andy