Subject: Re: Registration details for IETF 108

From: S Moonesamy <[email-masked]>
Date: Mon, 01 Jun 2020 02:39:11 -0700

Hi Brian, Stephen,
At 09:36 PM 31-05-2020, Brian E Carpenter wrote:
>On the substance (and partly in response to SM) I know that participants
>have had to cover IETF meeting costs since 1992, and presumably longer,
>so I don't find this shocking. But for the longer term, we do need to
>think about how this interacts with the goal of "any interested person
>can participate in the work, know what is being decided, and make his
>or her voice heard" [RFC3935].

Thanks for the above.  I would not describe the decision as 
"shocking" as it would be an exaggeration.  In my opinion, there are 
difficult questions ahead.  The text which you quoted is one example.

Regards,
S. Moonesamy

---

From: "tom petch" <[email-masked]>
Date: Mon, 1 Jun 2020 11:46:42 +0100

---- Original Message -----
From: S Moonesamy <[email-masked]>
Sent: 01/06/2020 10:39:11

Hi Brian, Stephen,

<tp> I took part in the questionnaire and was surprised at the number of questions about fees but then took it for granted that a fee would be charged; I still feel that any interested party can take part, join the mailing lists, submit I-Ds and so on.  Unless and until meetings have primacy over list decisions - and some WG Chair can act as if this was not the case:-( - then I see no change.  Tom Petch

---
New Outlook Express and Windows Live Mail replacement - get it here:
https://www.oeclassic.com/

Regards,
S. Moonesamy

---

From: Suresh Krishnan <[email-masked]>
Date: Mon, 1 Jun 2020 08:38:38 -0400

+1. I think this is a reasonable decision and allows people to participate without financial barriers, while allowing the ongoing activities funded by IETF meeting fees to proceed without interruption.

Regards
Suresh

> On May 31, 2020, at 5:24 PM, Joel M. Halpern <[email-masked]> wrote:
> 
> I agree with Eric in his description.  From where I sit, this seems a reasonable decision by the leadership.
> 
> Yours,
> Joel
> 
> On 5/31/2020 5:13 PM, Eric Rescorla wrote:
>> On Sun, May 31, 2020 at 1:56 PM S Moonesamy <[email-masked] <mailto:[email-masked]>> wrote:
>>    Dear Internet Engineering Steering Group,
>>    [Reply-To override]
>>    At 06:12 PM 27-05-2020, IETF Executive Director wrote:
>>     >This meeting will have a substantial agenda but as the cost of an
>>     >online meeting is lower, the registration fees have been set at
>>     >approximately one-third of those for an in-person meeting.  A
>>     >detailed explanation of why we charge a fee for meetings and how the
>>     >fee reduction was set for IETF 108 is provided in a separate blog
>>    post [3].
>>    In 2013, the IETF Chair affirmed that the Internet Engineering Task
>>    Force embraced the modern paradigm for standards.  One of the points
>>    in the document is the standards process being open to all interested
>>    and informed parties.  If I recall correctly, I raised a point a few
>>    months before 2013 about the IETF allowing free access to its
>>    meetings through the Internet.  I could not help noticing that there
>>    is now a required fee to access the next IETF meeting.  Was that
>>    approved by the IESG?
>>    I took a look at the meeting policy for the IETF.  I never understood
>>    why that policy is described as an ambition.  Anyway, as that policy
>>    does not specify anything about changing the existing practice for
>>    fees, it is unlikely that the decision to charge for online meetings
>>    can be challenged.
>>    I would like to thank the IETF LLC Directors for acknowledging that
>>    the fee presents a barrier to participation and their charitable
>>    offer.  I'll leave the charitable offer to those who are in need.
>>    It took a decade for the IETF to take this pay-to-play decision.  Was
>>    there any discussion about it?
>> I don't think the characterization of this as "pay-to-play" is accurate. You
>> are certainly free to participate in mailing lists, github, etc.
>> What is being charged here is a fee to participate [0] in real-time virtual
>> meetings, just as there is one charged for attending in-person meetings.
>> -Ekr
>> [0] I emphasize "real-time" as I expect that the recordings will be available
>> after the fact as usual.
>

---

From: "Livingood, Jason" <[email-masked]>
Date: Mon, 1 Jun 2020 15:07:43 +0000

It's interesting that the issue has been framed as a new fee will be charged to participate in an IETF meeting. But there's been a fee to attend an IETF meeting for as long as I've participated in the IETF. I might suggest that another way of considering this is that the typical meeting fee is being discounted for the virtual meeting.

Jason
(not speaking for the IETF LLC - personal view)

On 6/1/20, 8:39 AM, "ietf on behalf of Suresh Krishnan" <[email-masked] on behalf of [email-masked]> wrote:

    Regards
    Suresh

---

From: "Livingood, Jason" <[email-masked]>
Date: Mon, 1 Jun 2020 15:16:04 +0000

> 1) Is listen-only attendance charged the same fee as listen-and-speak? If so, is that right or wrong?

If I attend an IETF meeting in person but choose not to go to the mic line to comment, should I be charged less or not at all? That does not seem to make sense & isn't how the IETF has operated. Isn't it worse to charge people only if they engage in the meetings -- you can attend but if you want to speak at the mic you must pay?

Jason
(no IETF LLC hat - personal view)

---

From: Bob Hinden <[email-masked]>
Date: Mon, 1 Jun 2020 08:39:40 -0700

Jason,

I think the issue here is that we are now charging for something we didn’t before.  That is, we allowed remote participation at IETF meetings without a fee unto and including IETF 107.   As Brian points out, this change in policy was done with out any discussion.

I also note that everything we do in the IETF has a cost to it.  Every email, internet draft, submission to the IESG, working group charter, IETF tool, etc., etc.  We can see all these costs in the IETF LLC budget.    None of it is free.

The question is which of these do we charge for?    According the budget at:

  https://ietf.org/blog/ietf-administration-llc-2020-budget/

the non-meeting operating expenses are about $5.1 million per year.   Even the meeting revenue (including registration fees) doesn’t cover all of the meeting expenses.   That is, $3.8M revenue vs. $4.1M costs.

How do we decide what to charge for?   What is the policy?

Also, what does the budget look like without face to face meetings?

Bob

> On Jun 1, 2020, at 8:07 AM, Livingood, Jason <[email-masked]> wrote:
>

---

From: Ole Jacobsen <[email-masked]>
Date: Mon, 1 Jun 2020 08:41:20 -0700

Jason,

As a fairly regular in-person attendee (I think I am 97 or 98 meetings by now), I
would agree that this can be seen as a discounted meeting fee, and it seems reasonable.

However, I don’t think we should ignore those many attendees who never actually make
it to in-person meetings and who have attended via Meetecho or more recently the
YouTube live streams. There may be many reasons for their remote-only participation, 
but one has to assume that at least one reason is the registration fee (and of course
travel). These attendees are now faced with a fee which previously did not exist.
I am sure this came as a bit of a shock to them. I can think of a whole bunch of alternative
solutions including “click here if you want to sponsor another remote participant” or
whatever, but it is probably too late to implement now.

Ole

> On 1 Jun 2020, at 08:07, Livingood, Jason <[email-masked]> wrote:
> 

Ole J. Jacobsen
Editor and Publisher
The Internet Protocol Journal
Office: +1 415-550-9433
Cell:   +1 415-370-4628
Web: protocoljournal.org
E-mail: [email-masked]
E-mail: [email-masked]
Skype: organdemo

---

From: Lixia Zhang <[email-masked]>
Date: Mon, 1 Jun 2020 09:23:09 -0700

> On May 31, 2020, at 9:36 PM, Brian E Carpenter <[email-masked]> wrote:
> 
> ......
> On the substance (and partly in response to SM) I know that participants have had to cover IETF meeting costs since 1992, and presumably longer, so I don't find this shocking. But for the longer term, we do need to think about how this interacts with the goal of "any interested person can participate in the work, know what is being decided, and make his or her voice heard" [RFC3935].
> 
> Regards
>    Brian

a few observations following Brian's above comments as food for thought:

1/ organizing IETF meetings, in person or online, incurs cost. 

2/ if this cost needs to be covered by meeting participants: this conflicts with "any interested person can participate in the work" for free.

3/ for academic conferences: online conf. registration is so much lower now (e.g. one used to be $700/person, now $100/person), plus no travel cost, this makes it a lot more more affordable, potentially attract a higher attendance.

4/ as a central principles of the IETF, people participate as individuals, not representatives of their companies, this seems to argue for consideration of moving meeting registration fees, or more general IETF participation fees, towards a model as personal professional cost (e.g. IEEE or ACM membership fees), of course only if it can be made affordable.
(I didnt have time to follow all exchanges but do wonder whether the $230/person reg. fee can be reduced)

bottom line: it is so unfortunate there is no free lunch. C19 pandemic brought the issue on the table: We cannot have both "everyone can participate" and "for free" in the same sentence.

my 2 cents,
Lixia

---

From: Scott Kitterman <[email-masked]>
Date: Mon, 01 Jun 2020 12:31:58 -0400

Amazingly enough, I've participated in several IETF meetings, when needed for 
drafts I was working on, without being charged for it, so I'm curious about 
this 'discount' I'm now going to get.

Scott K

On Monday, June 1, 2020 11:07:43 AM EDT Livingood, Jason wrote:
> It's interesting that the issue has been framed as a new fee will be charged
> to participate in an IETF meeting. But there's been a fee to attend an IETF
> meeting for as long as I've participated in the IETF. I might suggest that
> another way of considering this is that the typical meeting fee is being
> discounted for the virtual meeting.
 
> On 6/1/20, 8:39 AM, "ietf on behalf of Suresh Krishnan"
> <[email-masked] on behalf of [email-masked]> wrote:
 
>     +1. I think this is a reasonable decision and allows people to
> participate without financial barriers, while allowing the ongoing
> activities funded by IETF meeting fees to proceed without interruption.
 
>     >> I don't think the characterization of this as "pay-to-play" is
 are certainly free to participate in mailing lists,
>     >> github, etc.
 meetings, just as there is one charged for attending
>     >> in-person meetings. -Ekr
 after the fact as usual.

---

From: Robert Raszuk <[email-masked]>
Date: Mon, 1 Jun 2020 18:37:14 +0200

> $230/person reg. fee can be reduced)

Is there some URL describing this decision ? What exactly is this fee for ?

Ability to attend online WG sessions ?

Does it also extend to interim meetings ?

Would it still apply when onsite meetings start to happen ?

What if chairs will call-up an informal zoom or google meet session without
any fees ? Will they be fired from chair positions of a WG ?

Would we also start to see charges for participation in email lists ? Or
charge per email sent ?

And last would recordings of the meetings be available for free ?

Depends on those answers I guess this may be very well the beginning of
email based standards process even further discouraging those not
associated with any big vendor/sponsor to participate.

Kind regards,
Robert

---

From: John C Klensin <[email-masked]>
Date: Mon, 01 Jun 2020 12:44:52 -0400

Hi.

Having read the survey results and having been suggesting for
many years that remote participants (note participants, not
observers/lurkers) should be charged at least a nominal fee, I
agree with all of those who have said that charging something is
reasonable.   I have three concerns that are, in increasing
order of importance below.  While not trivial, I hope that
neither of the first two become a distraction.

(1) At least in retrospect and with the understanding that we
are all learning as we go along, if the IESG was aware at the
time of the 14 May "meeting will be online" announcement,
indicating that a fee was likely (or certain) and that details
would follow with the IETF LLC had them ready would have been
helpful (rather than just saying "Further details ...will be
shared as they become available").  That might have prevented
the surprise some people felt about an announcement that there
would be a fee and having that announcement appear less than a
month before the early-bird cutoff.  Let's not pretend there is
an impenetrable wall between the IESG and the IETF
Administration LLC, especially after the community explicitly
agreed that the IETF Chair should have a seat on the LLC Board
precisely to foster this type of communication and Alissa's
comment that the IESG had discussed the fee structure.

(2) While I appreciate the specific numbers and comparison in
the announcement and blog post, the conclusion reads a bit like
numbers were pulled out of a hat (even if people were selective
about the numbers that were put into the hat).   To the extent
to which the LLC's goal is increasingly data-driven and
evidence-based decision making, some of this seems to have the
ring of arbitrariness about it.   Why up to 100 waivers and not
75 or 125 or some other number?  Does the LLC believe that
setting an arbitrary target and then running a lottery for who
gets a waiver (and hence who gets to participate) is better than
criteria-based case-by-case decision making and, especially
since the community was not consulted on that change, why?
Why "about a third" rather than a number somewhat higher or
somewhat lower?  And, as someone else asked, is there enough
difference in meeting arrangement and set=up costs to justify a
distinction between Early-bird and Standard registrations and a
$50 difference in fees between them and, if so, why?

(3) While I note that almost every posting since Melinda's
comments excerpted below has concentrated on the fees, I think
she has identified the important issue.  We continue to claim
that decisions are made --not just checked or last-called -- on
mailing lists, but that seems factually to have become less true
in recent years.  Like her, I believe that the trend may be
irreversible at this point.  However, unless there is some plan
to try to at least partially mitigate the effects of that
change, I think it is important that we recognize and make
adjustments for, not only the incoherency and inconsistencies
she points out, but the changes that dilute the "decisions on
mailing lists" principle.  We should also recognize that
diluting that principle inevitably has negative effects on the
diversity of experience and expertise -- not just demographic
diversity although there might be effects there too-- that end
up being represented in IETF decision-making.

I hope the IETF never has to go down the path of identifying
participants with specific categories of interests and insisting
that participants from all categories be present whenever a
discussion occurs or a decision is made, partially because such
rules are a horribly blunt instrument.  However, other voluntary
(and supposedly open) standards bodies have adopted exactly such
rules when their assortment of barriers to participation and
entry have grown high enough to raise suspicion that they have
become big-player industry cabals and/or are in need of
regulatory oversight and scrutiny from competitiveness and
antitrust authorities.  As things evolve, let's at least be
aware of those risks and make adjustments to our path
accordingly.

    john

--On Sunday, May 31, 2020 13:44 -0800 Melinda Shore
<[email-masked]> wrote:

> On 5/31/20 1:13 PM, Eric Rescorla wrote:
>> I don't think the characterization of this as "pay-to-play"
>> is accurate. You are certainly free to participate in mailing
>> lists, github, etc.
> 
> I'm somewhat troubled by this, as well, tbh.  To the extent
> that the IETF has gradually and effectively moved to having
> decisions made in meetings it would be unfortunate indeed to
> exclude people based on financial circumstances.  I'd like to
> see the decision-making situation fixed but given the history
> of that discussion I think we are where we are, and free
> remote participation provides at least some mitigation.  I
> also tend to think that saying that meeting participation
> isn't necessary because {mailing lists,Github,whatever} is
> incompatible with the insistence that the IETF continue to
> meet because it's not really possible to progress work without
> real-time discussion.  I'll also note that for as long as
> there's been a remote participation option available it's been
> free.  We're now in the odd position of having all-remote
> meetings absorb what used to be "remote participants" into the
> group of "participants," with some consequential side-effects
> (although arguably there are no such things as side-effects,
> just effects).
> 
> I do think this decision has some unintended consequences.
> Scholarships or other subsidy might provide some mitigation
> but would potentially be messy/awkward.  The organization
> is long overdue for some navel-gazing about working methods.
> It's unreasonable to expect perfect consistency but I think
> things have gotten a little more incoherent than they should
> be.
> 
> Melinda

---

From: Michael StJohns <[email-masked]>
Date: Mon, 1 Jun 2020 13:00:06 -0400

Bob et al -

My guess is that the in-person fees were providing at least some subsidy 
for the remote attendees. There are costs to provide the infrastructure 
for recording and streaming each of the sessions (and those include the 
time of the secretariat and other staff to set things up).   My further 
guess is that we have no clue about the actual cost to provide "just 
online" even with all that happened for 107 and that the fee number they 
came up with is nothing more than a good guess which will be refined 
each time we do an on-line only meeting (plus all of the 100+ virtual 
interim/non-interim WG sessions we're still having that have to be paid 
for somehow).

I think the LLC did a good job in balancing conflicting needs by 
providing the possibility of fee waivers.   To be honest, I wish the fee 
waiver were only partial as I think having some skin in the game from 
all of us is important.  I don't remember who said it, but "People don't 
value things they get for free" seems somewhat applicable.

Later, Mike

---

From: Vittorio Bertola <[email-masked]>
Date: Mon, 1 Jun 2020 19:12:10 +0200 (CEST)

> Il 01/06/2020 18:44 John C Klensin <[email-masked]> ha scritto:
> 
> in recent years.  

Indeed, as someone that started attending IETF meetings regularly only in the last few years, I did notice a clear disconnect between what the organization thinks it is and what it seems to be in practice (again, in my limited experience).

Even the continuously restated principle (already twice in this thread) that "people participate as individuals and not representatives of their companies" sounds IMHO a bit hypocritical in 2020. I do not doubt that participants strive to make proposals that represent what's best for the Internet in their view, but what you do and who you work for shape your view a lot. When different parts of the industry have conflicting views, that generally emerges in what their employees say "as individuals" - so there is no practical difference in the end.

I was seriously disconcerted when I realized that people that were replying to me from an anonymous Gmail address, with no signature except their given name, were in fact high ranking officers of some of the biggest companies around. Perhaps this is not perceived as a problem since most people here seem to have known each other for ages, but for people that do not know who is who, this approach is intransparent - a weird form of security by obscurity. It is another barrier to meaningful participation by outsiders.

> aware of those risks and make adjustments to our path

The Internet is now a multi-billion-$currency industry that basically runs the world, and transparency, conflicts of interests, accessibility, diversity, inclusiveness etc should be top concerns when designing mechanisms for participation and deliberation. But the instruments you mention are indeed horribly blunt, so it would be great if this organization found new ways to deal with this in innovative ways.

-- 
Vittorio Bertola | Head of Policy & Innovation, Open-Xchange
[email-masked] 
Office @ Via Treviso 12, 10144 Torino, Italy

---

From: Joseph Touch <[email-masked]>
Date: Mon, 1 Jun 2020 10:16:46 -0700

> On Jun 1, 2020, at 10:12 AM, Vittorio Bertola <vittorio.bertola=[email-masked]> wrote:
> 

Maybe it’s time the Internet started more directly supporting the IETF, on whose backs they profit.

A $1/yr fee on every TLD would more than cover any of our nominal expenses.

Joe

---

From: John Scudder <[email-masked]>
Date: Mon, 1 Jun 2020 17:19:03 +0000

On Jun 1, 2020, at 1:12 PM, Vittorio Bertola <vittorio.bertola=[email-masked]<mailto:vittorio.bertola=[email-masked]>> wrote:

It isn’t just you. I’ve been around awhile, but nobody can know everyone in an organization that regularly draws more than 1,000 in-person attendees, so this affects us all. For my own part, even though it would be more convenient for me to use a gmail or other address for IETF work, I don’t, exactly because I want to be transparent about who’s paying me to do this work. But, while I wish others would be equally transparent, we have no rule about it, and it would probably be difficult to enforce in any case. So we muddle through.

Your point about the practice being a barrier to participation is interesting, though.

—John

---

From: Vittorio Bertola <[email-masked]>
Date: Mon, 1 Jun 2020 19:36:48 +0200 (CEST)

>     Il 01/06/2020 19:16 Joseph Touch <[email-masked]> ha scritto:
> 
> 
> 
> 
> 
>         > >         On Jun 1, 2020, at 10:12 AM, Vittorio Bertola < vittorio.bertola=[email-masked] mailto:vittorio.bertola=[email-masked] > wrote:
> > 
A good part of my annual .org registration fee explicitly goes to support ISOC and the IETF, isn't it? Me and ~10 million other Internet users - there's enough money there to run the IETF multiple times, though I think it's wise that the IETF does not rely only on .org money.

But, from another viewpoint, yours is an argument for increased registration fees, especially for participants from big corporations. If someone profits financially from the IETF's work, it's not the end-user or the average domain name registrant but rather the companies that sell products and services implementing IETF standards.

--

Vittorio Bertola | Head of Policy & Innovation, Open-Xchange
[email-masked] mailto:[email-masked] 
Office @ Via Treviso 12, 10144 Torino, Italy

---

From: Joseph Touch <[email-masked]>
Date: Mon, 1 Jun 2020 10:43:08 -0700

I don’t like registration fees - that’s “pay per vote” or at least devolves to that.

I prefer a “tax” on the Internet itself - and it shouldn’t be just .org - to pay for these things.

I.e., "if you make money from it, you pay for it". Not “if you want to speak on the standards”, you pay.

Other orgs get some of this by licensing the standards; we understandably don’t want to do that.

Joe

> On Jun 1, 2020, at 10:36 AM, Vittorio Bertola <[email-masked]> wrote:
> 
> 
>>> On Jun 1, 2020, at 10:12 AM, Vittorio Bertola < vittorio.bertola=[email-masked] <mailto:vittorio.bertola=[email-masked]>> wrote:
>>> 
> [email-masked] <mailto:[email-masked]>

---

From: Colin Perkins <[email-masked]>
Date: Mon, 1 Jun 2020 19:06:39 +0100

> On 1 Jun 2020, at 17:44, John C Klensin <[email-masked]> wrote:
> 
...
> up being represented in IETF decision-making.

One of the key results of the survey was that time zones are hard, and make scheduling calls to be inclusive very difficult.

I’m not sure mailing lists are necessarily still the right technology, but I do hope that manycouches, and related discussions, will include a focus on effective asynchronous collaboration, and that we won’t fall by default into the mode of endless teleconferences at unsociable hours. 

Colin

---

From: Larry Masinter <[email-masked]>
Date: Mon, 1 Jun 2020 11:14:49 -0700

It’s pretty difficult to bring  an in-person surrogate to disrupt an in-person meeting,

But I think the concern of sponsored disruption of online-only meetings

might be mitigated by requiring payment information.

My understanding is that IETF mailing lists have at times been plagued by disruptions
from pseudonym sock puppets. That wouldn’t be the risk here, I’m just

pointing out the cause for concern.

From: ietf <[email-masked]> On Behalf Of John Scudder
Sent: Monday, June 1, 2020 10:19 AM
To: Vittorio Bertola <vittorio.bertola=[email-masked]>
Cc: IETF Best Practices <[email-masked]>
Subject: Re: Registration details for IETF 108

On Jun 1, 2020, at 1:12 PM, Vittorio Bertola <vittorio.bertola=[email-masked] <mailto:vittorio.bertola=[email-masked]> > wrote:

—John

---

From: John C Klensin <[email-masked]>
Date: Mon, 01 Jun 2020 14:47:34 -0400

Joe,

--On Monday, June 1, 2020 10:43 -0700 Joseph Touch
<[email-masked]> wrote:

> I don't like registration fees - that's "pay per vote"
> or at least devolves to that.

I don't like registration fees.  I also don't like paying for
airfares, hotels, and Internet connections good enough to
support remote participation in meetings.  I would also like
free cookies and perhaps free lunches.  If I didn't know, and
dislike, the costs of keeping ponies, I'd like a pony too. 

The reality is that operating the IETF has costs, those costs
are significant, and _any_ way to cover them has consequences.
To take your earlier suggestion as an example, not only would a
$1/yr fee on every TLD not cover the estimated costs of a single
online meeting (as estimated/reported at
https://www.ietf.org/blog/ietf108-registration-fees/ ), there
are well under 2000 of the puppies so it would provide an order
of magnitude less income than that estimate proposes to recover
from registration fees, much less the costs of more than one
meeting a year, some possibly in person. 

Now, if you were talking about registrations at the second level
and below, that would be a different matter financially, more or
less taxing ICANN from the tax it collects on TLD registries.

More important, at least from my point of view, is the old adage
about paying the pipe.  The domain name sales interests already
have far more influence over the Internet than makes me happy,
partially because they and others and done a good (if sometimes
self-interested) job of convincing much of the population that
domain names, especially TLDs, are far more important than they
probably actually are. 

> I prefer a "tax" on the Internet itself - and it
> shouldn't be just .org - to pay for these things.
> 
> I.e., "if you make money from it, you pay for it". Not "if
> you want to speak on the standards", you pay.

First, much as I have issues with the domain name sales
business, the real "making money from the Internet" business
seem to be those who sell advertising, user data, content, and
more tangible products.   Why pick on name sales or TLDs. 

How would you prevent "if I pay for the standards (because you
make money on the Internet), I expect to have input into, and
oversight of, what the IETF does?

> Other orgs get some of this by licensing the standards; we
> understandably don't want to do that.

Most of them, fwiw, charge annual membership fees and insist on
organizational membership rather than individual participation
(even those that allow for some of the latter as, e.g., "invited
experts").  You probably don't want to go there or do that
either but it turns into another version of "pay to Play" or at
least "pay to vote".

   john

---

From: JORDI PALET MARTINEZ <[email-masked]>
Date: Mon, 01 Jun 2020 21:13:31 +0200

Exactly. As I mention in my previous email, this is not really about "this" meeting, it is about next meetings (in person and online, with and without Covid19), it is about how to cover *all* our expenses.

It is unfair that people that contributes more, pay traveling expenses and attendance fees, and may have similar problems to cover all that cost as people that is participating remotely, which only will need to pay for a registration fee.

How we compensate all the people that have attended meetings for tens of years? In my own case my first meeting was summer 2001, and I never missed one, so I've contributed with about 34.000 USD (just in attendance fees!). For an individual or an SME, this is not the same as for a participant that works for a medium or big size organization, that is covering all the expenses for him/her.

So, this is a discussion about IETF budged in general. It is about what the PIR/.org was created for (cover IETF costs), and if this is sufficient to fund *all the IETF* costs, and reduce the meeting fees for *all* to a very minimum, for both, in-person and online meetings/participants, may be considering what "backup" participants from big organizations have (or as an alternative, providing 1-2 free registration or very low cost fees for each organization and then increase the cost for others, etc.). There are many ways to do that and be fair with people that is contributing vs only "attending".

Regards,
Jordi
@jordipalet

El 1/6/20 17:40, "ietf en nombre de Bob Hinden" <[email-masked] en nombre de [email-masked]> escribió:

    Jason,

    Bob

    >>> [0] I emphasize "real-time" as I expect that the recordings will be available

**********************************************
IPv4 is over
Are you ready for the new Internet ?
http://www.theipv6company.com
The IPv6 Company

This electronic message contains information which may be privileged or confidential. The information is intended to be for the exclusive use of the individual(s) named above and further non-explicilty authorized disclosure, copying, distribution or use of the contents of this information, even if partially, including attached files, is strictly prohibited and will be considered a criminal offense. If you are not the intended recipient be aware that any disclosure, copying, distribution or use of the contents of this information, even if partially, including attached files, is strictly prohibited, will be considered a criminal offense, so you must reply to the original sender to inform about this communication and delete it.

---

From: Joseph Touch <[email-masked]>
Date: Mon, 1 Jun 2020 12:15:17 -0700

> On Jun 1, 2020, at 11:47 AM, John C Klensin <[email-masked]> wrote:
> 
> Joe,
> 

I should have said “membership”; registration for events is different, understandably.

> domain names, especially TLDs, are far more important than they

Agreed. There are other sources - annual per-IP costs, etc. The trick - as always - is correlating the benefit to the cost. NATs undermine that for IP addresses, e.g.

> more tangible products.   Why pick on name sales or TLDs. 

I was giving an example. Glad to hear other alternatives.

> oversight of, what the IETF does?

They already do - as a side-effect of needing to have 80% support for many IETF leadership roles.

> least "pay to vote”.

That’s the example I started with that I do want to avoid.

But ultimately, making those who create value pay to do so is backwards.

Joe

---

From: Behcet Sarikaya <[email-masked]>
Date: Mon, 1 Jun 2020 14:16:21 -0500

On Mon, Jun 1, 2020 at 11:23 AM Lixia Zhang <[email-masked]> wrote:

> have had to cover IETF meeting costs since 1992, and presumably longer, so
> I don't find this shocking. But for the longer term, we do need to think
> about how this interacts with the goal of "any interested person can
> participate in the work, know what is being decided, and make his or her
> voice heard" [RFC3935].
> >
> > Regards
> >    Brian
>
> 2/ if this cost needs to be covered by meeting participants: this
> conflicts with "any interested person can participate in the work" for free.
>
> 3/ for academic conferences: online conf. registration is so much lower
> now (e.g. one used to be $700/person, now $100/person), plus no travel
> cost, this makes it a lot more more affordable, potentially attract a
> higher attendance.
>
> 4/ as a central principles of the IETF, people participate as individuals,
> not representatives of their companies, this seems to argue for
> consideration of moving meeting registration fees, or more general IETF
> participation fees, towards a model as personal professional cost (e.g.
> IEEE or ACM membership fees), of course only if it can be made affordable.
> bottom line: it is so unfortunate there is no free lunch. C19 pandemic
> brought the issue on the table: We cannot have both "everyone can
> participate" and "for free" in the same sentence.
>
>
I agree.
I find the fee as proposed to be too high and unjustifiable especially for
people who can not get the fee reimbursed.
There should be a different way to do this.

Regards,
Behcet

---

From: Andrew Sullivan <[email-masked]>
Date: Mon, 1 Jun 2020 15:31:17 -0400

Hi,

Speaking with my Internet Society hat on.

On Mon, Jun 01, 2020 at 09:13:31PM +0200, JORDI PALET MARTINEZ wrote:

> It is about what the PIR/.org was created for (cover IETF costs), and if this is sufficient to fund *all the IETF* costs

The Internet Society is a proud and eager supporter of the IETF, and we are committed to continuing that for as long as the IETF wants it to happen.  This year, the support is to the tune of $5M, and we are in the process of working with the LLC management to see what it should be in the future (as was envisioned in the LLC agreement).  I nevertheless do not believe that PIR or .ORG was created to "cover" IETF costs (especially, all the IETF costs).  If you have some evidence to show that it _was_ created for that, I would be interested to see it. 

Best regards,

A

-- 
Andrew Sullivan
President & CEO, Internet Society
[email-masked]
+1 416 731 1261

---

From: John C Klensin <[email-masked]>
Date: Mon, 01 Jun 2020 15:42:32 -0400

--On Monday, June 1, 2020 13:00 -0400 Michael StJohns
<[email-masked]> wrote:

>...
> I think the LLC did a good job in balancing conflicting needs
> by providing the possibility of fee waivers.   To be honest,
> I wish the fee waiver were only partial as I think having some
> skin in the game from all of us is important.  I don't
> remember who said it, but "People don't value things they get
> for free" seems somewhat applicable.

And that is one of two closely-related reasons why a few of us
have been suggesting for years that remote participants pay at
least a nominal registration fee.  The other is that payment
typically provides a small measure of authentication.

   john

---

From: Jay Daley <[email-masked]>
Date: Tue, 2 Jun 2020 09:27:03 +1200

Replying to multiple different things:

1.  The decision on registration fees is mainly an LLC one so please send any feedback to me.  

2.  It looks like some people are not aware that we have published a blog post explaining how the fee was set:

	https://www.ietf.org/blog/ietf108-registration-fees/

3.  The choice of 100 fee waivers was based on conversations with sponsors who want to fund the fee waivers specifically.  It was not chosen on any assessment of the potential need.

4.  The decision on how to allocate fee waivers is for the IESG not the LLC and I will leave it to them to explain their thinking behind a random draw rather than "criteria-based case-by-case decision making".

5.  This decision was not trailed on May 14 because there was still a lot of work to be done on the finances - budgets, sponsorship, insurance, etc - to understand *if* we had to charge a fee and what level that should be at, and we did not want to delay an announcement until that was complete.  The current situation demands that we do a lot of work in a short time and some compromises need to be made when deciding what to say when.

6.  We did not consult on this because there is not enough time for an effective consultation.  It would probably have been worse to have asked people their views and then said sorry we don’t have enough time to change anything.  

7.  The policy about what we charge for was set a long time ago - meeting registration fees are set to cover more than just the cost of the meeting, they also contribute towards the cost of running the IETF in-between meetings.  See https://mailarchive.ietf.org/arch/msg/ietf-announce/JUByvYCkSb2WDSt9h4lDkaoe9gc/ for one historic mention of that.  If the community wants that changed then the LLC will build a new budget accordingly, but I suggest that is discussed in the context of the overall financial structure of the IETF and how that relates to the aspirations of the IETF for participation, rather than just in the context of meeting finances.

While this pandemic feels like it has been with us for a long time, we are still working in exceptional circumstances and having to make decisions where there is limited consensus community guidance as these are circumstances that were only partially foreseen.  If the community wants to pick this up then more consensus community guidance around this would be very welcome, particularly if it is ready in plenty of time for IETF 109 in case that also needs to be switched to an online meeting.

If there are any questions I’ve missed then please let me know.

Jay

-- 
Jay Daley
IETF Executive Director
[email-masked]

---

From: Jay Daley <[email-masked]>
Date: Tue, 2 Jun 2020 10:14:39 +1200

A few detailed questions here I didn’t answer in my consolidated response:

> On 2/06/2020, at 4:37 AM, Robert Raszuk <[email-masked]> wrote:
> 

> Does it also extend to interim meetings ? 

Ability to attend all sessions that are scheduled as part of IETF 108.  The agenda is still to follow and the decision on what is part of IETF 108 and what is not is for the IESG.

> Would it still apply when onsite meetings start to happen ? 

No decision has been made about that.

> 
> What if chairs will call-up an informal zoom or google meet session without any fees ? Will they be fired from chair positions of a WG ? 

That is a question for the IESG.

> 
> Would we also start to see charges for participation in email lists ? Or charge per email sent ? 

There are no plans for that nor is it under discussion.

> And last would recordings of the meetings be available for free ? 

Yes, recordings and proceedings would continue to be available for free.

Jay

> 
> Depends on those answers I guess this may be very well the beginning of email based standards process even further discouraging those not associated with any big vendor/sponsor to participate. 
> 
> Kind regards,
> Robert
> 
> 

-- 
Jay Daley
IETF Executive Director
[email-masked]

---

From: "Adrian Farrel" <[email-masked]>
Date: Mon, 1 Jun 2020 23:21:47 +0100

Thanks for the clarity, Jay.

Money comes into the pot and money goes out of the pot.

It seems that meeting sponsorship is ring-fenced for meeting costs, but meeting fees are applied more generally. Is that true?

Thanks,
Adrian

-----Original Message-----
From: ietf <[email-masked]> On Behalf Of Jay Daley
Sent: 01 June 2020 22:27
To: ietf <[email-masked]>
Subject: Re: Registration details for IETF 108

Jay

-- 
Jay Daley
IETF Executive Director
[email-masked]

---

From: Jay Daley <[email-masked]>
Date: Tue, 2 Jun 2020 10:33:48 +1200

> On 2/06/2020, at 10:21 AM, Adrian Farrel <[email-masked]> wrote:
> 

No.  In our accounting, no money is ring-fenced this way.

Jay

-- 
Jay Daley
IETF Executive Director
[email-masked]

---

From: Stephen Farrell <[email-masked]>
Date: Mon, 1 Jun 2020 23:39:03 +0100

Hiya,

> No decision has been made about that.

Would it be sensible to promise/ensure that a community
discussion that determines direction, within the bounds
of practicality, precedes, rather than follows, that
decision? FWIW, I think it would and it's important that
that be the case. IOW, let's sort out our approach to
this before the timeframe of IETF109.

It might or might not be a nit but while the detailed level
of reasonable meeting fee is properly an LLC operational
matter, the distinction between zero vs. non-zero fees for
remote participants is IMO very much not an LLC matter and
definitely does require community consensus.

Cheers,
S.

---

From: Jay Daley <[email-masked]>
Date: Tue, 2 Jun 2020 10:50:11 +1200

> On 2/06/2020, at 10:39 AM, Stephen Farrell <[email-masked]> wrote:
> 
> 
> Hiya,
> 

It would be excellent if that could happen.

> definitely does require community consensus.

I would say that it should be covered by community consensus but as it isn’t and we have limited time to plan then it falls on the LLC to fill the gap as an interim measure.  From my perspective the sooner the community provides guidance the better, though I should repeat my suggestion that this discussed in the context of the overall financial structure of the IETF (i.e. what we charge for and why) and how that relates to the aspirations of the IETF for participation, rather than just in the context of meeting finances.

Jay

> <0x5AB2FAF17B172BEA.asc>

-- 
Jay Daley
IETF Executive Director
[email-masked]

---

From: Stephen Farrell <[email-masked]>
Date: Tue, 2 Jun 2020 00:19:20 +0100

Hiya,

On 01/06/2020 23:50, Jay Daley wrote:
>> Would it be sensible to promise/ensure that a community discussion
>> that determines direction, within the bounds of practicality,
>> precedes, rather than follows, that decision? FWIW, I think it
>> would and it's important that that be the case. IOW, let's sort out
>> our approach to this before the timeframe of IETF109.
> 

Agreed. I take it that means we'll all try make that
happen and that there'll be a discussion of this before
IETF109. (Hopefully that discussion will be done ahead
of the meeting date, but yeah, that might not happen;-)

> 
>> 
>> It might or might not be a nit but while the detailed level of
>> reasonable meeting fee is properly an LLC operational matter, the
>> distinction between zero vs. non-zero fees for remote participants
>> is IMO very much not an LLC matter and definitely does require
>> community consensus.
> 
> I would say that it should be covered by community consensus 

Sorry, I guess I was unclear. In the above I was trying to
say that I think the longer term zero vs. non-zero decision
requires community consensus. It's understandable if short-
term problems get in the way of that, but not ok that those
short-term issues trump the need for community consensus.

Cheers,
S.

> but as
> it isnâ€™t and we have limited time to plan then it falls on the LLC
> to fill the gap as an interim measure.  From my perspective the
> sooner the community provides guidance the better, though I should
> repeat my suggestion that this discussed in the context of the
> overall financial structure of the IETF (i.e. what we charge for and
> why) and how that relates to the aspirations of the IETF for
> participation, rather than just in the context of meeting finances.
> 
> Jay
> 
>> 
>> Cheers, S.
>> 
>> 
>> 
>> <0x5AB2FAF17B172BEA.asc>
>

---

From: "John Levine" <[email-masked]>
Date: 2 Jun 2020 01:03:08 -0000

In article <[email-masked]>,
>No.  In our accounting, no money is ring-fenced this way.

For anyone who's interested, the budget and actual numbers are here:

https://ietf.org/about/administration/financial-statements/

In past years, meetings usually ran a surplus that helped to pay for
the IETF's other expenses, but now it's closer to break even.

As the financial statements show, the 2019 budget forecast a $100K
surplus of meeting revenue over income. The actual meeting surplus was
abour $500K due mostly to lower than expected costs. The pre-COVID
2020 budget forecast had a meeting deficit (less revenue than expense)
of about $300K. Of course now, it's anyone's guess and I do not envy
Jay the job of staying on top of it.

R's,
John

-- 
Regards,
John Levine, [email-masked], Primary Perpetrator of "The Internet for Dummies",
Please consider the environment before reading this e-mail. https://jl.ly

---

From: S Moonesamy <[email-masked]>
Date: Mon, 01 Jun 2020 20:54:17 -0700

Hi Jason,
>(not speaking for the IETF LLC - personal view)

The latest monthly statement available is from February.  I'll skip 
asking about that.  What the IETF has is an eight figure LLC running 
on an accounting system.  The RSM report is quite interesting.

Regards,
S. Moonesamy

---

From: Jay Daley <[email-masked]>
Date: Tue, 2 Jun 2020 17:55:59 +1200

> On 2/06/2020, at 4:23 PM, S Moonesamy <[email-masked]> wrote:
> 
> Hi Jason,
> The latest monthly statement available is from February.  I'll skip asking about 

We have not closed the March accounts due to the complexities of accounting for the cancelled IETF 107 meeting. For example, we reimbursed flights for a number of contractors who have been trying to claim refunds and we need to show that properly in the accounts.  I hope to have it published this week. 

>  What the IETF has is an eight figure LLC running on an accounting system. 

Could you explain the reference to an accounting system? It sounds as if you are suggesting we run the LLC without an accounting system but that would be a disaster so I must have misunderstood. 

> The RSM report is quite interesting.

Yes indeed. It is always reassuring to read an unqualified, clean audit. 

Jay

-- 
Jay Daley
IETF Executive Director
+64 21 678840

---

From: "Mehmet Ersue" <[email-masked]>
Date: Tue, 2 Jun 2020 13:44:10 +0300

> 6.  We did not consult on this because there is not enough time for an effective consultation.  It would probably have been worse to have asked people their views and then said sorry we don’t have…

This is ridiculous as a reason. This is not the usual practice at the IETF I know.
We do discuss openly and develop a consensus after understanding the reasons and consequences.
If it is too late and there is no time to discuss the appropriate decision would be to defer such a new rule on fees.
I wonder whether LLC responsibles are indeed capable to manage such an important and international organization.

BR,
Mehmet

> Sent: Tuesday, June 2, 2020 12:27 AM
> To: ietf <[email-masked]>
> 3.  The choice of 100 fee waivers was based on conversations with sponsors
> who want to fund the fee waivers specifically.  It was not chosen on any
> assessment of the potential need.
> 
> 4.  The decision on how to allocate fee waivers is for the IESG not the LLC and
> I will leave it to them to explain their thinking behind a random draw rather
> than "criteria-based case-by-case decision making".
> 
> 5.  This decision was not trailed on May 14 because there was still a lot of
> work to be done on the finances - budgets, sponsorship, insurance, etc - to
> understand *if* we had to charge a fee and what level that should be at, and
> we did not want to delay an announcement until that was complete.  The
> current situation demands that we do a lot of work in a short time and some
> compromises need to be made when deciding what to say when.
> 
> 6.  We did not consult on this because there is not enough time for an
> effective consultation.  It would probably have been worse to have asked
> people their views and then said sorry we don’t have enough time to change
> anything.
> 
> 7.  The policy about what we charge for was set a long time ago - meeting
> registration fees are set to cover more than just the cost of the meeting,
> they also contribute towards the cost of running the IETF in-between
> meetings.  See https://mailarchive.ietf.org/arch/msg/ietf-
> announce/JUByvYCkSb2WDSt9h4lDkaoe9gc/ for one historic mention of that.
> If the community wants that changed then the LLC will build a new budget
> accordingly, but I suggest that is discussed in the context of the overall
> financial structure of the IETF and how that relates to the aspirations of the
> IETF for participation, rather than just in the context of meeting finances.
> 
> 
> While this pandemic feels like it has been with us for a long time, we are still
> working in exceptional circumstances and having to make decisions where
> there is limited consensus community guidance as these are circumstances
> that were only partially foreseen.  If the community wants to pick this up
> then more consensus community guidance around this would be very
> welcome, particularly if it is ready in plenty of time for IETF 109 in case that
> also needs to be switched to an online meeting.
> 
>

---

From: Eric Rescorla <[email-masked]>
Date: Tue, 2 Jun 2020 05:57:02 -0700

On Tue, Jun 2, 2020 at 3:45 AM Mehmet Ersue <[email-masked]> wrote:

> If it is too late and there is no time to discuss the appropriate decision
> would be to defer such a new rule on fees.
>

This seems like entirely appropriate practice on short notice. I would note
that the LLC regularly makes decisions which involve a far larger change to
people's costs than the fees -- namely, where to site the meeting --
without consultation, so I while I think it would be good for the LLC to
get feedback on this topic, I don't think there's inherently an obligation
to put it to a community wide call for consensus.

Moreover, as Jason points out, the IETF has charged attendance fees for
some time, so one could view this as a decision to *reduce* fees, in light
of the virtual status.

-Ekr

---

From: Nick Hilliard <[email-masked]>
Date: Tue, 2 Jun 2020 14:16:13 +0100

Eric Rescorla wrote on 02/06/2020 13:57:
> This seems like entirely appropriate practice on short notice.

neither side's position seems unreasonable from their own point of view: 
the LLC needs to make executive decisions and sometimes these will be 
problematic. Conversely, the IETF community has an expectation that 
there's engagement about policy changes before they happen.

We're all hostage to our own constraints.

The challenge now is to resolve this, i.e. how to discuss it without 
prejudice and come up with something that's workable within the 
financial constraints of the LLC while still being compatible with 
community process.

Nick

---

From: Eric Rescorla <[email-masked]>
Date: Tue, 2 Jun 2020 06:27:56 -0700

> there's engagement about policy changes before they happen.

Hmm... This doesn't seem like the right framing to me in several respects:

First, I think everyone agrees that some kinds of policy changes would need
consultation. For instance, if the LLC were to decide that in perpetuity we
were not to havemeetings or that we were to have 6 a year, that would
clearly need consultation. On the other hand, I (would hope) that everyone
agrees that some changes could be made by executive  decision. For
instance, moving the refund date forward or back by a day would I hope not
require community consultation. So the question at hand is what kind of
decision this is.

Second, as you can see from the thread above, it's not correct that "the
iETF community" has an expectation they should have been consulted about
this in advance. Rather, part of the IETF community does and some of it
thinks this was fine.

-Ekr

---

From: Stephen Farrell <[email-masked]>
Date: Tue, 2 Jun 2020 15:12:33 +0100

Hiya,

> some time, so one could view this as a decision to *reduce* fees, in light

While I think having the discussion in the context of
IETF109 and future meetings is ok, I don't think the
above is even close to correct. A change from zero to
non-zero cost is a policy change and not IMO within
the LLC's power to decide, except in an emergency case
as seems to still be the case for IETF108.

Cheers,
S.

---

From: "John Levine" <[email-masked]>
Date: 2 Jun 2020 15:21:19 -0000

In article <CABcZeBOLAw_9s-gobFYB=[email-masked]>,
>to put it to a community wide call for consensus.

Agreed. The IETF works within financial constraints, and a large part
of the LLC's job is to balance what we want to do with the resources
we have. Unilaterally making 108 free for everyone would blow a large
hole in our budget (there are still expenses even without a physical
meeting) and we can't just decree it.

R's,
John

---

From: Phillip Hallam-Baker <[email-masked]>
Date: Tue, 2 Jun 2020 12:03:39 -0400

On Tue, Jun 2, 2020 at 9:29 AM Eric Rescorla <[email-masked]> wrote:

> First, I think everyone agrees that some kinds of policy changes would
> need consultation. For instance, if the LLC were to decide that in
> perpetuity we were not to havemeetings or that we were to have 6 a year,
> that would clearly need consultation. On the other hand, I (would hope)
> that everyone agrees that some changes could be made by executive
> decision. For instance, moving the refund date forward or back by a day
> would I hope not require community consultation. So the question at hand is
> what kind of decision this is.
>

Indeed in this particular case, there are no alternative choices available
and thus no decision to be made.

I have spent far too much time over the past four years explaining to my
former Oxford friends that reality isn't something you decide by
referendum. Reality isn't subject to consensus calls either.

The brute facts we face are that international travel is certain to be
infeasible for the remainder of the year and quite likely for some time
beyond, that the IETF business model is predicated on income from in-person
meetings that can't now take place and this leaves few options on the table.

Making standards is fundamentally a process of making the choices that
don't matter - except to the extent it matters that we all do the same
thing. In this case they aren't even really choices.

> this in advance. Rather, part of the IETF community does and some of it

Rather than 'fine', I would use the word 'unavoidable'.

---

From: Phillip Hallam-Baker <[email-masked]>
Date: Tue, 2 Jun 2020 12:11:34 -0400

On Tue, Jun 2, 2020 at 11:22 AM John Levine <[email-masked]> wrote:

> In article <CABcZeBOLAw_9s-gobFYB=
> [email-masked]>,

Had ISOC been allowed to dispose of the PIR without the political meddling,
it would of course have been able to do exactly that, and could have been
expected to.

But it wasn't and while it probably still could we can't expect that it
should. Which means that because some folk decided to fund raise off the
risk that the minority of non profits holding .org names might end up
paying one or two dollars a year extra, the one non-profit the PIR is
actually supposed to fund now continues to face a massive concentrated
position in its portfolio.

---

From: Spencer Dawkins at IETF <[email-masked]>
Date: Tue, 2 Jun 2020 11:40:24 -0500

To the community, not just to Jay,

I'm current on the mail thread as of when I hit "reply all", but am
replying here because that's point in the discussion I had an opinion
about.

> It would be excellent if that could happen.

Speaking only for myself, my IETF 107 wasn't actually canceled all at once,
but enough working group chairs and research group chairs canceled meetings
that I probably should have requested refunds then, instead of waiting for
the IESG's pronouncement. I might have still gone to Vancouver if the IESG
hadn't canceled the face-to-face meeting, but it would have been to show
support for the organization, not to get specific work done.

See the discussion about whether working groups have an incentive to meet
during IETF virtual meeting weeks for more details, but the community
really does have a lot of influence on the decision to resume in-person
meetings, whether anyone else thinks they do, or not.

So, I'm reading Stephan's point about IETF 109 as "if the community is
going to have an opinion about whether IETF 109 is virtual, we should
probably start that discussion, like, now". Did I misread that?

If I'm good so far, my questions are
on this mailing list, or elsewhere?
who's sending the first e-mail to start the discussion?

Best,

Spencer

---

From: Phillip Hallam-Baker <[email-masked]>
Date: Tue, 2 Jun 2020 13:15:08 -0400

On Tue, Jun 2, 2020 at 12:41 PM Spencer Dawkins at IETF <
[email-masked]> wrote:

> Speaking only for myself, my IETF 107 wasn't actually canceled all at
> once, but enough working group chairs and research group chairs canceled
> meetings that I probably should have requested refunds then, instead of
> waiting for the IESG's pronouncement. I might have still gone to Vancouver
> if the IESG hadn't canceled the face-to-face meeting, but it would have
> been to show support for the organization, not to get specific work done.
>

There is a discussion of sorts on manycouches. I don't quite have time for
that at the moment (working on a technical proposal).

Having a discussion of anything related to IETF 108 is pointless because
there were no real decisions to be made. Discussion of 109 seems much more
to the point as there are still options open.

The constraint with 109 is that while the IETF can decide NOT to have the
meeting, it cannot decide that it will. There are too many other factors
involved. Not least among them the likelihood that many of us may be
unemployed by then. The notion that the winds blowing through the rest of
the economy won't affect tech seems somewhat optimistic to me.

What we can usefully discuss is:

* Is it better to decide to cancel now rather than continue in an uncertain
state.?
* Does it make sense to concentrate meetings in a single week with the
inevitable scheduling conflicts that then arise?
* What sort of work does and does not work at remote meetings?
* How far do we want the IETF community to extend?

The last one is something that I think people should think about seriously.
One of the big drawbacks to IETF for many network related groups was the
cost of participation: Three in person meetings a year. Thats more than
most folk working on open source apps can afford.

Consider the following scenario: IETF moves to schedule with one in person
meeting and two virtuals a year with most of the WG effort taking place in
bi-weekly interims. At that point the cost of participation in IETF is
lower than OASIS or W3C. And maybe IETF becomes an attractive venue for a
lot of efforts that it isn't attractive for at the mo.

And that then gets us into further consideration of the role of the
secretariat, IESG, RFCs and so on. How much control do we actually want?
The IETF is rather strange in that the constitution gives the IESG the
highest level of direct involvement in WG decisions and the least
accountability to the membership (none, the membership cannot appoint or
remove and isn't even recognized as a membership).

Now we are at the point where it is impossible to carry on as in the past,
it seems now is a good time to think about how we think we should carry on.

---

From: S Moonesamy <[email-masked]>
Date: Tue, 02 Jun 2020 12:11:31 -0700

Hi Jay,
At 10:55 PM 01-06-2020, Jay Daley wrote:
>We have not closed the March accounts due to the complexities of 
>accounting for the cancelled IETF 107 meeting. For example, we 
>reimbursed flights for a number of contractors who have been trying 
>to claim refunds and we need to show that properly in the 
>accounts.  I hope to have it published this week.

I forgot why I was looking for the monthly statements.  Thanks for 
explaining why the publication was delayed.

>Could you explain the reference to an accounting system? It sounds 
>as if you are suggesting we run the LLC without an accounting system 
>but that would be a disaster so I must have misunderstood.

There is usually some framework between to ensure that the LLC does 
not run into trouble.   It is, in simple terms, to ensure that the 
money is not being abused.  It could also help to lessen your 
workload (that is a guess as I don't have visibility of what you do).

Regards,
S. Moonesamy

---

From: Ted Hardie <[email-masked]>
Date: Tue, 2 Jun 2020 13:44:41 -0700

Howdy,

> as seems to still be the case for IETF108.
I think "policy change" might be true, thought I think we disagree on the
level of that change. I am sure we disagree, though, with the implication
that it is outside the purview of the IETF LLC to make that change.

To illustrate what I mean, I'd like to look first at two different
changes.  The IETF requiring registration to use the facilities for remote
participation was a policy change for the standards process, because it
formalized the understanding that those participants are part of the
standards making bits when they're engaged in the meeting (thus subject to
note well and our other policies).  I think it was an appropriate change,
because the facilities permitted contributions, rather than simply allowing
folks to listen in (as multicast audio had before).  Because it is at its
core a standards process issue, having the IESG in the thick of that
decision made sense.  That's their remit.

On the far side of that were the changes that the IAOC brought in in 2018
when Andrew was chair, to change the timing of "early bird" and "standard"
registrations.  There is no change in the status of those registrations as
a result, just a change in when you pay to get different discounts.  The
IAOC put forward a draft policy and requested community feedback on it,
then implemented the change.  That was their remit--how and when to collect
the fees.

The IETF LLC, as the successor the IAOC in the IASA seat, has a similar
remit.  It has to set both the per meeting fee and the timing of
collection.  You appear to be arguing that moving from zero to any number
for a particular class of participants effectively excludes some of those
participants from the standards process and because that would be a
standards process change, that would pull it from their bailiwick.  But
zero isn't a magic number here.  Had they moved it to $1, would those
people be excluded?  Had they moved it to €2, would those people be
excluded here?   How about 10 of the lowest denomination currency for the
home country of the participant?  The reality is that it's a balance
between finding the number that enables the standards process to run
effectively and the number that enables the organization to continue to
house the standards process.  It's always been that balance and there are a
host of choices (e.g. the currency in which to accept registrations) which
effect it.  And it has been the IASA folks (currently, the LLC) who have to
make the choices of where to put the balance.

That doesn't mean that there isn't a public process for feedback and input;
just like the changes that Andrew put forward in 2018, there should be
public discussion of a draft plan.  I'm sure any implementation of the plan
will also get analyzed post-facto and changes made in light of the lessons
learned.  But it is, at least at the moment, the LLC who are supposed to
take that feedback and learn those lessons.  They are the stuckees for this
type of decision, and they are charged with making it with the health of
the whole organization in mind.  We gave that body those responsibilities,
and this decision goes along with that.

That's my take on it any case,

regards,

Ted Hardie

---

From: Stephen Farrell <[email-masked]>
Date: Tue, 2 Jun 2020 21:55:57 +0100

Hiya,

On 02/06/2020 21:44, Ted Hardie wrote:
> You appear to be arguing that moving from zero to any number
> standards process change, that would pull it from their bailiwick. 

No. I'm arguing that the move from zero to non-zero ought
be an IESG decision, based on community discussion. That's
not only because it might exclude people but also because
such changes can have longer term and subtle effects. One
already pointed out on the wg chairs list is that this
may create an incentive to have virtual interims for WGs
outside the IETF meeting week, as those don't have a fee.
That could be good, bad or indifferent in terms of the
standards process.

To be clear: I'm not now arguing that remote participation
ought not have a fee. I might make that argument later in a
discussion about policy for IETF109 and beyond but my
argument here is solely about who gets to set the policy. I
do not believe that ought be the LLC. (But can live with
IETF108 as an exception.)

Cheers,
S.

---

From: "Pete Resnick" <[email-masked]>
Date: Tue, 02 Jun 2020 16:05:21 -0500

On 2 Jun 2020, at 15:55, Stephen Farrell wrote:

> such changes can have longer term and subtle effects.

Yep. Ted, would your opinion be different if the LLC chose to move from 
zero to non-zero for sending email to mailing lists?

pr
-- 
Pete Resnick https://www.episteme.net/
All connections to the world are tenuous at best

---

From: Jay Daley <[email-masked]>
Date: Wed, 3 Jun 2020 09:11:16 +1200

> On 3/06/2020, at 7:11 AM, S Moonesamy <[email-masked]> wrote:
> 
> Hi Jay,
> I forgot why I was looking for the monthly statements.  Thanks for explaining why the publication was delayed.
> 
> There is usually some framework between to ensure that the LLC does not run into trouble.   It is, in simple terms, to ensure that the money is not being abused.  It could also help to lessen your workload (that is a guess as I don't have visibility of what you do).

I see - you are unclear as to what financial controls the LLC has in place.  To summarise, there are the following elements to our financial control framework:

1.  The board approves a budget on an annual basis, which is the base control for what can be spent on what.

2.  The board maintains a documented set of delegations to the Executive Director - how much I can spend on what, within the constraints of the budget, and any special controls around that.

3.  The board approves a financial policy that is made up of multiple process and controls.  Most notably, it is the financial policy that specifies the separation of duties, which are the operational checks and balances necessary to prevent fraud.

4.  The board receives a monthly financial report prepared directly by the accountants independently of the Executive Director. 

5.  Every year the accounts are audited by an independent firm of auditors who carry out a range of tests to detect fraud or unintentional financial problems.  That report is then presented directly to the board and the auditors meet with the board without the ED present.

The delegations referenced in 2 and the policy referenced in 3 will be published at some point, hopefully soon.  This is waiting on the completion of a review of the financial policy triggered by our switch in accountancy firms and delayed by the pandemic.  

Please feel free to ask for such information directly rather by allusion, as that is easier for me to pick up on.

Jay

-- 
Jay Daley
IETF Executive Director
[email-masked]

---

From: Ted Hardie <[email-masked]>
Date: Tue, 2 Jun 2020 14:16:19 -0700

Howdy,

> That could be good, bad or indifferent in terms of the

And the decision by the IESG on the timing of the interim will have an
impact on registration and thus on revenue; clearly the two groups (LLC and
IESG) should talk to each other (and the wisdom of having an IESG appointed
member to ensure that is pretty evident).

But somebody has to be the stuckee for the decision on the money side of
that, and at the moment it is the LLC.  Having been on the IESG before the
IASA process, when the IESG did all of that, I will personal object to any
effort to shove that level of decision back on the IESG plate.  The money
side moved onto a different set of plates for darn good reasons, and it
shouldn't move back.

Things were pretty plain on IETF 107:  the IESG decided to cancel the
meeting when it was no longer going to be an effective meeting (standards
issue), but the logistics of financing stayed with the LLC.

> IETF108 as an exception.)
The LLC is not a separate body from the IETF--it's the part of the
leadership with this set of responsibilities.  Like the rest of the IETF,
there are times when their role requires public consultation and an
assessment of consensus.   I hope you'll both trust them to do that right
and recognize that if we give them the responsibility for that job, we
ought to give them the relevant authority.

regards,

Ted

---

From: Ted Hardie <[email-masked]>
Date: Tue, 2 Jun 2020 14:19:55 -0700

Howdy,

> zero to non-zero for sending email to mailing lists?
I think you're asking a different question than the one Stephen and I
disagree about ("What do I think of this policy") rather than ("Who is the
stuckee for making this type of policy"?).  To answer the question you
asked, if any body in IETF leadership tried to make it the policy of the
IETF to charge for sending mail to mailing lists, I would oppose that
specific policy.

I think my answer to Steven is pretty clear on the question you didn't ask;
let me know if you disagree.

Ted

pr

---

From: Stephen Farrell <[email-masked]>
Date: Tue, 2 Jun 2020 22:25:06 +0100

Hiya,

I think this bit is where our disagreement is most clear:

On 02/06/2020 22:16, Ted Hardie wrote:
> that, and at the moment it is the LLC. 

The move from zero to non-zero is not "on the money
side" as the status-quo involves no fee. (Ignoring
the exception that will be IETF108.)

FWIW, this discussion is convincing me more that
the LLC definitely ought not be setting such policies.

S.

---

From: "Pete Resnick" <[email-masked]>
Date: Tue, 02 Jun 2020 16:26:23 -0500

On 2 Jun 2020, at 16:19, Ted Hardie wrote:

> On Tue, Jun 2, 2020 at 2:05 PM Pete Resnick 
> <[[email-masked]](<mailto:[email-masked]>)> wrote:
>
>>  Ted, would your opinion be different if the LLC chose to move from 
> disagree about ("What do I think of this policy") rather than ("Who is 
> the stuckee for making this type of policy"?). 

No, I was asking about the stuckee. It sounded to me in your original 
message that since all meeting operation was in their remit, therefore 
pricing of remote-access to meetings was in their remit. I am asking, 
since email operation is in their remit, whether pricing for email 
access is in their remit.

> I think my answer to Steven is pretty clear on the question you didn't 
> ask; let me know if you disagree.

It wasn't to me. That's why I asked.

pr

---

From: Brian E Carpenter <[email-masked]>
Date: Wed, 3 Jun 2020 09:39:50 +1200

Fully agree with Stephen on this. It's very clear to me that a
*permanent* change to charging for remote listening to meetings,
and for remote speaking in meetings, is a fundamental change
of standards-making policy and it's clear to me that consensus
on such a change has to be called by the same mechanism as a change
to RFC2026, i.e. by the IESG.

It also seems clear that the LLC has a part to play in the discussion,
such as laying out the facts of life (remote meetings cost money). 
Once the principle is decided, it seems like the LLC's job to set the
level of the fees. 

Regards
   Brian

---

From: Ted Hardie <[email-masked]>
Date: Tue, 2 Jun 2020 14:41:23 -0700

On Tue, Jun 2, 2020 at 2:25 PM Stephen Farrell <[email-masked]>
wrote:

> Well, we agree that we disagree.  From my perspective, zero is not a magic
number, and the status quo is not doctrine.  Both, in the case, are part of
a balancing act that goes into making sure the IETF works both for a
meeting and for the long term.  Handing financial responsibility for that
without the relevant authority is an invitation to silly states.

> the LLC definitely ought not be setting such policies.
And you are convincing me that attempting to settle it on the IETF list
will require somebody to judge consensus, since there look to be a minimum
of two people with the time and keyboards available to disagree.  We
apparently, however, disagree on who that should be.

best,

Ted

---

From: Ted Hardie <[email-masked]>
Date: Tue, 2 Jun 2020 14:48:58 -0700

On Tue, Jun 2, 2020 at 2:26 PM Pete Resnick <[email-masked]> wrote:

> Then let me answer both questions at once, then:  If the IESG attempted to
impose such a silly fee, I would tell them they were out of bounds.  If the
LLC did, I would tell them not to be so silly*.

> It wasn't to me. That's why I asked.
I hope that was clear,

regards,

Ted

*At one time the IETF worked on hashcash type anti-SPAM measures (Cullen's
work on computational puzzles in SIP springs to mind) and there is one
parallel universe at least where they succeeded enough that proof-of-work
ended up making sense for email anti-spam systems.  Attempting to use that
in such a parallel universe might be an operational enough decision to fall
to the LLC.  But using the fees such a process generated (if any) to fund
the IETF would still be wrong-headed, and I expect that universe's me would
say so.

---

From: Stephen Farrell <[email-masked]>
Date: Tue, 2 Jun 2020 22:56:49 +0100

> apparently, however, disagree on who that should be.

Perhaps not! If you do agree that consensus calling is
required that seems to imply the LLC is not the one to
do that. We have a bunch of 14 victims already setup
to do just that:-)

Cheers,
S.

---

From: Ted Hardie <[email-masked]>
Date: Tue, 2 Jun 2020 15:11:48 -0700

> do that. We have a bunch of 14 victims already setup
I think the LLC can call consensus on a matter within their remit (just as
the IAOC evaluated the feedback on the registration date change policy that
I referenced many messages ago).  So, I think they are the victims set up
to do that in this case.

Since you referenced the magic number 14, I conclude we still disagree.

I think we do agree that there should be public discussion.  I think we do
agree that the LLC and IESG should talk to each other about the
implications of different strategies to both the ongoing work of the IETF
and its financial future.  I think we do agree that any conclusion would be
revisited in the light of evidence of how it ends up working.

But our disagreement on on who the stuckee is remains.

regards,

Ted

---

From: Stephen Farrell <[email-masked]>
Date: Tue, 2 Jun 2020 23:51:00 +0100

Hiya,

On 02/06/2020 23:11, Ted Hardie wrote:
> I referenced many messages ago).  

Ah. That's a surprise to me. I don't believe that the
concept of the LLC calling consensus of a discussion
of the IETF community was a part of iasa2 at all. Or if
it was, I missed it. Of course the LLC needs to watch
and be reactive to community discussion, but calling
consensus, being a term of art around here, isn't how
I'd describe that.

> So, I think they are the victims set up
> to do that in this case.
> 

Referring to zero, or 14, as magic numbers, is an excellent rhetorical
way to disparage my argument (I'm not at all
complaining btw, I like it:-) I could as well claim that
the numbers in Jay's mail were magical, but meh.

> revisited in the light of evidence of how it ends up working.

Yep.

> But our disagreement on on who the stuckee is remains.

Yep again.

Cheers,
S.

---

From: Brian E Carpenter <[email-masked]>
Date: Wed, 3 Jun 2020 10:56:22 +1200

On 03-Jun-20 10:11, Ted Hardie wrote:
> On Tue, Jun 2, 2020 at 2:56 PM Stephen Farrell <[email-masked] <mailto:[email-masked]>> wrote:
> 
> 
> 
> I think the LLC can call consensus on a matter within their remit (just as the IAOC evaluated the feedback on the registration date change policy that I referenced many messages ago).  So, I think they are the victims set up to do that in this case.

It's a change to the openness of the standards process, unprecedented since we first started multicasting the audio for free back in the early 1990s. BCP101 defines the LLC's scope:

"The IETF LLC is established to provide administrative support to the IETF. It has no authority over the standards development activities of the IETF."

There's no doubt that the IETF Executive Director *sets* the fees, but IMHO that isn't the point at issue. In this text:
"The IETF Executive Director sets those meeting fees, in consultation with other IETF LLC staff and the IETF community, with approval by the IETF LLC Board."
I don't see any indication of how the ExecD knows the result of consulting the community when there is disagreement. The mechanism we have for that is the IESG determining the rough consensus. I can see nothing in BCP101 that gives the ExecD the power to determine IETF
consensus, although it does require the LLC to respect IETF consensus. Those are two different things.

Maybe this is a tiny gap in RFC8711, where Ted and (Stephen + I) have different interpretations.

Regards
   Brian

> I think we do agree that there should be public discussion.  I think we do agree that the LLC and IESG should talk to each other about the implications of different strategies to both the ongoing work of the IETF and its financial future.  I think we do agree that any conclusion would be revisited in the light of evidence of how it ends up working.
>

---

From: Brian E Carpenter <[email-masked]>
Date: Wed, 3 Jun 2020 11:06:58 +1200

Another point. Ted wrote:

> I referenced many messages ago)

The IAOC was a community-appointed body. The IETF ExecD is not. When it comes to evaluating community consensus, that's a big difference of principle.

Regards
   Brian

---

From: "Joel M. Halpern" <[email-masked]>
Date: Tue, 2 Jun 2020 19:26:24 -0400

I assume that the to determine the long term policy on charging for 
remote participation at various kinds of meetings, rough consensus would 
be gathered on the SHMO list, and then confirmed on the IETF list with 
the IETF Chair judging rough consensus.  Then, in line with Jay's 
frequent description of the LLC operation, the LLC will follow the 
community guidance.

I do not see how the LLC could reasonably have asked for input for this 
meeting in time to be useful.  As someone else mentioned, asking for 
input and then saying "sorry, we know the discussion is still going on 
but we have to act" would probably have been even worse.

Yours,
Joel

---

From: Robert Raszuk <[email-masked]>
Date: Wed, 3 Jun 2020 01:50:27 +0200

> meeting in time to be useful.

And would the world collapse if we would push IETF 108 a month or two
forward ? What's up with the rush ?

Charging for remote participation flat fee IMO is a very bad move. If
someone like to attend just one meeting online why would she or he be
forced to pay the same as someone attending 20 meetings ?

All it will result with is further limiting participation and only
supporting marketing focused groups to join. Do we really want IETF to be a
yet one more marketing venue ?

Rgs,
R.

On Wed, Jun 3, 2020 at 1:26 AM Joel M. Halpern <[email-masked]> wrote:

> > The IAOC was a community-appointed body. The IETF ExecD is not. When it
> comes to evaluating community consensus, that's a big difference of
> principle.
> >
> > Regards
> >     Brian
> >
> >>> On Tue, Jun 2, 2020 at 2:56 PM Stephen Farrell <
> [email-masked] <mailto:[email-masked]>> wrote:
> >>>
> >>>
> >>>
> >>> I think the LLC can call consensus on a matter within their remit
> (just as the IAOC evaluated the feedback on the registration date change
> policy that I referenced many messages ago).  So, I think they are the
> victims set up to do that in this case.
> >>
> >> It's a change to the openness of the standards process, unprecedented
> since we first started multicasting the audio for free back in the early
> 1990s. BCP101 defines the LLC's scope:
> >>
> >> "The IETF LLC is established to provide administrative support to the
> IETF. It has no authority over the standards development activities of the
> IETF."
> >>
> >> There's no doubt that the IETF Executive Director *sets* the fees, but
> IMHO that isn't the point at issue. In this text:
> >> "The IETF Executive Director sets those meeting fees, in consultation
> with other IETF LLC staff and the IETF community, with approval by the IETF
> LLC Board."
> >> I don't see any indication of how the ExecD knows the result of
> consulting the community when there is disagreement. The mechanism we have
> for that is the IESG determining the rough consensus. I can see nothing in
> BCP101 that gives the ExecD the power to determine IETF
> >>> I think we do agree that there should be public discussion.  I think
> we do agree that the LLC and IESG should talk to each other about the

---

From: "Joel M. Halpern" <[email-masked]>
Date: Tue, 2 Jun 2020 19:57:58 -0400

I'm pretty sure that many folks would expect a decision to change the 
date of the meeting drastically would itself require rough consensus. 
So we would ahve the same debate about that.  And about ....

Yes, the long term policy needs to be set by the community.  The IESG 
has been trying to start those discussions.  Whether they have been 
trying hard enough is a topic I presume we can disagree about.  I 
commented to someone privately earlier in this discussion that I 
expected it would take at least 6 months to arrive at a rough consensus 
on policies for these issues.  At taht, i expect I am being optimistic. 
Process and policy discussions in the IETF tend to bifurcate into two 
strong positions and a lot of folks staring in confusion.  Which does 
not lead to decisions.

Yours,
Joel

On 6/2/2020 7:50 PM, Robert Raszuk wrote:
> supporting marketing focused groups to join. Do we really want IETF to 
> be a yet one more marketing venue ?
> 
> Rgs,
> R.
> 
> 
> 
> 
> 
> 
> 
> On Wed, Jun 3, 2020 at 1:26 AM Joel M. Halpern <[email-masked] 
> <mailto:[email-masked]>> wrote:
> 
>      > The IAOC was a community-appointed body. The IETF ExecD is not.
>     When it comes to evaluating community consensus, that's a big
>     difference of principle.
>      >
>      > Regards
>      >     Brian
>      >
>      >>> On Tue, Jun 2, 2020 at 2:56 PM Stephen Farrell
>     <[email-masked] <mailto:[email-masked]>
>     <mailto:[email-masked]
>     <mailto:[email-masked]>>> wrote:
>      >>>
>      >>>
>      >>>
>      >>>      > And you are convincing me that attempting to settle it
>     on the IETF list
>      >>>      > will require somebody to judge consensus, since there
>     look to be a minimum
>      >>>      > of two people with the time and keyboards available to
>     disagree.  We
>      >>>      > apparently, however, disagree on who that should be.
>      >>>
>      >>> I think the LLC can call consensus on a matter within their
>     remit (just as the IAOC evaluated the feedback on the registration
>     date change policy that I referenced many messages ago).  So, I
>     think they are the victims set up to do that in this case.
>      >>
>      >> It's a change to the openness of the standards process,
>     unprecedented since we first started multicasting the audio for free
>     back in the early 1990s. BCP101 defines the LLC's scope:
>      >>
>      >> "The IETF LLC is established to provide administrative support
>     to the IETF. It has no authority over the standards development
>     activities of the IETF."
>      >>
>      >> There's no doubt that the IETF Executive Director *sets* the
>     fees, but IMHO that isn't the point at issue. In this text:
>      >> "The IETF Executive Director sets those meeting fees, in
>     consultation with other IETF LLC staff and the IETF community, with
>     approval by the IETF LLC Board."
>     consulting the community when there is disagreement. The mechanism
>     we have for that is the IESG determining the rough consensus. I can
>     see nothing in BCP101 that gives the ExecD the power to determine IETF
>      >> consensus, although it does require the LLC to respect IETF
>     consensus. Those are two different things.
>      >>
>      >>> I think we do agree that there should be public discussion.  I
>     think we do agree that the LLC and IESG should talk to each other
>     about the implications of different strategies to both the ongoing
>     work of the IETF and its financial future.  I think we do agree that
>     any conclusion would be revisited in the light of evidence of how it
>     ends up working.
>      >>>

---

From: Robert Raszuk <[email-masked]>
Date: Wed, 3 Jun 2020 02:02:27 +0200

So I am struggling with just one question here ...

What is the practical difference for standards development of formal IETF
WG meeting with fee vs a WG interim meeting with no fee using zoom or
google meet ?

Kind regards,
Robert.

On Wed, Jun 3, 2020 at 1:58 AM Joel M. Halpern <[email-masked]> wrote:

> >     remit (just as

---

From: "Joel M. Halpern" <[email-masked]>
Date: Tue, 2 Jun 2020 20:09:06 -0400

If that is your only question, you are doing better than I.  I can see a 
myriad questions that we are going to need to answer.  Some of them 
urgent, some not.
I suspect that the key to the answer to the question you chose lies in 
how we end up treating them.  But that is just a guess.

Yours,
Joel

On 6/2/2020 8:02 PM, Robert Raszuk wrote:
> What is the practical difference for standards development of formal 
> IETF WG meeting with fee vs a WG interim meeting with no fee using zoom 
> or google meet ?
> 
> Kind regards,
> Robert.
> 
> 
> On Wed, Jun 3, 2020 at 1:58 AM Joel M. Halpern <[email-masked] 
>      >  > I do not see how the LLC could reasonably have asked for input
>     for this
>      >  > meeting in time to be useful.
>      >
>      > On Wed, Jun 3, 2020 at 1:26 AM Joel M. Halpern
>     <[email-masked] <mailto:[email-masked]>
>      > <mailto:[email-masked] <mailto:[email-masked]>>> wrote:
>      >
>      >     remote participation at various kinds of meetings, rough
>     consensus
>      >     would
>      >      > Another point. Ted wrote:
>      >      >
>      >      >> I think the LLC can call consensus on a matter within their
>      >     remit (just as
>      >      >> the IAOC evaluated the feedback on the registration date
>     change
>      >     policy that
>      >      >> I referenced many messages ago)
>      >      >
>      >      > The IAOC was a community-appointed body. The IETF ExecD is
>     not.
>      >      >
>      >      > Regards
>      >      >     Brian
>      >      >
>      >      > On 03-Jun-20 10:56, Brian E Carpenter wrote:
>      >      >> On 03-Jun-20 10:11, Ted Hardie wrote:
>      >      >>> On Tue, Jun 2, 2020 at 2:56 PM Stephen Farrell
>     <mailto:[email-masked] <mailto:[email-masked]>>
>     <mailto:[email-masked]>
>     <mailto:[email-masked]>>>> wrote:
>      >      >>>
>      >      >>>
>      >      >>>
>      >      >>>      On 02/06/2020 22:41, Ted Hardie wrote:
>      >      >>>      > And you are convincing me that attempting to
>     settle it
>      >     on the IETF list
>      >      >>>      > will require somebody to judge consensus, since there
>      >     look to be a minimum
>      >      >>>      > of two people with the time and keyboards
>     available to
>      >     disagree.  We
>      >      >>>      > apparently, however, disagree on who that should be.
>      >      >>>
>      >      >>>      Perhaps not! If you do agree that consensus calling is
>      >      >>>      required that seems to imply the LLC is not the one to
>      >      >>>      do that. We have a bunch of 14 victims already setup
>      >      >>>      to do just that:-)
>      >      >>>
>      >      >>>
>      >      >>> I think the LLC can call consensus on a matter within their
>      >      >>
>      >      >> It's a change to the openness of the standards process,
>      >      >>
>      >      >> "The IETF LLC is established to provide administrative
>     support
>      >      >>
>      >      >> There's no doubt that the IETF Executive Director *sets* the
>      >      >> "The IETF Executive Director sets those meeting fees, in
>      >      >> I don't see any indication of how the ExecD knows the
>     result of
>      >      >> consensus, although it does require the LLC to respect IETF
>      >      >>
>      >      >> Maybe this is a tiny gap in RFC8711, where Ted and
>     (Stephen + I)
>      >     have different interpretations.
>      >      >>
>      >      >> Regards
>      >      >>     Brian
>      >      >>
>      >      >>> Since you referenced the magic number 14, I conclude we
>     still
>      >     disagree.
>      >      >>>
>      >      >>> I think we do agree that there should be public
>     discussion.  I
>      >      >>>
>      >      >>> But our disagreement on on who the stuckee is remains.
>      >      >>>
>      >      >>> regards,
>      >      >>>
>      >      >>> Ted
>      >      >>>
>      >      >>>
>      >      >>>      Cheers,
>      >      >>>      S.
>      >      >>>
>      >      >>
>      >      >
>      >
>

---

From: Alissa Cooper <[email-masked]>
Date: Tue, 2 Jun 2020 20:37:49 -0400

Hi,

A few notes related to the discussion that has been happening in this thread:

Over on [email-masked] [1] where we have been discussing a possible charter for a new Stay Home Meet Online (SHMO) working group, I have proposed [2] some new charter text to add a work item about principles to guide the determination of registration fees for fully online meetings. Please join the discussion on that list and provide your input about that.

Regarding the announcement of meeting fees for IETF 108, as I mentioned previously, the IESG did discuss the meeting fee proposal in advance of it being announced to the community and suggested changes to it. The IESG does not typically vote (about anything, normally), and we did not take a formal vote to “approve” the fee proposal but had the bulk of the IESG disagreed with it, it would not have gone forward in the form presented to us.

I think trying to compare the registration fee decision for IETF 108 to registration fee decisions for in-person meeting or registration fee decisions for remote participation at in-person meetings is a lost cause. IETF 108 will be in a new category and its meeting format will be something we have never tried before. Better to acknowledge the novelty of the situation in which we find ourselves than to argue about how to analogize it to something else.

Regarding participants who are only interested in one working group, there is a one-day pass option for those who intend to participate in WGs on a single day. It may be that no one will avail themselves of this option, but IMO there was no harm in including it.

It is clear that participants in individual working groups may seek to “avoid” paying the registration fee by convincing their WG chairs to schedule interim meetings rather than have their groups scheduled during the meeting week. We are an open community and the IESG has no practical means of preventing people from gathering on web conferences to discuss IETF work outside of the scheduled meeting. My hunch is that a significant proportion of the IETF community is interested in work across multiple WGs or areas and therefore may be enticed to join us for the full meeting week. We are also aiming to arrange things so that WGs scheduled during the meeting week will benefit from having technical support on-call, the full suite of Meetecho features (queue management, integrated blue sheets, etc.), access to a virtual hallway-style experience, and possibly other enhancements to the meeting week experience. We won’t know what participation looks like until we try it, and we won’t make future plans until we gain experience with the current ones.

As noted previously, we will be providing up to 100 fee waivers because we recognize that the fee may present a barrier to participation for some.

We all wish there weren’t a pandemic, but there is one, so we have to accept the fact of it and adapt.

Alissa

[1] https://www.ietf.org/mailman/listinfo/manycouches
[2] https://mailarchive.ietf.org/arch/msg/manycouches/qkUNflWL1XcxGxrtu8XVvGqdeQQ/

---

From: S Moonesamy <[email-masked]>
Date: Tue, 02 Jun 2020 18:08:36 -0700

Hi Ted,
At 02:41 PM 02-06-2020, Ted Hardie wrote:
>Well, we agree that we disagree.  From my perspective, zero is not a 
>magic number, and the status quo is not doctrine.  Both, in the 
>case, are part of a balancing act that goes into making sure the 
>IETF works both for a meeting and for the long term.  Handing 
>financial responsibility for that without the relevant authority is 
>an invitation to silly states.

I read an email about "registration details" and that was went I was 
informed that there would be a fee for IETF 108.  I asked who took 
the decision as it was not clear.  I did not argue for or against 
whether a fee should be charged.

The next meeting will be covered by the "Note Well".  It is standards 
process as that has been the custom.  It has been free for me to 
attend or participate.  Now, it is not free.  In my opinion, it is 
not up to the IETF Administration LLC Executive Director to decide 
that.  That opinion is based on the discussions and documents from 
IASA2.  It might sound silly that such a decision requires debate 
given that the fee was $1; it is not about the amount.

There is a research group which scheduled a session about "rights" at 
the next meeting.  I'll wait and see what it will do.  For what it is 
worth, I am not into digital rights as it could potentially cause a conflict.

Regards,
S. Moonesamy

---

From: Ted Hardie <[email-masked]>
Date: Tue, 2 Jun 2020 20:18:25 -0700

On Tue, Jun 2, 2020 at 3:51 PM Stephen Farrell <[email-masked]>
wrote:

> I think we expect it of any of our community selected leaders, including
WG chairs, IESG and son.  Given that the IETF LLC board a set of community
selected leaders, I don't think it's strange to expect them to be able to
call consensus.

> way to disparage my argument

Didn't mean to disparage it, and I apologize if it came across that way.  I
just meant that 14 matched the number of IESG members and not the number of
LLC Board members.

regards,

Ted

> (I'm not at all

---

From: Ted Hardie <[email-masked]>
Date: Tue, 2 Jun 2020 20:30:20 -0700

HI Brian,

On Tue, Jun 2, 2020 at 3:57 PM Brian E Carpenter <
[email-masked]> wrote:

> > I think the LLC can call consensus on a matter within their remit (just
> as the IAOC evaluated the feedback on the registration date change policy
> that I referenced many messages ago).  So, I think they are the victims set
> up to do that in this case.
>

This isn't one thing.  It's a modification of the working methods of the
IETF to deal with a crisis (and there's many more aspects of the methods
which are changing).  It's an effort to provide administrative support for
both a specific meeting and the IETF long term.  And it is an effort to
manage the fairness of impact.  For many of us, the lack of airfare, hotel,
and reduced costs for this makes this a very cheap option compared to other
years.  For others it will go up, but they will be on even keel with
others.  For those who truly can't afford it, donations have made up 100
registration fees, and I'm sure the LLC would be happy for more donations
to help those in need.

> There's no doubt that the IETF Executive Director *sets* the fees,

As I said in my note to Stephen just now, I meant that the LLC Board, as
the relevant community leadership, would call consensus on this.  I thought
that was implied by the references to "they" and "them", but my apologies
for not being explicit.

> but IMHO that isn't the point at issue. In this text:
> "The IETF Executive Director sets those meeting fees, in consultation with
> other IETF LLC staff and the IETF community, with approval by the IETF LLC
> Board."
> I don't see any indication of how the ExecD knows the result of consulting
> the community when there is disagreement. The mechanism we have for that is
> the IESG determining the rough consensus.

As I said, I think any of our leadership is expected to be able to manage a
consensus call, and I don't see why the LLC board shouldn't do it.  They
are responsible for setting the fees; they use community guidance in RFCs,
consultations with the IESG, and public feedback.    They are also
community selected leaders, just like the IESG.  Putting the IESG back in
that particular role is a step backward in the division of labor we've set
out, and I don't see that its either warranted or appropriate.

regards,

Ted Hardie

I can see nothing in BCP101 that gives the ExecD the power to determine IETF
> > I think we do agree that there should be public discussion.  I think we
> do agree that the LLC and IESG should talk to each other about the

---

From: Brian E Carpenter <[email-masked]>
Date: Wed, 3 Jun 2020 15:38:15 +1200

Let's take this discussion to the SHMO WG, assuming it's created.

Regards
   Brian

On 03-Jun-20 15:30, Ted Hardie wrote:
> HI Brian,
> 
> On Tue, Jun 2, 2020 at 3:57 PM Brian E Carpenter <[email-masked] <mailto:[email-masked]>> wrote:
> 
>     > On Tue, Jun 2, 2020 at 2:56 PM Stephen Farrell <[email-masked] <mailto:[email-masked]> <mailto:[email-masked] <mailto:[email-masked]>>> wrote:
>     >
>     >
>     >
>     >     > And you are convincing me that attempting to settle it on the IETF list
>     >     > will require somebody to judge consensus, since there look to be a minimum
>     >     > of two people with the time and keyboards available to disagree.  We
> This isn't one thing.  It's a modification of the working methods of the IETF to deal with a crisis (and there's many more aspects of the methods which are changing).  It's an effort to provide administrative support for both a specific meeting and the IETF long term.  And it is an effort to manage the fairness of impact.  For many of us, the lack of airfare, hotel, and reduced costs for this makes this a very cheap option compared to other years.  For others it will go up, but they will be on even keel with others.  For those who truly can't afford it, donations have made up 100 registration fees, and I'm sure the LLC would be happy for more donations to help those in need. 
>  
> 
> 
> As I said in my note to Stephen just now, I meant that the LLC Board, as the relevant community leadership, would call consensus on this.  I thought that was implied by the references to "they" and "them", but my apologies for not being explicit.
> 
>  
> 
>     I don't see any indication of how the ExecD knows the result of consulting the community when there is disagreement. The mechanism we have for that is the IESG determining the rough consensus.
> 
> 
> As I said, I think any of our leadership is expected to be able to manage a consensus call, and I don't see why the LLC board shouldn't do it.  They are responsible for setting the fees; they use community guidance in RFCs, consultations with the IESG, and public feedback.    They are also community selected leaders, just like the IESG.  Putting the IESG back in that particular role is a step backward in the division of labor we've set out, and I don't see that its either warranted or appropriate.
> 
> regards,
> 
> Ted Hardie
> 
>

---

From: S Moonesamy <[email-masked]>
Date: Wed, 03 Jun 2020 05:29:39 -0700

Hi Jordi,
At 12:13 PM 01-06-2020, JORDI PALET MARTINEZ wrote:
>Exactly. As I mention in my previous email, this is not really about 
>"this" meeting, it is about next meetings (in person and online, 
>with and without Covid19), it is about how to cover *all* our expenses.
>
>It is unfair that people that contributes more, pay traveling 
>expenses and attendance fees, and may have similar problems to cover 
>all that cost as people that is participating remotely, which only 
>will need to pay for a registration fee.
>
>How we compensate all the people that have attended meetings for 
>tens of years? In my own case my first meeting was summer 2001, and 
>I never missed one, so I've contributed with about 34.000 USD (just 
>in attendance fees!). For an individual or an SME, this is not the 
>same as for a participant that works for a medium or big size 
>organization, that is covering all the expenses for him/her.

Revenue from IETF attendees is less than 50% of the IETF revenue.  I 
was a bit surprised by the numbers as I made some assumptions based 
on past IETF discussions.  I don't have an answer to your question.

>So, this is a discussion about IETF budged in general. It is about 
>what the PIR/.org was

The above is the controversial topic which was avoided over the past 
six months.

Getting back to the topic, it usually turns into big/small 
organizations and individuals.     One of these days someone may come 
up with an acceptable solution.  There were two (more) interesting 
messages within the discussion, one from Ole and the other from you.

Regards,
S. Moonesamy

---

From: Phillip Hallam-Baker <[email-masked]>
Date: Wed, 3 Jun 2020 10:59:39 -0400

This discussion is showing the limits of consensus based decision making in
the IETF.

There are two discussions we could be having, only one of which actually
involves a choice. We are currently having a discussion of the short term
issue where there is no real choice and not the long term issue where we do.

Charging for the lost in-person meetings is water under the bridge. What we
should be discussing is where we want to be in the future.

While the IETF is all about the Internet, its fundamental structures and
business model were established before the Internet. It is at root a 1980s
institution. By which I mean not that it is typical of the institutions of
the 1980s but it is a product of the thinking about institutions at that
time. There are innovative aspects of the IETF that represent experiments
in organization. But not necessarily experiments that worked.

There are very similar problems in the world of academic journals. The
business model that was established by the publishers in the 1960s makes no
sense from the point of view of the agencies that fund the research. That
has been apparent for what, 30 years? There is a law of gravity at work
here but one that takes generations to take effect.

On Tue, Jun 2, 2020 at 7:27 PM Joel M. Halpern <[email-masked]> wrote:

> as

---

From: "tom petch" <[email-masked]>
Date: Wed, 3 Jun 2020 17:28:43 +0100

----- Original Message -----
From: Phillip Hallam-Baker [email-masked]
Sent: 03/06/2020 15:59:39

This discussion is showing the limits of consensus based decision making in the IETF.

There are two discussions we could be having, only one of which actually involves a choice. We are currently having a discussion of the short term issue where there is no real choice and not the long term issue where we do.

Charging for the lost in-person meetings is water under the bridge. What we should be discussing is where we want to be in the future.

While the IETF is all about the Internet, its fundamental structures and business model were established before the Internet. It is at root a 1980s institution. By which I mean not that it is typical of the institutions of the 1980s but it is a product of the thinking about institutions at that time. There are innovative aspects of the IETF that represent experiments in organization. But not necessarily experiments that worked.
<tp>
I have only been involved with the IETF for 25 years, post IESG, pre IAxx, LLC etc, and  not back to the 1980s, but even in that short time it has changed out of recognition IMHO, becoming more structured, more formal, more procedural in the non-technical aspects of the work and I think that that is a good thing.  The pandemic is undermining the assumptions on which many businesses are currently based and that could be happening with the IETF.  Meeting in person is a likely candidate.  I agree that we should focus on what we can change and accept what we cannot but I think too that the psychology of participants in a group is little changed so far and so some discussions we have had on this list before, we will have again and they will likely be as unproductive as they have been in the past.   Interestingly, academic journals, which you also mention

---

, is something I now seem to use only for looking up the history of developments.
Tom Petch

There are very similar problems in the world of academic journals. The business model that was established by the publishers in the 1960s makes no sense from the point of view of the agencies that fund the research. That has been apparent for what, 30 years? There is a law of gravity at work here but one that takes generations to take effect.

Yours,
Joel

---

From: Bob Hinden <[email-masked]>
Date: Wed, 3 Jun 2020 09:32:06 -0700

Jay,

I have some specific questions about the registration fees for IETF 108 as announced.  Note, I am OK with charging a fee for remote participation, but I still have questions.  I have reviewed your blog entry [3].

While I support charging a fee to participate, I don’t see any justification for having different fee levels (Early, Standard, Late).  Why is this being done?   It makes some sense for a face-to-face meeting, where we do need to know how many people will be on site, cookies to buy, etc., but that is not the case here.   Do we have a cash flow problem that we need to get the money early?   Please explain, this seems completely arbitrary to me.

How does the fee relate to the costs of running the meeting?    As it said in your blog entry:

"As noted above, $515,145 is much higher than the direct cost of running an online meeting due to the way we spread some operational costs.”

How much higher is it?   Please share the details.   I infer the fee is being set do to how the LLC is doing its accounting, not related to the direct costs.

I would prefer that the fee be set based on our costs for running the meeting.

Bob

> On May 27, 2020, at 6:12 PM, IETF Executive Director <[email-masked]> wrote:
> 
> As previously announced [1], IETF 108 is switching to a fully online meeting over 5 days, 25-31 July, with an agenda structure similar to that of an in-person meeting [2].
> 
> Registrations will open on 8 June 2020 and the registration fees will be as follows:
> 
>    Early-Bird:  USD 230, until 26 June 2020
>    Standard:  USD 280, until 20 July 2020
>    Late:  USD 330, after 20 July 2020
>    Full-time Student:  USD 50
>    One Day Pass:  USD 125
> 
> This meeting will have a substantial agenda but as the cost of an online meeting is lower, the registration fees have been set at approximately one-third of those for an in-person meeting.  A detailed explanation of why we charge a fee for meetings and how the fee reduction was set for IETF 108 is provided in a separate blog post [3].
> 
> As online participants have until now not had to pay a fee, it is recognised that there may be some for whom the fee presents a barrier to participation and so we will provide up to 100 early bird fee waivers for IETF 108. If the number of waiver requests exceeds the number we can offer, waiver recipients will be chosen at random using a process similar to the one specified in RFC 3797. Details of how to apply for a waiver will be provided when registration opens.
> 
> No decision has been made on whether or not a fee for online participation is needed when we return to in-person meetings.
> 
> As this is a fully online meeting, there are two key changes in the meeting process for you to be aware of:
> 
> 1.  When you register you will be able to choose if you want to receive an IETF 108 t-shirt delivered to you at no additional expense. Numbers will be limited to 1000 t-shirts on a first-come-first-served basis with 900 for Early Birds and 100 for Students.
> 
> 2.  All participants will need a Datatracker account in order to authenticate with Meetecho.  If you do not already have an account then one will be created for you during registration and you will receive a password setup link by email.
> 
> As with in-person meetings, a video recording of each scheduled session will be posted after the session concludes and the proceedings will be posted in the normal timeframe following the meeting.
> 
> Finally, we are still in the process of securing sponsors with some generous contributions already agreed and more under discussion.  Full details and thanks will follow later.
> 
> Please feel free to contact me directly if you have any questions or comments.
> 
> [1]  https://mailarchive.ietf.org/arch/msg/ietf-announce/kzC7M48oKrAwdh9uyOvseeKFW3A/
> [2]  https://www.ietf.org/blog/ietf108-survey-results-informed-planning/
> [3]  https://www.ietf.org/blog/ietf108-registration-fees
> 
> --
> Jay Daley
> IETF Executive Director
> [email-masked]
> 
> _______________________________________________
> IETF-Announce mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ietf-announce

---

From: Jay Daley <[email-masked]>
Date: Thu, 4 Jun 2020 07:15:12 +1200

Bob

> On 4/06/2020, at 4:32 AM, Bob Hinden <[email-masked]> wrote:
> 
> Jay,
> 

As you know the Early/Standard/Late approach was implemented as a forcing function on the basis that the earlier people registered, the better the planning and it works well in that regard as the bulk of people register in the Early Bird phase.  I don’t know when the Early Bird/Standard split came but the Late phase was added in 2018:

	https://mailarchive.ietf.org/arch/msg/ietf-announce/jJ8_yArXVOtsw613FP9gol9EjxU/

While an online meeting is different from an in-person meeting there are still a number of key variables where the earlier we know, the better the planning.  These include: the number of people we need to have on support desks, the initial scaling of the infrastructure and how many t-shirts to order.

> How much higher is it?   Please share the details.  

I don’t know the answer to that in detail as we have only started looking at this recently.  As explained in the blog post, one third of the annual Secretariat labor cost and of some of the annual NOC cost is assigned to each meeting. In other words, four months of labor is assigned to each meeting.  I have not done the work with the Secretariat to see if that is actually one month or more.  Additionally, there are multiple costs incurred in the run up to meetings, such as site visits, which are not accounted for in the cost (and so would raise it) that would need to be incorporated.

>  I infer the fee is being set do to how the LLC is doing its accounting, not related to the direct costs.

Yes, though I would say we’ve (LLC and prior to the the IAOC) been explicit about that for several years rather than leaving it to inference.

> I would prefer that the fee be set based on our costs for running the meeting.

That is a very substantial piece of work with significant implications that need to be thought through and in light of those this might not be a good idea.  For example, it would show our meeting income greatly exceeding our meeting costs, which may lead some participants or some sponsors to question our fee levels and that would then cause problems for our non-meeting expenses.  

As this is the basis on which, for several years, the LLC and the IAOC before it has structured its accounts, there would need to be a compelling reason to change.

Jay

-- 
Jay Daley
IETF Executive Director
[email-masked]

---

From: Mary B <[email-masked]>
Date: Wed, 3 Jun 2020 14:37:13 -0500

A simple answer to the t-shirt issue is that t-shirts will be only be
available if you register by a certain date (FCFS) - that's the best
forcing function with this group AFAICT since the cookie count isn't
impacted.

Otherwise, I don't see the point in deadlines either.  I would think you
could get an estimate based on the number that participated remotely for
IETF-108, maybe adding 10%.  Or using the average number of in person
attendees + remote attendees.  I really doubt that having the virtual
meeting would dramatically increase the number of participants and I would
hope the logistics aren't that sensitive to fluctuations in number of
participants.  And, having the late fee could very well backfire and you'll
have a lot more one day folks once people see the agenda and realize they
missed the early bird (or even standard) registration dates, especially for
those of us that are self funded.

I do have a question as to whether those with a one day pass would still be
able to attend the plenary (and any other non-WG meetings that might be
scheduled) even if they attend a regular session on another day (which is
how it is currently)?

Mary.

On Wed, Jun 3, 2020 at 2:15 PM Jay Daley <[email-masked]> wrote:

> I have some specific questions about the registration fees for IETF 108 as
> announced.  Note, I am OK with charging a fee for remote participation, but
> I still have questions.  I have reviewed your blog entry [3].
>
> While I support charging a fee to participate, I don’t see any
> justification for having different fee levels (Early, Standard, Late).  Why
> is this being done?   It makes some sense for a face-to-face meeting, where
> we do need to know how many people will be on site, cookies to buy, etc.,
> but that is not the case here.   Do we have a cash flow problem that we
> need to get the money early?   Please explain, this seems completely
> arbitrary to me.
>
>
> As you know the Early/Standard/Late approach was implemented as a forcing
> function on the basis that the earlier people registered, the better the
> planning and it works well in that regard as the bulk of people register in
> the Early Bird phase.  I don’t know when the Early Bird/Standard split came
> but the Late phase was added in 2018:
>
>
> While an online meeting is different from an in-person meeting there are
> still a number of key variables where the earlier we know, the better the
> planning.  These include: the number of people we need to have on support
> desks, the initial scaling of the infrastructure and how many t-shirts to
> order.
>
>
> "As noted above, $515,145 is much higher than the direct cost of running
> an online meeting due to the way we spread some operational costs.”
>
> I don’t know the answer to that in detail as we have only started looking
> at this recently.  As explained in the blog post, one third of the annual
> Secretariat labor cost and of some of the annual NOC cost is assigned to
> each meeting. In other words, four months of labor is assigned to each
> meeting.  I have not done the work with the Secretariat to see if that is
> actually one month or more.  Additionally, there are multiple costs
> incurred in the run up to meetings, such as site visits, which are not
> accounted for in the cost (and so would raise it) that would need to be
> incorporated.
>
>
> Yes, though I would say we’ve (LLC and prior to the the IAOC) been
> explicit about that for several years rather than leaving it to inference.
>
>
> That is a very substantial piece of work with significant implications
> that need to be thought through and in light of those this might not be a
> good idea.  For example, it would show our meeting income greatly exceeding
> our meeting costs, which may lead some participants or some sponsors to
> question our fee levels and that would then cause problems for our
> non-meeting expenses.
>
> As this is the basis on which, for several years, the LLC and the IAOC
> before it has structured its accounts, there would need to be a compelling
> reason to change.
>
> Jay
>
>
> Bob
>
>
>
>
>
>
>
>
>
> As previously announced [1], IETF 108 is switching to a fully online
> meeting over 5 days, 25-31 July, with an agenda structure similar to that
> of an in-person meeting [2].
>
> This meeting will have a substantial agenda but as the cost of an online
> meeting is lower, the registration fees have been set at approximately
> one-third of those for an in-person meeting.  A detailed explanation of why
> we charge a fee for meetings and how the fee reduction was set for IETF 108
> is provided in a separate blog post [3].
>
> As online participants have until now not had to pay a fee, it is
> recognised that there may be some for whom the fee presents a barrier to
> participation and so we will provide up to 100 early bird fee waivers for
> IETF 108. If the number of waiver requests exceeds the number we can offer,
> waiver recipients will be chosen at random using a process similar to the
> one specified in RFC 3797. Details of how to apply for a waiver will be
> provided when registration opens.
>
> No decision has been made on whether or not a fee for online participation
> is needed when we return to in-person meetings.
>
> 1.  When you register you will be able to choose if you want to receive an
> IETF 108 t-shirt delivered to you at no additional expense. Numbers will be
> limited to 1000 t-shirts on a first-come-first-served basis with 900 for
> Early Birds and 100 for Students.
>
> 2.  All participants will need a Datatracker account in order to
> authenticate with Meetecho.  If you do not already have an account then one
> will be created for you during registration and you will receive a password
> setup link by email.
>
> As with in-person meetings, a video recording of each scheduled session
> will be posted after the session concludes and the proceedings will be
> posted in the normal timeframe following the meeting.
>
> Finally, we are still in the process of securing sponsors with some
> generous contributions already agreed and more under discussion.  Full
> details and thanks will follow later.
>
> [1]
> https://mailarchive.ietf.org/arch/msg/ietf-announce/kzC7M48oKrAwdh9uyOvseeKFW3A/

---

From: Jay Daley <[email-masked]>
Date: Thu, 4 Jun 2020 09:19:35 +1200

> On 4/06/2020, at 7:37 AM, Mary B <[email-masked]> wrote:
> 
> A simple answer to the t-shirt issue is that t-shirts will be only be available if you register by a certain date (FCFS) - that's the best forcing function with this group AFAICT since the cookie count isn't impacted.   
> 
> Otherwise, I don't see the point in deadlines either.  I would think you could get an estimate based on the number that participated remotely for IETF-108, maybe adding 10%.  Or using the average number of in person attendees + remote attendees.  I really doubt that having the virtual meeting would dramatically increase the number of participants and I would hope the logistics aren't that sensitive to fluctuations in number of participants.  And, having the late fee could very well backfire and you'll have a lot more one day folks once people see the agenda and realize they missed the early bird (or even standard) registration dates, especially for those of us that are self funded.  
> 
> I do have a question as to whether those with a one day pass would still be able to attend the plenary (and any other non-WG meetings that might be scheduled) even if they attend a regular session on another day (which is how it is currently)?     

That is the intention yes, though the details of how to make that happen are unclear at this stage.

Jay

> 
> Mary.  
> 
> On Wed, Jun 3, 2020 at 2:15 PM Jay Daley <[email-masked] <mailto:[email-masked]>> wrote:
> Bob
> 
>> On 4/06/2020, at 4:32 AM, Bob Hinden <[email-masked] <mailto:[email-masked]>> wrote:
>> 
>> Jay,
>> 
> 	https://mailarchive.ietf.org/arch/msg/ietf-announce/jJ8_yArXVOtsw613FP9gol9EjxU/ <https://mailarchive.ietf.org/arch/msg/ietf-announce/jJ8_yArXVOtsw613FP9gol9EjxU/>
> 
>>> On May 27, 2020, at 6:12 PM, IETF Executive Director <[email-masked] <mailto:[email-masked]>> wrote:
>>> 
>>> [1]  https://mailarchive.ietf.org/arch/msg/ietf-announce/kzC7M48oKrAwdh9uyOvseeKFW3A/ <https://mailarchive.ietf.org/arch/msg/ietf-announce/kzC7M48oKrAwdh9uyOvseeKFW3A/>
>>> [2]  https://www.ietf.org/blog/ietf108-survey-results-informed-planning/ <https://www.ietf.org/blog/ietf108-survey-results-informed-planning/>
>>> [3]  https://www.ietf.org/blog/ietf108-registration-fees <https://www.ietf.org/blog/ietf108-registration-fees>
>>> 
>>> --
>>> Jay Daley
>>> IETF Executive Director
>>> [email-masked] <mailto:[email-masked]>
>>> 
>>> [email-masked] <mailto:[email-masked]>
>>> https://www.ietf.org/mailman/listinfo/ietf-announce <https://www.ietf.org/mailman/listinfo/ietf-announce>
>> 
> 
> -- 
> Jay Daley
> IETF Executive Director
> [email-masked] <mailto:[email-masked]>
> 

-- 
Jay Daley
IETF Executive Director
[email-masked]

---

From: Carsten Bormann <[email-masked]>
Date: Wed, 3 Jun 2020 23:40:42 +0200

On 2020-06-03, at 18:32, Bob Hinden <[email-masked]> wrote:
> 
> While I support charging a fee to participate, I don’t see any justification for having different fee levels (Early, Standard, Late). 

While I’m not in the business of providing justifications here, I do like the differential pricing.  The heavier your bureaucracy, the later you pay, and thus the more you pay.
Lean organizations get away with low cost, expensive organizations get to spend the money they undoubtedly have.
(If we do need the money, differential pricing is an easy way to bolster it a bit while minimizing the drawbacks of doing that.)
This is a reason to do it, not a justification; we can run with Jay’s justification.

Grüße, Carsten

---

From: Bob Hinden <[email-masked]>
Date: Wed, 3 Jun 2020 20:07:24 -0700

Jay,

Thanks for the quick response.   Inline.

> On Jun 3, 2020, at 12:15 PM, Jay Daley <[email-masked]> wrote:
> 
> Bob
> 

I am aware of the past, but this is quite different now and I don’t think it applies.

> While an online meeting is different from an in-person meeting there are still a number of key variables where the earlier we know, the better the planning.  These include: the number of people we…

Charging different rates based on when you register doesn’t have much effect on this.   You need the same level of support independent of when people register and how much they pay.   I bet you have a good idea of how many people will attend independent of this.

Note, I also think that a virtual t-shirt would be more appropriate, instead of mailing everyone a shirt around the world.  This seems like a needless expense to me.

> I don’t know the answer to that in detail as we have only started looking at this recently.  As explained in the blog post, one third of the annual Secretariat labor cost and of some of the annual…

I was responding to what you wrote in your blog, I assume you had the data behind what you wrote.   Secretariat labor makes a lot of sense, but I suspect there won’t be a NOC so there shouldn’t be any significant NOC expenses, except for additional Meetecho expenses for the additional remote participation support.

> That is a very substantial piece of work with significant implications that need to be thought through and in light of those this might not be a good idea.  For example, it would show our meeting i…

That isn’t a new problem, as much of our funding some from ISOC.

A model where the meetings (face to face or all remote) pay for themselves, and ISOC pays for the rest would work.  The financials break this all out quite clearly.   According to the 2020 budget the meetings are running at a slight loss. We are close to that now.

https://www.ietf.org/media/documents/IETF_2020_Public_Budget_nmHyaCx.pdf

> As this is the basis on which, for several years, the LLC and the IAOC before it has structured its accounts, there would need to be a compelling reason to change.

How about because the world has changed and our ability to have face to face meetings any time soon is unlikely.   This is not business as usual.  It’s unlikely we are going to have any face to face meetings this year, nor I suspect the first half of next year.

Bob

---

From: John C Klensin <[email-masked]>
Date: Wed, 03 Jun 2020 23:27:55 -0400

--On Thursday, June 4, 2020 09:19 +1200 Jay Daley <[email-masked]>
wrote:
 
>> A simple answer to the t-shirt issue is that t-shirts will be
>> only be available if you register by a certain date (FCFS) -
>> that's the best forcing function with this group AFAICT since
>> the cookie count isn't impacted.   
>> 
>> Otherwise, I don't see the point in deadlines either.  I
>> would think you could get an estimate based on the number
>> that participated remotely for IETF-108, maybe adding 10%.
>> Or using the average number of in person attendees + remote
>> attendees.  I really doubt that having the virtual meeting
>> would dramatically increase the number of participants and I
>> would hope the logistics aren't that sensitive to
>> fluctuations in number of participants.  And, having the late
>> fee could very well backfire and you'll have a lot more one
>> day folks once people see the agenda and realize they missed
>> the early bird (or even standard) registration dates,
>> especially for those of us that are self funded.  

Jay,

As I continue to defer sending my very long note (and take
things out of it as others ask similar questions), I like Mary's
idea about making the t-shirts or equivalent available only to
those who register by a certain date.  Maybe printing up some
extras, charging extra for them, and making that second-wave
collection FCFS.

There is another aspect of the charging plan that I'm a little
concerned about and it is connected to Mary's comment about
latecomers opting for day passes.  Before the recent
disruptions, one of the features of coming in remotely has been
that someone could opt to just watch and listen in real time
(i.e., not wait for the YouTube recordings to show up), giving
the option of remaining anonymous, etc.  I don't have any data
on how often we managed to turn them into active participants
but I know there have been people who were encouraged to use
that option to understand better how the IETF worked or what a
particular WG was doing.     The other was the participant,
option which, in recent years, required registering, virtually
signing blue sheet approximations, etc. 

And someone who was watching but decided they were interested
enough to want to contribute during that meeting could simply
log out, register (at no cost) and come back in.  I, at least,
mentioned that "if you are uncomfortable identifying yourself,
watch and then register if you feel like you want to speak up"
option to several people in recent years.

So...

(1) With the new fee structure, will the watch/observe option --
without any fee or need to identify oneself -- still exist?

(2) If we have someone who signs up to observe, is remote
partially to minimize costs, and who then decides to start
participating and contributing, is a super-premium
during-meeting registration fee the message we want to send?
Did you and the LLC, ideally in consultation with the IESG,
think about waiving late fees (or creating a cheap more-than-one
day pass) for first-timers?  I'd be astonished if that had a
major budgetary impact, but it would help send a message about
our being welcoming and would  be independent of the actual
waiver program.

thanks,
   john

---

From: Jay Daley <[email-masked]>
Date: Thu, 4 Jun 2020 15:36:04 +1200

Bob

> On 4/06/2020, at 3:07 PM, Bob Hinden <[email-masked]> wrote:
>> 
> Charging different rates based on when you register doesn’t have much effect on this.   You need the same level of support independent of when people register and how much they pay.

There is always a difference between planned numbers and actuals.  This certainly helps with the former, which is sufficient reason to keep it.  It’s also not clear what downside there is to keeping it.

>   I bet you have a good idea of how many people will attend independent of this.

Unfortunately I don’t - we are in uncharted waters now.

> Note, I also think that a virtual t-shirt would be more appropriate, instead of mailing everyone a shirt around the world.  This seems like a needless expense to me.

There were differing views expressed on this in our internal planning but the winning view is that t-shirts matter a great deal to IETF participants and represent the only tangible takeaway from this event.

> I was responding to what you wrote in your blog, I assume you had the data behind what you wrote.   Secretariat labor makes a lot of sense, but I suspect there won’t be a NOC so there shouldn’t be…

We no longer have a volunteer funded NOC lead and so pay for NOC services throughout the year.  Additionally, there will indeed be a NOC for IETF 108 with both volunteers and a contracted helpdesk (in addition to Meetecho)

> https://www.ietf.org/media/documents/IETF_2020_Public_Budget_nmHyaCx.pdf <https://www.ietf.org/media/documents/IETF_2020_Public_Budget_nmHyaCx.pdf>
> 

I think you’ve misunderstood.  We are running at a slight loss with some non-meeting costs bundled in with meetings.  If we took those out and reduced meeting income so that the meetings were at break even then that leaves those non-meeting costs not covered.  We cannot assume that ISOC would cover that shortfall if that’s the way we decided to go.

> How about because the world has changed and our ability to have face to face meetings any time soon is unlikely.   This is not business as usual.  It’s unlikely we are going to have any face to fac…

That isn’t a reason for why we need to fundamentally restructure our finances.  Charging a registration fee for IETF 108 puts us in a very similar financial position to that we were in before the pandemic and so with all other things being equal, this is "solved" for now.

If the reason is "well this is how we reduce registration fees to the minimum possible" then let’s start with getting consensus that we should set fees that way and then the LLC can work out how best to fund that.

Jay

-- 
Jay Daley
IETF Executive Director
[email-masked]

---

From: Jay Daley <[email-masked]>
Date: Thu, 4 Jun 2020 15:45:48 +1200

John

> On 4/06/2020, at 3:27 PM, John C Klensin <[email-masked]> wrote:
> 
> 
> 
> --On Thursday, June 4, 2020 09:19 +1200 Jay Daley <[email-masked] <mailto:[email-masked]>>
> wrote:
> 

The intention is that they are time limited as they only apply to early bird registrations, but the text may not have been clear on that.  

> without any fee or need to identify oneself -- still exist?

Not contemporaneously.  Recordings will be posted to YouTube after each session (timing to be operationally determined).

> our being welcoming and would  be independent of the actual

That edge case was not considered.  

Jay

-- 
Jay Daley
IETF Executive Director
[email-masked]

---

From: John C Klensin <[email-masked]>
Date: Thu, 04 Jun 2020 01:18:16 -0400

Jay,

--On Thursday, June 4, 2020 15:45 +1200 Jay Daley <[email-masked]>
wrote:

>> disruptions, one of the features of coming in remotely has
>> been that someone could opt to just watch and listen in real
>> time (i.e., not wait for the YouTube recordings to show up),
>> giving the option of remaining anonymous, etc.  I don't have
>> any data on how often we managed to turn them into active
>> participants but I know there have been people who were
>> encouraged to use that option to understand better how the
>> IETF worked or what a particular WG was doing.     The other
>> was the participant, option which, in recent years, required
>> registering, virtually signing blue sheet approximations,
>> etc. 
>> 
>> (1) With the new fee structure, will the watch/observe option
>> -- without any fee or need to identify oneself -- still exist?
> 
> Not contemporaneously.  Recordings will be posted to YouTube
> after each session (timing to be operationally determined).

Noting first that "operationally determined" has, IIR, sometimes
amounted to a week or so and that the machinery is already in
Meetecho to accommodate (and separate) observers and
participants...

It seems to me that, even more than the decision to charge
remote participants at all, this is really a decision in which
community consensus is needed because it affects the standards
process, the general perception of the openness of the IETF,
etc.  Equally important, there have been multiple discussions
over the years about the importance and value of allowing, nay
encouraging, people to participate as observers in real time.
Is that still important?  I don't know -- you'd have to ask the
community (and not just the IESG).  I can imagine that the worst
possible effects could be mitigated by an IESG decision [1] that
no WG was allowed to make any decisions on its mailing list
until some time after the videos were posted, but I don't
believe the IESG has announced such a decision.  Especially
without the ability to observe meeting sessions and then, if
desired, participate fully on the mailing list --and without the
disability of almost everyone on the mailing list having access
to information that one does not-- we move very much closer to
"pay to play".

And, at least as far as I can tell, this changes the standards
process and who can participate in it as surely as a decision to
impose a fee for posting Internet Drafts or receiving mailing
lists would.  That means you (and the LLC) are making changes to
the standards process, something that the community was assured
when the LLC was created would be permanently out of its scope
and authority.

    best,
     john

[1] I believe that determining the timetables under which WGs
can do work is within the IESG's authority without requiring
evidence of community consensus.  I'm not sure everyone else
would agree.

---

From: Tim Chown <[email-masked]>
Date: Thu, 4 Jun 2020 13:28:44 +0100

> On 2 Jun 2020, at 22:25, Stephen Farrell <[email-masked]> wrote:
> 
> Hiya,
> 

I agree with this, though the IESG may have come to the same conclusion if tasked to consider the matter.

As it stands, WG chairs can presumably schedule interims in place of a slot at IETF 108, if they wish to maximise virtual participation, and avoid clashes with other IETF 108 sessions that may draw important contributors away.

Tim

---

From: Tim Chown <[email-masked]>
Date: Thu, 4 Jun 2020 13:34:42 +0100

> On 3 Jun 2020, at 20:37, Mary B <[email-masked]> wrote:
> 
> Otherwise, I don't see the point in deadlines either. 

I agree.

If t-shirts are an issue, add $20 for those who want one, or whatever the actual cost is with postage and handling time, and keep the costs down.

Tim

---

From: Nick Hilliard <[email-masked]>
Date: Thu, 4 Jun 2020 14:25:26 +0100

Phillip Hallam-Baker wrote on 02/06/2020 17:03:
> beyond, that the IETF business model is predicated on income from 
> in-person meetings that can't now take place and this leaves few options 
> on the table.

there are a lot of ways of looking at this, but there is a human 
interaction issue here.  No-one denies the realities of international 
travel or the obligation of the LLC to implement realistic financial 
policies for the company. In an ecosystem like the ietf, if the decision 
had been handled as soliciting input + getting buy-in, and not as a 
unilateral imposition, I suspect peoples' hackles wouldn't have been 
raised nearly as much.  Downstream, it would have made discussion about 
meetings after 108 much easier.

It's easy to be wise after the fact and also when you're not in the hot 
seat.

My point was simply that we need to approach post-IETF108 meeting 
charges without prejudice to the IETF108 decision, and hopefully also 
learn from it.

Nick

---

From: Robert Raszuk <[email-masked]>
Date: Thu, 4 Jun 2020 16:29:53 +0200

Shouldn't virtual IETF have virtual T-Shirts ? Or if real thing like
mascot  is needed a 3D printer project file such that those who want it can
print it locally.

R.

On Thu, Jun 4, 2020 at 2:37 PM Tim Chown <[email-masked]> wrote:

> If t-shirts are an issue, add $20 for those who want one, or whatever the
> actual cost is with postage and handling time, and keep the costs down.
>
> Tim
>
>

---

From: "tom petch" <[email-masked]>
Date: Fri, 5 Jun 2020 12:32:30 +0100

----- Original Message -----
From: Tim Chown [email-masked]
Sent: 04/06/2020 13:28:44

<tp>
I saw a discussion on a WG list yesterday which I would characterise as

In person meeting; Cost thousands; Timing chosen to suit others
Virtual meeting; Cost hundreds; Timing chosen to suit others
Virtual interim; Cost negligible; Timing chosen to suit us

which makes me wonder if there will be an increase in requests for Virtual interim,  And if they are constrained, will there be an increase in Webex?

Tom Petch

---

Tim

---

From: Andrew Sullivan <[email-masked]>
Date: Fri, 5 Jun 2020 11:30:42 -0400

Hi,

[ObDisclaimer: I am ISOC's CEO, but please note that I am _not_ offering an ISOC position at the moment.]

On Wed, Jun 03, 2020 at 08:07:24PM -0700, Bob Hinden wrote:

>A model where the meetings (face to face or all remote) pay for themselves, and ISOC pays for the rest would work.

I'm sure that would work well for the IETF, but it is not the deal the IETF agreed to when the LLC agreement was established.  The IETF and ISOC came to an agreement based on the then-in-force principles of budgetting, and those were not "ISOC pays for everything other than IETF direct meeting costs".  So if the proposed were the way the IETF wished to budget in the future, it would require some negotiation -- negotiation that I suspect probably cannot be undertaken in time for a July virtual meeting.

(More generally, and not in reference to Bob's message in particular, I'm a little surprised at the degree to which the community wants to manage the LLC on this topic, given the oft-expressed concern during the IASA reform work that the community tended to try to involve itself in details that were really properly a staff question.)

Best regards,

A

-- 
Andrew Sullivan
[email-masked]

---

From: Larry Masinter <[email-masked]>
Date: Fri, 5 Jun 2020 09:41:21 -0700

Andrew wrote, earlier today:
> (More generally, and not in reference to Bob's message in particular, I'm a
> little surprised at the degree to which the community wants to manage the
> LLC on this topic, given the oft-expressed concern during the IASA reform
> work that the community tended to try to involve itself in details that were
> really properly a staff question.)

It should be no surprise that there is globally increased concern
for the stability of institutions like IETF.

It's reassuring to see the bike shed painted beige
--
https://LarryMasinter.net

---

From: Michael Richardson <[email-masked]>
Date: Fri, 05 Jun 2020 14:11:48 -0400

Andrew Sullivan <[email-masked]> wrote:
    > (More generally, and not in reference to Bob's message in particular,
    > I'm a little surprised at the degree to which the community wants to
    > manage the LLC on this topic, given the oft-expressed concern during
    > the IASA reform work that the community tended to try to involve itself
    > in details that were really properly a staff question.)

I'm dismayed, but not surprised.

We often write try to write down in stone the things which we fear (we!)
won't be able to live up to.

--
]               Never tell me the odds!                 | ipv6 mesh networks [
]   Michael Richardson, Sandelman Software Works        |    IoT architect   [
]     [email-masked]  http://www.sandelman.ca/        |   ruby on rails    [

---

From: Brian E Carpenter <[email-masked]>
Date: Sat, 6 Jun 2020 08:40:49 +1200

Andrew,

...
> (More generally, and not in reference to Bob's message in particular, I'm a little surprised at the degree to which the community wants to manage the LLC on this topic, given the oft-expressed conc…

I agree that we (the IETF as whole) must not take over the IAOC's micromanagement role. But what we've really been exploring here is mainly a matter of principle: paying for remote attendance. Obviously, the details are the LLC's province, but I think the matter of principle is a valid community concern.

    Brian

---

From: Stephen Farrell <[email-masked]>
Date: Fri, 5 Jun 2020 22:02:41 +0100

On 05/06/2020 21:40, Brian E Carpenter wrote:
> I agree that we (the IETF as whole) must not take over the IAOC's
> micromanagement role. But what we've really been exploring here is
> mainly a matter of principle: paying for remote attendance.
> Obviously, the details are the LLC's province, but I think the matter
> of principle is a valid community concern.
I very strongly agree.

For example, were paying to attend a WG conference call aka
virtual-interim a requirement, I would likely dial down my
involvement in the IETF. I doubt I'd be alone. Thankfully,
that has not been part of the IETF108 discussion but there
are real policy matters to discuss that are not in the
competence of the LLC or LLC board. Hopefully that'll be
discussed in the putative SHMO WG which is the right way
to handle it.

S.

---

From: Randy Bush <[email-masked]>
Date: Fri, 05 Jun 2020 14:08:07 -0700

> Virtual interim; Cost negligible; Timing chosen to suit us

i am constantly amused that the internet engineering task force tries
to replicate in-person meetings as verbatim as possible.  it's as if
the ietf has yet to discover the internet.  ever read sci-fi where a
culture replicates ancient rituals for which they do not even remember
the reasons?

> which makes me wonder if there will be an increase in requests for
> Virtual interim, And if they are constrained, will there be an
> increase in Webex?

for example, a number of us have stood up jitsi servers.  and there are
https://meet.jit.si, free zoom, et alia, of course.  we even hold
informal ad hoc technical conversations, open cafes, ... without asking
the ruling ietf llc <gasp!>.

the world is changing, whether we like it, or it fits our beloved well
controlled models, or not.

randy

---

From: Robert Raszuk <[email-masked]>
Date: Sat, 6 Jun 2020 00:02:20 +0200

That message says it all !!!

Thank you Randy,
R.

---

From: Brian E Carpenter <[email-masked]>
Date: Sat, 6 Jun 2020 12:07:04 +1200

> controlled models, or not.

Doesn't fix time zones though, which is why primacy of email remains
essential IMNSHO. Otherwise, what you said.

   Brian

---

From: John C Klensin <[email-masked]>
Date: Fri, 05 Jun 2020 21:35:57 -0400

--On Friday, June 5, 2020 11:30 -0400 Andrew Sullivan
<[email-masked]> wrote:

>...
> (More generally, and not in reference to Bob's message in
> particular, I'm a little surprised at the degree to which the
> community wants to manage the LLC on this topic, given the
> oft-expressed concern during the IASA reform work that the
> community tended to try to involve itself in details that were

I want to respond to that comment and that comment alone.  

I can't speak for others and wouldn't try, but I've been trying
to make and preserve an important distinction that the comment
above may obscure.  My understanding of the LLC and the IASA2
documents has been that the LLC is not permitted to make
decisions that change the standards process (or who can
participate in it) at least in non-trivial ways.  Such decisions
have to be made by the community, using ordinary IETF procedures
in ordinary ways.  I also don't believe there is anything in the
LLC documents that permits the LLC, or its contractors or
appointees, to say "this is an emergency and hence we get to
make changes to the standards process especially if those are
just consequences of other decisions".

So, as examples,

(1) The IETF has had a practice (I'd claim a principle) that
people are allowed to observe sessions in real time, without
identifying themselves or paying a fee, since "observe" meant
audio-only and multicast.  Some of us (maybe very few) believe
the availability of that option is key to perceptions of the
IETF being open and key to both the standards process and its
credibility.   Does the LLC get to say "for all-remote meetings
generally, or at least for IETF 108, we are charging for remote
participation and anyone who wants to observe anonymously just
has to wait for the YouTube videos" and to do so without
community discussion of the issues and tradeoffs?  I think that
violates their charter and authority.  YMMD.

(2) The IETF has never charged for active remote participation,
even when someone remote was asking questions via Jabber (or its
predecessors) or having audio (and sometimes video) piped into
the room so they could present.  Some people clearly think that
is as much as a principle (and as important to the standards
process) as the above.  I don't (for reasons that are outside
the scope of this note), but there is certainly enough of a
question there that the decision to charge, without community
discussion, seems like having a discussion about appropriateness
is reasonable.

I think there are also examples on the other side of the
boundary I'm trying to describe.   If things were "normal" and
the LLC were to decide to charge extra for cookies rather than
including them in the registration fee or to offer a discount on
registration for anyone who did not want a tee-shirt, I'd be
very concerned if the IETF felt a need to get involved in those
decisions and even more concerned if there were quibbling about
the amounts.   I would feel much the same way if we were having
a debate about whether the minimum registration fee for IETF 108
should be $100, $230, or $400.  In all of those cases, I think
the community would be within its rights to insist, as a matter
of accountability, on explanations of why particular numbers
were chosen, but that is different from debating the precise
values of the numbers, "managing the LLC", or trying to involve
itself in details that are properly staff functions.

Just my opinion.
best,
   john

---

From: Andrew Sullivan <[email-masked]>
Date: Fri, 5 Jun 2020 23:01:47 -0400

Hi,

[ObDisclaimer: employed by ISOC as CEO.  Not their/an official
opinion, just mine.]

>just consequences of other decisions".

I think we are in complete agreement about that.  To be clear, my
remarks about managing the LLC had much more to do with observations
about how t-shirts should be allocated or delivered or even made,
whether there should be early/standard/late registration, and so on.
I thought we had agreement as part of IASA2 that these are just things
the staff are supposed to decide.  Checking with the community is
correct.  Debates with the Executive Director on the IETF list are
not, if I understood the consensus then (noting that I was not then
judging and do not now wish to judge it).

>audio-only and multicast.

In this case, we may be running up against realities of history and
what was feasible.  I was certainly not around at the time of the
earliest IETFs (my first was 64), but are you really asserting that
the IETF _always_ allowed anyone to go into any meeting without
"joining" in some sense?  I thought the point of the "decisions on the
mailing list" was to avoid this problem?  This is not to discount the
issue that continues to plague the IETF about how decisions are
actually made.  Still: a more-asynchronous and more-distributed form
of work such as is being forced again on the IETF might actually be
salubrious.  It encourages the mode of decision-making that includes
people not actually in the room at a moment, even if mailing lists are
not the ultimate mode by which such decisions ought to be made.  (I
think those are separate questions, much as I personally like mailing
lists as a mode of operation.)

>the room so they could present.

But this way of describing the topic requires "the [real] room" and
"the remote" as distinct entities, with one of them the preferred one
and one a degenerate case.  One might just as easily cast this case
as, "Remote participation as a degenerate case is, for exigent
reasons, over: everyone gets the same experience."  In that case, it's
not that "remote participants" are losing something, but that there is
no class, "remote participants".  In other words, the flattening of
the participation space into a single class means that everyone has to
pay the same ticket, or not be in.  (Again, to be clear, I don't
personally have an opinion about how this ought to go -- I'm not
really a useful attendee in any case.  These are just my personal
observations.)

Best regards,

A

-- 
Andrew Sullivan
[email-masked]

---

From: Randy Bush <[email-masked]>
Date: Fri, 05 Jun 2020 21:41:34 -0700

> Doesn't fix time zones though

let me see if i can push you just a little bit out of the box.  a
small step.

there are two time slots in the day which work for what i call three
continent calls, apac, emea/africa, noam/alyc.  each day a different
wg meets in one of those two slots of *their* choice.  thus the ietf
'meeting' is smeared over three months.

rough example.  not adjusted for 'summer' time and other details

    UTC 22:00
    CET 23:00
    JST 07:00+1
    PST 14:00
    EST 17:00

    UTC 14:00
    CET 15:00
    JST 23:00
    PST 06:00
    EST 09:00

> which is why primacy of email remains essential IMNSHO.

email is good

randy

---

From: "Bajpai, Vaibhav" <[email-masked]>
Date: Sat, 6 Jun 2020 10:47:34 +0000

Hi,

The purchasing power of folks living in developing countries is much less than
that of the developed world. $230 likely is close a monthly-salary (after tax)
of a starting engineer, who likely doesn't get reimbursed for the IETF
participation either.  To be inclusive, perhaps we can think of differential
registration fees for folks based in developing regions.

This is what IEEE/ACM memberships do.

— Vaibhav

>    Full-time Student:  USD 50

------------------------------
Vaibhav Bajpai, www.vaibhavbajpai.com

---

From: Daniel Karrenberg <[email-masked]>
Date: Sat, 6 Jun 2020 13:44:49 +0200

If we want to be *really* inclusive this is required and not optional. 

---
Sent from a handheld device.

> On 6. Jun 2020, at 12:48, Bajpai, Vaibhav <[email-masked]> wrote:
> 
> To be inclusive, perhaps we can think of differential

---

From: John C Klensin <[email-masked]>
Date: Sat, 06 Jun 2020 21:54:13 -0400

Andrew,

First and most important, I think you are helping to identify
the discussion(s) we should be having and trying to separate
those from ones we should skip, leave to staff, and get involved
in only to ensure that staff (and the LLC Board) are
sufficiently accountable to the community (again, different
discussions from e.g., trying to set fee amounts).  I, for one,
appreciate that.

More below about the part of this on which we _might_ not agree.
All of what follows is personal opinion; others may well not
agree.

--On Friday, June 5, 2020 23:01 -0400 Andrew Sullivan
<[email-masked]> wrote:

> "joining" in some sense?

Absolutely not and, if I was not clear about that, I apologize.
We have required registration for attending meetings for as long
as I can remember and have occasionally even had people standing
at doors keeping people out of sessions who don't have badges.
Perhaps oddly given recent discussions, there are at least two
reasons for that which have nothing to do with finances and that
would presumably require that we continue to have a registration
requirement even if the Internet Leprechaun showed up tomorrow
and handed the IETF LLC a sufficiently big pot of gold to pay
all Meeting, Secretariat, and other expenses for the next 50
years.  It is still a bad idea to have anonymous people
influencing that IETF (or any other) standards process and our
IPR rules require for their utility on the ability to identify
Contributors.  At least in theory, we know who is subscribed to
our mailing lists and, a twitch a few months ago
notwithstanding, we do not allow anonymous Internet Drafts.
Some of those activities require payment, some don't.  Whether
some of those -- other than participation in an all-online
meeting -- should require payment is a discussion we can leave
for another day.

That is tied to the reasons I think that the LLC does not need
permission to charge a registration fee for participation in
online meetings.  We have established the principle that
identification and registration of participants is required and
the principle that a fee may be charged for registration.
Applying such a fee to remote participants (and, incidentally to
remote participants in WG interim meetings) may violate
tradition and be a terrible idea (and that may be arguments
about where "pay to play" come in) but I don't think it breaks
any principles.

However, I suggest we have a different set of principles that
apply to use of IETF products and observing its processes.  We
do not charge people (or require that they identify themselves)
to obtain and read RFCs.  We not only do not require that people
pay for Internet-Drafts and other working documents, we don't
restrict access to them to "Members" or identified participants.
And we don't require anyone, even lawyers planning to draw up
into litigation, journalists with a record of hostility toward
the IETF, curious bosses trying to check up on what they are
spending resources when they allow employees to participate in
the IETF, or people who want to observe meetings for a while to
see if they want to participate or advise others to do so, to
identify themselves and/or pay a fee to observe meetings in real
time.

Now that seems to me like a principle, not trying to micromanage
administrative matters.  It even seems like a fairly important
principle.  I am more than a little surprised, in an IETF that
claims that openness about its own work and privacy across the
Internet are important, that the LLC can define anonymous remote
observers in an IETF meeting as an edge case not worth worrying
about if they can pick the videos up on YouTube in a few days.
Or perhaps I misunderstood Jay's comment about that.

>  I thought the point of the "decisions on the
> actually made.

If it works, it solves several other problems.  If it manifestly
does not work, I hope that none of us ever have to answer the
question about who we think we are kidding and, perhaps more
important, look forward to guidance from the IESG about working
groups not taking any actions that might be hard to reverse
prior to minutes and videos being available.  But, again, that
is not my main concern in this note. 

> Still: a more-asynchronous and more-distributed form of work
> such as is being forced again on the IETF might actually be
> salubrious.  It encourages the mode of decision-making that
> includes people not actually in the room at a moment, even if
> mailing lists are not the ultimate mode by which such
> decisions ought to be made.  (I think those are separate
> questions, much as I personally like mailing lists as a mode
> of operation.)
> 
> Indeed, they are separate questions.  But yes.
>  > (2) The IETF has never charged for active remote >
> participation, even when someone remote was asking questions >
> via Jabber (or its predecessors) or having audio (and >
> sometimes video) piped into the room so they could present.
>  But this way of describing the topic requires "the [real]
> room" and "the remote" as distinct entities, with one of them
> the preferred one and one a degenerate case.  One might just
> as easily cast this case as, "Remote participation as a
> degenerate case is, for exigent reasons, over: everyone gets
> the same experience."  In that case, it's not that "remote
> participants" are losing something, but that there is no
> class, "remote participants".  In other words, the flattening
> of the participation space into a single class means that
> everyone has to pay the same ticket, or not be in. 

And a variation on that explanation is connected to why I think
the LLC is within its authority to impose a remote
_participation_ fee.  At the same time (and again with the
understanding that I don't think the same principles apply to
remote _participation_ that apply to remote observers), there
are a non-trivial number of IETF participants who have been
participating remotely for multiple years and who have built
personal (or corporate) budgets and plans around zero-fee remote
participation.   Even if 100% of the community were convinced
that imposing a fee on them (along with everyone else) was
within the LLC's authority, I suggest that it was unwise and bad
for the IETF to effectively tell those people (well, us) to
choose between finding adequate budget on short notice, coming
begging (and hoping that, if the number of people who ask is
more than 100, they get lucky), or deciding that the IETF is
just not where they want to be putting in energy any more.  

Frankly, for me and I assume many of our colleagues from
industrialized countries, the size of this registration fee for
one meeting is unlikely to be an issue but I think we have
participants from developing countries for whom that might not
be true.  More important, if the new plan is "even after we go
back to f2f meetings, everyone who participates pays" the impact
might be significant even for "historically mostly remote"
participants who can shrug off the charge for IETF 108.  So,
since any change that affects who can participate and who cannot
affects the whole of the IETF and the range of perspectives that
go into making our standards, I suggest that, even if there was
no requirement for them to do so, it would have been appropriate
and wise for the LLC to come to the community --as early as it
became clear that, if we were likely to do more than one meeting
online-- and say "fiscally, we are going to need to impose
registration fees for everyone, everyone including those
participating remotely, consider this a heads up and a request
for community input on impact and/or alternatives".  IMO, the
possibility that IETF 107 might not be the last meeting we could
not to f2f was clear, as a possibility, to almost everyone by
the second week in March and such an announcement/ request for
input could have been made then, certainly no later then when
IETF 107 started.  To come to the community at the very end of
May and say, approximately, "this is the decision and we had to
make it without consulting the community because it was an
emergency and there was no time" is, at best, a little
uncomfortable for reasons that have nothing to do with the
calculation of the amounts and other fiscal rules and policies
involved.

best,
   john

---

From: Stephen Farrell <[email-masked]>
Date: Sun, 7 Jun 2020 15:50:26 +0100

Hiya,

> about where "pay to play" come in) but I don't think it breaks

While I agree with a lot of the rest of your email, I don't
agree with the above. IMO, a move from zero to non-zero is
a change that does require community consideration. I don't
think we need to try reconcile those opinions right now (as
there's a putative WG in the offing that'll discuss that)
but just wanted to note that there are, and likely always
will be, grey areas where it's not clear whether or not a
decision is within the LLC's remit. I think in such cases
the LLC needs to consult the IESG and/or community and in
most cases defer to the community consensus, as established
via our usual processes. There are also many non-grey
areas (e.g. t-shirt shipping) where the community ought
not (but will:-) nit-pick, but it's important for the LLC
to make sure to distinguish things where the community
needs a debate before a decision can be made. As there's
no magic rule that distinguishes those cases, this comes
down to experience with this community and judgement.

Cheers,
S.

---

From: Andrew Sullivan <[email-masked]>
Date: Mon, 8 Jun 2020 09:54:15 -0400

Hi,

[ObDisclaimer: still employed by ISOC, still just my opinion]

On Sat, Jun 06, 2020 at 09:54:13PM -0400, John C Klensin wrote:

>Now that seems to me like a principle

I guess what I'm wondering about is the extent to which "in real time" is important there.  Why does it matter whether it happens synchronously or after the video &c is posted, given the differential costs to the IETF in managing an "observers only" stream?  The incremental cost to the IETF of letting anyone at all look at the stream on YouTube or anywhere else is 0, but there are costs involved in creating a second stream just for observers.  "Observe in real time" seems like it might be quite important when people are all in one place and could be having chats on the sidelines (so the "observer" status might be important in that case).  Not so in a virtual context: you can't tell when people are having such side chats, even though they might be, by observing them in real time.

>participation.

Yes, I think that is probably true.  It strikes me that many people's expectations have been thrown out by the COVID-19 situation, and this seems to me like another one: it is possible that, if the IETF decided _more generally_ on a model where charging for remote participation would happen, it ought to be rolled out gradually or at least with warning so that people can adjust budgets appropriately.  But alas, the virus waits for no budget season, so here we are.  

Best regards,

A

-- 
Andrew Sullivan
[email-masked]

---

From: Lou Berger <[email-masked]>
Date: Mon, 8 Jun 2020 10:22:01 -0400

Hi,

On 6/5/2020 11:01 PM, Andrew Sullivan wrote:
> the IETF_always_  allowed anyone to go into any meeting without
> "joining" in some sense?

FWIW I think the principle went beyond just observation.  I remember 
Phil Gross saying, when he was IETF Chair, that the IETF didn't check 
badges at meeting room doors since it was more important to have good 
technical contribution than to block those who couldn't pay.  Of course, 
this didn't mean allowing anonymous contributions or that those that 
payed weren't subsidizing those who didn't.

I personally see having documented fee waivers as consistent with this 
early un-published principle on not checking badges.

Lou

---

From: Ted Hardie <[email-masked]>
Date: Mon, 8 Jun 2020 09:38:17 -0700

On Sun, Jun 7, 2020 at 7:51 AM Stephen Farrell <[email-masked]>
wrote:

> a change that does require community consideration.

As noted earlier, I agree with John on this.  There are two things in
tension here:  a desire to make the IETF as open to participation as
possible and a desire to make the IETF a stable organization.  We've had a
"three-legged stool" version of our funding model for at least as long as
meetecho-style remote participation.  That model has some funding come from
ISOC, some from sponsors, and some from the participants.  If the
participants cease to be a source of funding, there are long-term
implications for how the organizations functions.  If you make up the
difference with increased sponsorship, the pay to play aspects become a
risk ("*Fastly presents the QUIC Multipath working group!  Fastly, we help
good companies do great things.*" being the NASCAR problem writ into our
world).  If you make up the difference from ISOC, you are dependent on both
ISOC's funding sources and continuing priorities.  Andrew has spoken at
length about the need to diversify the funding sources, so I won't go into
it more, but please page that in.  On priorities, I believe ISOC remains
committed to the IETF, but there is an agreement on how that support works;
if participants stopped contributing, I think that would have to get
discussed again.

Or, obviously, you can cut costs.  If we never meet in person, some of the
costs go down by themselves, but there are a bunch that don't:  the cost
per page of RFCs, the work on the datatracker, the work of the secretariat
in supporting the IESG, IAB, and WG chairs.  There's no principle involved
in keeping any of those, but the impact would be quite real and possibly
much more dramatic over time than changing the participation fee structure
in light of a change in participation model.

Achieving the right place among those risks remains an effort at striking a
balance.  If you don't want to see this as a point that continues to be in
contention when striking that balance, then the way forward for you is
clear:  write a document declaring that the fee for remote position should
remain zero for the life of the organization and laying out the principles
for it.  When you have rough consensus for that, you will have demonstrated
that this is a principle, not a consequence of previous tactical
decisions.  I don't, however, think you have demonstrated that now.  It's
certainly tradition, but so are giant buffets of cookies and snacks, and I
don't think public health practice will have them coming back any time soon.

regards,

Ted

> I don't

---

From: John C Klensin <[email-masked]>
Date: Mon, 08 Jun 2020 15:11:56 -0400

--On Monday, June 8, 2020 10:22 -0400 Lou Berger
<[email-masked]> wrote:

>> In this case, we may be running up against realities of
>> history and what was feasible.  I was certainly not around at
>> the time of the earliest IETFs (my first was 64), but are you
>> really asserting that the IETF_always_  allowed anyone to go
>> into any meeting without "joining" in some sense?
> 
> FWIW I think the principle went beyond just observation.  I
> remember Phil Gross saying, when he was IETF Chair, that the
> IETF didn't check badges at meeting room doors since it was
> more important to have good technical contribution than to
> block those who couldn't pay.  Of course, this didn't mean
> allowing anonymous contributions or that those that payed
> weren't subsidizing those who didn't.

We of course blew that principle off when we had a few meetings
in which where badge checks at meeting room doors and we tried
experiments about badge readers at microphones.  And, IIR, we
instituted the former with a lot less discussion and fuss than
the current changes have caused.  I don't know, but I suspect,
that some of the difference is the sudden announcement of a fee
with very little lead time and no opportunity to have the
discussion we are having now.  Yes, as Andrew points out, the
sudden onset of the COVID-19 situation constrains the options
for discussion.  However, the possibility that we would need to
have more than one all-remote meeting was known, and discussed
on this list, even before the decision to convert IETF 107 to
all-remote was made.  And, while I might have misread things, I
thought that, when that decision was made, the message from the
community about planning and discussion was fairly clear.  I may
be repeating myself, but, given the compressed schedule around
the IETF 107 decision, the IESG, IRTF Chair, and the IETF LLC
Board coming together and making that decision seemed perfectly
reasonable to me.  Doing it that way again, and maybe again and
again, seems less so.[1]

Perhaps what concerns me most about the current situation is
that the pressure of time was, in March, a good reason for
making decisions in an ad hoc way and by an ad hoc collection of
people/bodies.  However, given that it was clear to  the
community that we _might_ have to hold additional all-remote
meetings this year (or even sometime), I'm concerned that we are
still proceeding in an ad hoc mode, with claims that the
COVID-19 emergency leaves no time for community input, three
months on.  Could we had today's discussions in late March or
early April?  Yes, I think so and, IIR, people were suggesting
it.  Is the IESG plus the LLC Board plus the IRTF Chair the
right group to be making these decisions?  Should the IAB be
involved other that via the crossover of Chairs and reciprocal
liaisons? Should, for example, the traditional but
self-constituted Thursday evening draft evaluation group be
consulted -- certainly their work is significantly impacted by a
shift to all-remote meetings?  No, I'm not serious about the
latter and maybe the current group is the right group to be
making these decisions, but, in the context of the IETF, a group
coming together and announcing that there is an emergency and
they have decided they are in charge should not turn them into a
permanent decision body without community discussion and
consent.  

Similarly, the LLC Board, as I have understood it, is supposed
to be responsible for thinking about things strategically and to
be at least minimally accountable to the community for that
thinking.  We aren't seeing much evidence of strategic thinking
and planning that should have, IMO, been well underway in March.
Instead, we are seeing announcements of fees and associated
arrangements with the same "emergency", "we have decided", and
"no time to consult the community, even about principles"
discussion we saw in March.

Probably all of that, including the fee arrangements, are
irreversible (and unlikely to cause any permanent harm), but it
would be good for us to hear from the people and groups involved
about their plans to prevent this -- specifically the assertion
that decisions with potential impact on principles and/or the
standards process can and should be made by claiming an
emergency and time pressures that could not be anticipated--
from happening again.   The way that IETF 107 decisions were
made was a legitimate response to a crisis that could not have
been anticipated.  Maybe (although I obviously doubt it), so was
the decision about IETF 108.  But, if we end up having the same
process and discussion-making in October, that would have the
ring of top-down governance with, e.g., a Nomcom appointment
conveying "do what thou wilt" auth0rity.

> I personally see having documented fee waivers as consistent
> with this early un-published principle on not checking badges.

Really?  With an upper limit of 100 such waivers and a lottery?
Is that more fair than someone dropping a note to Phill or one
of his successors saying "I don't have funds to get to this
meeting, can you waive the registration fee"?  Probably.
Certainly more transparent and immune from claims of favoritism
or abuse.  And maybe only 96 people will ask and no one will be
deterred from asking because, while they can't afford the fee,
they either feel that it would be better to just not participate
than to ask or that they should not ask because someone in even
more difficult circumstances might be cut off?  Don't know.
Given those possibilities, would it have been better, if there
are 150 applicants, to announce that (at least to the
applicants) and give people a chance to voluntarily withdraw
their requests?   I don't know about that either, nor do I know
if that sort of option was considered; what I do know is  that
there as been zero opportunity for meaningful and effective
community discussion and input.

And, again, I'm less concerned with trying to second-guess the
decisions with registrations supposedly opening this week than I
am about making sure that we don't do things this way again.
And, in that regard, "Finally, please note that no decision has
been made on whether or not a fee for online participation is
needed when we return to in-person meetings." [2] is not
comforting.  I'm certain it is true and therefore that it is a
reasonable thing to say.  However, in the absence of mention of
any other process to revisit models or made decisions, it can
reasonably be interpreted as "the way we made these decisions is
the way we intend to do it in the future".   And, whether we
agree about the waiver plan as appropriate mitigation of a
suddenly-imposed fee, one agrees with Stephen and any myself
about whether the LLC has the authority to make the binary
"charge or no charge" decision about remote participants, or how
one feels about whether (as Andrew asked) observing in real time
is an important principle for all-remote meetings, I hope that
at least most of us can agree that those are legitimate
questions for us to expect the community to be able to address
[3] even if the dollar amounts of the fee structure are issues
that we have delegated to the LLC (and that should stay
delegated).

thanks,
   john

[1] I am not ignoring the SHMO proposal.  But, "let's make a WG
and see if we discuss it there" would also have been reasonable
in March.  Instead, a mailing list was created to discuss the
relevant issues (fine plan) and now that mailing list is being
charged with designing a charter for that WG.  Under normal
circumstances, another fine plan.  But, unless there is a firm
commitment to accelerate things and a plan about doing that, the
IETF's "normal" in recent years would predict some time for
discussions, a BOF at IETF 108 if the discussions on manycouches
[4] converge in the next four days and otherwise at IETF 109,
creation of the actual WG, and...   I hope that Alissa's plan
(per her note on the 3rd) to move toward SHMO chartering this
week without a BOF will eliminate that potential problem but it
would be truly unfortunate if it got to be 2021 and we were
still making decisions on an ad hoc basis with the reason being
"waiting for the WG" rather than "emergency".  

[2]  https://www.ietf.org/blog/ietf108-registration-fees/

[3] I note that Jay has pointed out, on-list, that the decision
and fee structure model used for IETF 108 could easily be
adapted for future meetings.  I took that as just a default (and
an obvious one) so have no problem with his pointing it out.
But, absent a statement about community review of principles or
a plan for asking for and getting community input, it would
appear that the decisions about principles are out of the
community's hands.

[4] Interestingly, the "manycouches" list does not appear on
https://datatracker.ietf.org/list/nonwg, perhaps because it was
announced as a design team effort rather that a discussion group
for potentially forming a WG.

---

From: Jay Daley <[email-masked]>
Date: Tue, 9 Jun 2020 11:06:46 +1200

John

> On 9/06/2020, at 7:11 AM, John C Klensin <[email-masked]> wrote:

I think you are significantly underestimating the level of work that we have had to put into planning in a very short time in response to a global crisis that has taken a new trajectory almost every week.  

One of the first things we had to do was to establish a sound foundation on which to assess if an in-person meeting can go ahead or not - the go/no-go framework.  If you recall, that was not a simple matter and took a lot of work to produce and a fair amount of community engagement.

The second thing was to understand what the community wanted of an online meeting - what it should contain, how it should be structured, when it should operate and so on - without time for the community to deliver that as consensus guidance.  That was addressed through the survey, which was a very large piece of work.  At that stage we needed to know what form of meeting, if any, we were expected to operate before we could work out costs/sponsorship/fees, and so only one question in the survey addressed fees.  (I’m glossing over the different responsibilities of the IESG and LLC in this as they're not relevant to the key points about resourcing and dependencies).

Yes, we could have started earlier to unpick the issues of principle around charging and the practical impact of some of the edge cases, and that’s on me for not being familiar enough yet to understand the need for that.  Other than the one prescient comment on list in March [1] there was no mention of this in the community that might have alerted me otherwise.

Having said that, I’m not sure it would have been wise for the LLC to lead that.  You may have seen from the Many Couches list that a few people including the IETF Chair drafted a proposed charter [2] some weeks ago for a new WG (Stay Home Move Online) to look at all of these issues and provide community guidance to the IESG and LLC, though including fees in the scope came later [3].  This is the best approach by far as the guidance is consensus guidance and because it ensures that we don’t run into a tail-wagging-dog scenario if instead the LLC had led that conversation.

Jay

[1]  https://mailarchive.ietf.org/arch/msg/ietf/JPJQkY93oeaDKX9L0Li-YIjyQ4k/
[2]  https://datatracker.ietf.org/doc/charter-ietf-shmo/ 
[3]  https://mailarchive.ietf.org/arch/msg/manycouches/qkUNflWL1XcxGxrtu8XVvGqdeQQ/

-- 
Jay Daley
IETF Executive Director
[email-masked]

---

From: S Moonesamy <[email-masked]>
Date: Tue, 09 Jun 2020 10:56:32 -0700

Hi Bob,
At 08:07 PM 03-06-2020, Bob Hinden wrote:
>Charging different rates based on when you register doesn't have 
>much effect on this.   You need the same level of support 
>independent of when people register and how much they pay.   I bet 
>you have a good idea of how many people will attend independent of this.

My guess is that the number of previous remote attendees will 
decrease to around 150.  Revenue projection would be around 
$150,000.  I did not factor in a new restriction [1] as I only 
noticed it a few minutes ago.

Regards,
S. Moonesamy

1. The IETF is prohibiting the distribution or broadcasting of 
recordings of the events without written consent.

---

From: Carsten Bormann <[email-masked]>
Date: Tue, 9 Jun 2020 20:23:50 +0200

On 2020-06-08, at 21:11, John C Klensin <[email-masked]> wrote:
> the current changes have caused. 

Badge readers always were optional (I never managed to properly operate one).

Badge checks were a one-time thing needed for a meeting in a country that made this a prerequisite for Internet access.  I think we accepted that regression as the one-time thing it was because Internet access is something very unusual in that country and we were very happy to be able to meet there.

No, we did not “blow that principle off”.

Grüße, Carsten

---

From: John C Klensin <[email-masked]>
Date: Tue, 09 Jun 2020 15:06:30 -0400

Carsten,

I was at both meetings and concurred with the decisions.  "Blow
off" was probably too strong, but, as best, those examples
demonstrate that we have been willing to be flexible and
pragmatic about those principles.  However, that pragmatism
takes us back to the underlying questions about scope and
authority.  If the principles are treated as firm (or we review
the decision-making in those cases and discover that there was
strong consensus about the exceptions and that they were
one-time events), then, for example, deciding to charge for
remote participation is a binary decision on which the community
should (or maybe MUST) be consulted.   It the principles are
flexible given special conditions, then, as long as is is a
one-time decision that does not set precedents or mark a
permanent change, it is perfectly appropriate for Jay, or the
LLC generally, to say "unusual situation, no time for adequate
consideration, let's impose the charge and watch to see if there
are ill effects from which we should learn".  To a first-order
approximation, that is what has been said.

YMMD.
    john

--On Tuesday, June 9, 2020 20:23 +0200 Carsten Bormann
<[email-masked]> wrote:

>> We of course blew that principle off when we had a few
>> meetings in which where badge checks at meeting room doors
>> and we tried experiments about badge readers at microphones.
>> And, IIR, we instituted the former with a lot less discussion
>> and fuss than the current changes have caused. 
> 
> Badge checks were a one-time thing needed for a meeting in a
> country that made this a prerequisite for Internet access.  I
> think we accepted that regression as the one-time thing it was
> because Internet access is something very unusual in that
> country and we were very happy to be able to meet there.
> 
> No, we did not "blow that principle off".
> 
> Grüße, Carsten
>

---

From: John C Klensin <[email-masked]>
Date: Tue, 09 Jun 2020 15:15:59 -0400

--On Tuesday, June 9, 2020 10:56 -0700 S Moonesamy
<[email-masked]> wrote:

>> Charging different rates based on when you register doesn't
>> have  much effect on this.   You need the same level of
>> support  independent of when people register and how much
>> they pay.   I bet  you have a good idea of how many people
>> will attend independent of this.
> 
> decrease to around 150. 

Just for clarification, by "previous remote attendees", you mean
people who have regularly been attending remotely for some time
and not just, for example those who remotely attended IETF 107?
Right?  Or, if not, can you explain?  

> I did not factor in a new restriction [1] as I only

See separate thread that I'm about to start.

best,
    john

---

From: Michael StJohns <[email-masked]>
Date: Tue, 9 Jun 2020 15:29:03 -0400

> Badge checks were a one-time thing needed for a meeting in a country that made this a prerequisite for Internet access.  I think we accepted that regression as the one-time thing it was because Int…

To be clear here (and I believe this is correct) - we - the IETF - did 
not impose the badge checks.   AFAICT they were hired without knowledge 
or consent of the IETF and just appeared.   In one case, possession of 
the badge was not sufficient for entry - the badge checkers refused 
entry when the badge did not match the (local) person.

And I would argue that "we were very happy to be able to meet there" was 
not a universally held emotion.

---

From: S Moonesamy <[email-masked]>
Date: Tue, 09 Jun 2020 12:49:05 -0700

Hi John,
>Right?  Or, if not, can you explain?

Remote attendees would be people who usually attend remotely, people 
who attend one meeting remotely and people attending meeting when it 
is relevant to them.  I did not rely on the IETF 107 figures only.

>See separate thread that I'm about to start.

Ok.

Regards,
S. Moonesamy

---

From: Tim Chown <[email-masked]>
Date: Thu, 11 Jun 2020 10:11:32 +0100

> On 6 Jun 2020, at 05:41, Randy Bush <[email-masked]> wrote:
> 

Indeed!

Keep pushing.

And this would win us a schedule free of WG meeting clashes, and avoidance of several hundred drafts being published in 24 hours with very little hope of reading the ones that interest you before the WG meeting.

Many WGs are already embracing more frequent online interims, so “smearing” the work is already happening.  The question is whether some structure like the above is preferred, or ad-hoc meetings as and when each WG wants them.

Tim

---

From: Randy Bush <[email-masked]>
Date: Thu, 11 Jun 2020 05:01:42 -0700

> And this would win us a schedule free of WG meeting clashes, and
> avoidance of several hundred drafts being published in 24 hours with
> very little hope of reading the ones that interest you before the WG
> meeting.
> 
> Many WGs are already embracing more frequent online interims, so
> “smearing” the work is already happening.  The question is whether
> some structure like the above is preferred, or ad-hoc meetings as and
> when each WG wants them.

an example

https://ooni.org/post/2020-internet-measurement-village/#schedule

TMA2020, which i am attending as i type, is a more classic format,
mixing zoom and slack, and is time skewed somewhat to try to have a
timezone footprint which is not too onerous for asia and the americas.
but they tried to innovate in the discussions, per-paper slack channels,
interactive q&a, etc.

maybe the hardest part is what our community refers to as 'the hallway.'
i am looking for communities trying to innovate in this space.  imiho,
this is really important.  i can read your paper/draft/...  and zoom +q
interaction is about as good as the mic line.  but hanging out,
discussing, gossiping, ...  is more important to us funny monkeys the
tools seem to support.

randy

---

From: Colin Perkins <[email-masked]>
Date: Thu, 11 Jun 2020 13:20:03 +0100

> On 11 Jun 2020, at 13:01, Randy Bush <[email-masked]> wrote:

I’ve seen a couple of conferences using gather.town – there’s a video from PLDI at https://www.youtube.com/watch?v=Y0xZLJVhzPc that talks about their plans.

We’ve had some discussion of trying it with IETF, although it’s not clear it’ll work at the scale we need.

Colin

---

From: Tim Chown <[email-masked]>
Date: Thu, 11 Jun 2020 13:29:43 +0100

> discussing, gossiping, ...  is more important to us funny monkeys the

Someone pointed me at this recently.  

https://www.youtube.com/watch?v=Y0xZLJVhzPc

OK, a bit of a twee blend of retro rpg and video, but a nice concept imo.  

I’ve also seen one where you can move around and the volume of other people is reduced the further you are from them, so you can self organise into group who can only hear/see each other.

As you say, that type of innovation is badly needed as the hallway / coffee table / bar interactions are so useful.

Tim

---

From: Randy Bush <[email-masked]>
Date: Thu, 11 Jun 2020 05:51:02 -0700

> I’ve seen a couple of conferences using gather.town – there’s a video
> from PLDI at https://www.youtube.com/watch?v=Y0xZLJVhzPc that talks
> about their plans.

pldi tried a couple of things worth the look

i am willing to try https://gather.town/ in the next tma break

> clear it’ll work at the scale we need.

imiho, you do not need room for more than a couple of dozen folk in a
hallway conversation

btw, credit in this space to lisa dusseault for trying to get ietf folk
to try second life

randy

---

From: Samuel Weiler <[email-masked]>
Date: Thu, 11 Jun 2020 15:36:16 -0400 (EDT)

On Tue, 9 Jun 2020, Carsten Bormann wrote:

> Badge checks were a one-time thing needed for a meeting in a country 
> that made this a prerequisite for Internet access.  I think we 
> accepted that regression as the one-time thing it was because 
> Internet access is something very unusual in that country and we 
> were very happy to be able to meet there.

I also remember badge checks being a only-one-time thing, though 
there might be some confusion about the history.

A code was needed for network access at TWO meetings, and (IIRC) that 
code was printed on our badges.  We tested that system at IETF78 in 
Maastricht in July 2010 then used it at IETF79 in Beijing.

Badge checks happened at only one meeting - IETF79 in Beijing.  The 
IAOC explained that they were imposed by the host and/or hotel, not 
the IETF.  (We got different answers about who imposed it, and, as far 
as I recall, never a definitive one.)  As John observes, this checking 
was indeed implemented with little discussion - the IAOC implied and 
perhaps said that even they were not consulted, and the community was 
certainly not consulted.  And at least some of us were not complacent 
about it.  I raised it in the plenary, and I and others raised it on 
this list.

In any case, I think the Beijing debacle does not set precedent, since 
that requirement was imposed by someone other than ourselves.  Badge 
checking is not normal practice at a normal IETF meeting.  And the 
Beijing meeting was not normal.

Excerpts from the archives:
https://mailarchive.ietf.org/arch/msg/ietf/1lrhHGPg0ejrkkqfk0WYIm891eQ/
https://mailarchive.ietf.org/arch/msg/ietf/dZX08hYhXyjUEAecTlGoM63dTjw/

As for the present discussion, I am deeply concerned about the 
process, also.  My first instinct is that we should not charge a fee 
for this meeting, but, if we do, we need community consensus around 
it first.

-- Sam Weiler

---

From: Scott Kitterman <[email-masked]>
Date: Thu, 11 Jun 2020 16:20:02 -0400

> Beijing meeting was not normal.

The IETF held the meeting there knowing what the requirement would be, so no.  
The IETF made the choice.  Every location is different.  When the IETF decides 
to meet somewhere, then the IETF has determined that local conditions are 
acceptable.

Scott K

---

From: Samuel Weiler <[email-masked]>
Date: Thu, 11 Jun 2020 17:04:25 -0400 (EDT)

> to meet somewhere, then the IETF has determined that local conditions are

We knew about the network access control requirement (as demonstrated 
by the experiment in Maastricht).  We did not know about the badge 
police.

-- Sam

---

From: Ole Jacobsen <[email-masked]>
Date: Thu, 11 Jun 2020 14:09:19 -0700

Right, but we learned an important lesson: Access to the meeting *area* is useful
not just for attendees, but also for their companions. Thus was born the now official
Companion Program which is not a free ticket to the meetings, but does (for a modest fee)
give access to the meeting area and even the opening reception.

Ole

> On 11 Jun 2020, at 14:04, Samuel Weiler <[email-masked]> wrote:
> 
> We knew about the network access control requirement (as demonstrated by the experiment in Maastricht).  We did not know about the badge police.
> 
> -- Sam
> 

Ole J. Jacobsen
Editor and Publisher

---

From: Jay Daley <[email-masked]>
Date: Fri, 12 Jun 2020 14:03:02 +1200

> On 12/06/2020, at 12:51 AM, Randy Bush <[email-masked]> wrote:
> 

Someone pointed us to this a while ago and we met with one of the principals there a couple of weeks ago to understand how we might be able to use it.  It’s affordable but they require some form of authentication integration for large gatherings and we don’t like their current option for privacy reasons and so they are looking at new options.

We’re hoping to get to the stage where we can do an open test, before IETF 108 to see if is suitable to trial during the meeting.

Jay

-- 
Jay Daley
IETF Executive Director
[email-masked]

---

From: Larry Masinter <[email-masked]>
Date: Fri, 12 Jun 2020 13:37:56 -0700

IMNSHO I don’t think pursuing awkward 2D MMORPG-style interaction is useful.
gather reminds me most of 1990’s PARC spin-off PlaceWare.

I’m sure you are busy.

For moving IETF online, I’d suggest hiring some group that does it  for a living

https://www.diplomacy.edu/conference-tech-lab

in consultation with IETF in an open transparent manner, of course.

What is the value of a test without any criteria for success?

Jay

---

From: John C Klensin <[email-masked]>
Date: Fri, 12 Jun 2020 18:05:16 -0400

--On Friday, June 12, 2020 13:37 -0700 Larry Masinter
<[email-masked]> wrote:

>...
> For moving IETF online, I'd suggest hiring some group that
> does it  for a living
> 

Larry, that path leads to a rathole-rich environment with very
smart and well-fed rats. Among other things, I note that Diplo's
list does not include Meetecho, which I believe IETF chose for
good reasons and with the limitations of other systems for our
purposes in mind and then, more important, assorted people
(including Ray and the Secretariat) worked closely with the
developers to further adapt to our needs.

Moreover, unless something has changed that you or Jay know
about but I don't, prior experience with Meetecho strongly
suggests that, if we discover deficiencies that we would like to
have corrected before IETF 108 and give them reasonable notice,
the chances of getting those changes made are quite good.
Having tried, in non-IETF contexts, to work with the providers
of three or four of the systems Diplo lists to get bugs or
unfortunate features fixed, a year or two might be plausible,
but not six weeks... unless , of course, one is a government
making demands and/or threats.

It seems to me that Jay has, to his credit even if he has not
gotten it right every time, been struggling to avoid such
ratholes.  If nothing else, even if Diplo were a perfect match,
there almost certainly is not enough time to work out a contract
with them, have them understand our needs, adjust fees as
needed, and then go into a meeting that is now only six weeks
away without creating unacceptable risk.

So, at minimum, can we postpone that particular discussion until
we get through IETF 108 and can start assessing what we learned
and what to do next?

thanks,
   john

---

From: Randy Bush <[email-masked]>
Date: Fri, 12 Jun 2020 16:01:15 -0700

> IMNSHO I don’t think pursuing awkward 2D MMORPG-style interaction is
> useful.  gather reminds me most of 1990’s PARC spin-off PlaceWare.
> 
> For moving IETF online, I’d suggest hiring some group that does it for
> a living https://www.diplomacy.edu/conference-tech-lab

looks like commercial folk who dress well consulting to help you select
from 1990s 2d mmorpgs, particularly the commercial ones owned by big
corporates.  that will fit well in to the new ietf corporate model.

lisa actually tried to get open standards 3d mmorpg going, but ietf was
not interested.

randy

---

From: Larry Masinter <[email-masked]>
Date: Fri, 12 Jun 2020 16:08:51 -0700

"I believe IETF chose for good reason" doesn't sound open or transparent.

Why don't we focus on what are the unique IETF technical requirements
that would drive a system choice?  Are they listed in the
conference-tech-lab's
list of things to consider?  Something that the system chosen uniquely
meets?  Those considerations are important to capture, and would
then become part of the RFP. Surely if they can run a conference
using any of the listed systems, they could run one using meetecho too.

I'd think we'd want to contract with SOMEONE to actually manage
logistics, rather than roll our own, in a hurry.

> From: John C Klensin <[email-masked]>
> Sent: Friday, June 12, 2020 3:05 PM
> To: Larry Masinter <[email-masked]>; 'Jay Daley' <[email-masked]>
> Cc: 'IETF Rinse Repeat' <[email-masked]>
> Subject: RE: Registration details for IETF 108
> 
> 
> 
> --On Friday, June 12, 2020 13:37 -0700 Larry Masinter <[email-masked]>
> wrote:
> 
> >...
> > For moving IETF online, I'd suggest hiring some group that  does it
> >for a living
> >
> Larry, that path leads to a rathole-rich environment with very smart and
> well-fed rats. Among other things, I note that Diplo's list does not
include
> Meetecho, which I believe IETF chose for good reasons and with the
> limitations of other systems for our purposes in mind and then, more
> important, assorted people (including Ray and the Secretariat) worked
> closely with the developers to further adapt to our needs.
> 
> Moreover, unless something has changed that you or Jay know about but I
> don't, prior experience with Meetecho strongly suggests that, if we
discover
> deficiencies that we would like to have corrected before IETF 108 and give
> them reasonable notice, the chances of getting those changes made are
> quite good.
> Having tried, in non-IETF contexts, to work with the providers of three or
> four of the systems Diplo lists to get bugs or unfortunate features fixed,
a
> year or two might be plausible, but not six weeks... unless , of course,
one is
> a government making demands and/or threats.
> 
> It seems to me that Jay has, to his credit even if he has not gotten it
right
> every time, been struggling to avoid such ratholes.  If nothing else, even
if
> Diplo were a perfect match, there almost certainly is not enough time to
> work out a contract with them, have them understand our needs, adjust fees
> as needed, and then go into a meeting that is now only six weeks away
> without creating unacceptable risk.
> 
> So, at minimum, can we postpone that particular discussion until we get
> through IETF 108 and can start assessing what we learned and what to do
> next?
> 
> thanks,
>    john

---

From: Ole Jacobsen <[email-masked]>
Date: Fri, 12 Jun 2020 16:14:30 -0700

Larry,

The history of the relationship between the IETF and “The Meetecho Guys” goes back a decade or more. They have been working closely with the NOC and others to tailor the system to our needs.

Ole J. Jacobsen
Editor & Publisher
The Internet Protocol Journal
Cell: +1 415 370-4628
T-Mobile: +1 415 889-9821
Docomo: +81 90 3337 9311‬
http://protocoljournal.org

Sent from my iPhone

> On 12 Jun 2020, at 16:09, Larry Masinter <[email-masked]> wrote:
>

---

From: Brian E Carpenter <[email-masked]>
Date: Sat, 13 Jun 2020 14:43:55 +1200

>> that would drive a system choice? 

As I understand it, that -- exactly that -- drove the choice to work with Meetecho.

Regards
   Brian Carpenter

On 13-Jun-20 11:14, Ole Jacobsen wrote:
>>> year or two might be plausible, but not six weeks.... unless , of course,
>> one is
>>> every time, been struggling to avoid such ratholes..  If nothing else, even
>> if

---

From: Michael Richardson <[email-masked]>
Date: Sat, 13 Jun 2020 17:20:46 -0400

> making demands and/or threats.

And, I think that I need to repeat that I was unable to file a real bug
report when webex stopped working for desktops with public IPv4.
I got no acknowlegement of my bug, and I have no idea what the problem is.
It's been like 6 weeks now.
And it's not like we don't know people who know the webex people.
I'm hardly surprised that zoom ate their lunch.
I am observing many paying customer abandonning gotomeeting; I'm not sure
why exactly, as it had a lot of advantages.

Allusions were made that it's my browsers' fault, but I note that all the
other webrtc based services continue to function fine.  Some even prefer IPv6.

I guess I can try removing my mitigation during the next call I'm involved
in, and see.

--
Michael Richardson <[email-masked]>, Sandelman Software Works
 -= IPv6 IoT consulting =-

---

From: Michael Richardson <[email-masked]>
Date: Sat, 13 Jun 2020 17:23:19 -0400

> lisa actually tried to get open standards 3d mmorpg going, but ietf was

I don't think that is accurate.
Randy, it's not always the IETF that is problem.

From what I could tell, none of the participating companies wanted to ceed
revision control to the IETF, let alone adopt a system that might be based
upon their competitors specifications.

---

From: Larry Masinter <[email-masked]>
Date: Sat, 13 Jun 2020 16:00:20 -0700

Sorry for not being clear...I have no problem with MeetEcho or the way it was chosen.

But it seems like there is more to be learned from 108 as an experiment
More than "did it work?" but certainly paying attention to those
who have technical difficulties with remote participation.
What are the unique IETF requirements.  Queue management?
https://www.w3.org/2001/12/zakim-irc-bot.html integration?

pre-meeting testing? Survey meeting attendees about quality problems,
correlate with WebRTC test tools?
--
https://LarryMasinter.net https://going-remote.info

---

From: Randy Bush <[email-masked]>
Date: Sat, 13 Jun 2020 21:06:45 -0700

> Allusions were made that it's my browsers' fault, but I note that all
> the other webrtc based services continue to function fine.  Some even
> prefer IPv6.

these days, one needs three or four browsers to get to all the j random
web sites and service one needs in a norlam day.  and we've become
inured to it.

but my fave of 2020 so far is that i successfully receive email from
chase visa that they failed sending email to me to say that my paperless
statement is ready.

there might be a place for a standards organization for this internet
thing.

if the compatibility mess gets below layer seven, things are gonna get
really ugly.  we'll need translators, transition mechanisms, ...  oh
wait.

randy

---

From: Phillip Hallam-Baker <[email-masked]>
Date: Thu, 18 Jun 2020 11:00:49 -0400

> there might be a place for a standards organization for this internet

SMTP was designed to support exchange of inter-office memos. While it has
been used for much more it really isn't fit for those purposes. Nor do
S/MIME or OpenPGP or STARTTLS really address what is needed.

As folk know, I keep a list of expiring patents I consider to be
significant. A short while before it happened, I told people that Haber
Stornetta was about to expire and we should take a serious look at the
opportunities. That is the blockchain patent.

There is another patent even more interesting that has now expired:
Micali's fair exchange with invisible trusted third party. This allows
Alice to send a message to Bob such that Bob can read it if and only if Bob
provides a receipt. The TTP is only involved in the case that Alice defects
and does not release the decryption key after Bob signs the receipt.

Now replacing SMTP is obviously futile, a non starter. There is too much
water under that bridge. But deploying a new open transactional messaging
system that is designed for purpose of transactional email is certainly not
futile. In fact it is something we clearly need now that the business
processes exist that can leverage it.

And of course, if enough people have an app that supports the transactional
messaging protocol, it can be used in place of SMTP. Like the fax machine,
SMTP will never completely disappear but there is a good chance that we can
obsolete it.

Deployment is hard. But we did manage to deploy the Web despite the clients
being technically less slick than Hyper-G, despite Adobe Acrobat having the
commercial support, despite the academics rejecting the paper to Hypertext
'92.

Oh and the same client has a second factor auth capability, a true end to
end password manager and supports management of all your PGP web o' trust
by means of in person QR code exchange, among other things.

---

From: Michael Richardson <[email-masked]>
Date: Thu, 18 Jun 2020 14:36:37 -0400

Phillip Hallam-Baker <[email-masked]> wrote:
    > Alice to send a message to Bob such that Bob can read it if and only if
    > Bob provides a receipt. The TTP is only involved in the case that Alice
    > defects and does not release the decryption key after Bob signs the
    > receipt.

    > Now replacing SMTP is obviously futile, a non starter. There is too
    > much water under that bridge. But deploying a new open transactional
    > messaging system that is designed for purpose of transactional email is
    > certainly not futile. In fact it is something we clearly need now that
    > the business processes exist that can leverage it.

I want to say two interpretations, and I'd like you to pick one or the other:

1) SMTP in unreplacebale, but (S)MIME format email can be replaced,
   being a different media type across SMTP. (Possibly a new verb
   replacing MAIL To)

2) SMTP as a transport could be augmented with some transactional message
   system, that in the end moved (S)MIME formatted emails.
   This is in much the way that HTTP has reused headers... (but HTTP/2)

    > Oh and the same client has a second factor auth capability, a true end
    > to end password manager and supports management of all your PGP web o'
    > trust by means of in person QR code exchange, among other things.

:-)

---

From: Phillip Hallam-Baker <[email-masked]>
Date: Thu, 18 Jun 2020 22:25:47 -0400

>    This is in much the way that HTTP has reused headers... (but HTTP/2)

Neither. But a little bit of the second.

I started off looking at the problem of how to make management of
credentials for OpenPGP and S/MIME so easy and transparent that people
could make use of end to end encrypted email without having to think about
it. Zero extra effort.

So lets say we meet in person at IETF, I present my iPhone to you with a QR
code, you scan it with your android and we both come away with a complete
contact record for the other, our S/MIME, OpenPGP, Signal, etc. etc. keys
and the means to update them as they change for life (or until one or other
of us decides to drop the connection).

[We can do other forms of exchange but lets leave that for now]

OK so now we can do end to end email over SMTP if we like. But here is the
problem, the infrastructure I need to support that contact exchange scheme
and do it really right is a messaging infrastructure in its own right. And
it has access control so people can't send me email unless I authorize them
to. So no spam. And the messages are limited to 32KB so the inbox doesn't
get clogged up because some twit sent a huge message (anything longer has
to be pulled).

So basically, fixing SMTP means that we end up building a second scheme and
doing it right.