Subject: Re: Consultation on *revised* IETF LLC Draft Strategic Plan 2020

From: Stephen Farrell <[email-masked]>
Date: Wed, 3 Jun 2020 15:26:43 +0100

Hiya,

I re-read [3] and it is much improved, thanks.

I do have a few remaining comments:

- The word "privacy" doesn't appear. That needs to be fixed,
to provide the proper balance vs. things like: "Sufficient
high-quality data on participants their activities,
motivations, expectations, etc to support an evidence-led
culture." I'd say the way to do that is to make a generic
statement that the LLC aims to honor the privacy expectations
of the IETF community - those vary a lot but we are and should
be a picky crowd when it comes to this topic. (Sorry for not
noticing this in my earlier review.)

- I can't see how all the stuff about "participant journey"
isn't either waffle or over-reach, e.g. if "Fully documented
participant journey" meant that the someone thinks IETFers are
going to only follow paths set-out in such a document, that's
silly and over-reach. If it doesn't mean that then what's it
for? I suggest removing the term and replacing each occurrence
with whatever is really meant in each case (or with nothing).
(And then re-reviewing.)

- Saying "LLC strategy closely aligned with the strategic
objectives of IESG, IRSG and IAB" still indicates a fundamental
misunderstanding IMO. Those bodies cannot, collectively, have
an agreed set of such "strategic objectives" at any given
moment in the sense meant here. ISTM that baking that error
into the LLC's strategy is likely to lead to over-reach as
the LLC "extrapolates" from something that can never exist.
I'd suggest just deleting the offending statements would be
best.

Cheers,
S.

On 03/06/2020 04:04, IETFExecutive Director wrote:
> The IETF Administration LLC began a consultation on its Draft
> Strategic Plan 2020 [1] on 4 May 2020 and in response to the issues
> raised so far [2], has developed a revised draft [3] with some
> substantial changes.  Consultation on this revised draft will
> continue until Monday 15 June 2020 and may be extended longer if
> required.
> 
> The strategic plan is made up of the following elements, all of which
> are being presented for comment:
> 
> 1. Linkages.  The organisations and communities that the IETF LLC is
> linked to and how that linkage is the top-level driver of the IETF
> LLC strategy. 2. Mission.  This is a literal definition of what the
> IETF LLC does.  The mission rarely changes in the lifetime of the
> company. 3. Values.  These define how the company behaves as it
> follows its mission. These may change over time to reflect broader
> social changes. 4. Strategic Goals.  The highest priority goals of
> the IETF LLC.  These may be short-, medium- or long-term goals or a
> mix.  These are the big picture of what the IETF LLC is aiming to do
> in the next 3-5 years and so are the key setting that the board
> expects the company to follow. 5. Strategic Transformations.  These
> detail the changes that need to be made in order to achieve the
> strategic goals.   Each transformation details the current state and
> the desired state to transform into. These transformations should be
> achievable within 1-3 years.
> 
> If you have any comments or questions then you can submit those by
> any of the following methods:
> 
> * Raising an issue on the Github repository * Direct to me at
> [email-masked] * Direct to the IETF LLC Board (not including
> me) at [email-masked] * To the [email-masked] list
> 
> Please rememeber to comment on the revised draft [3] not the
> original.
> 
> [1]
> https://github.com/ietf-llc/strategy-2020-consultation/blob/master/DRAFT%20Strategic%20Plan%202020.md
>
> 
[2]  https://github.com/ietf-llc/strategy-2020-consultation/issues
> [3]
> https://github.com/ietf-llc/strategy-2020-consultation/blob/latest-updates-from-consultation/DRAFT%20Strategic%20Plan%202020.md
>

---

From: Eric Rescorla <[email-masked]>
Date: Wed, 3 Jun 2020 10:19:52 -0700

On Wed, Jun 3, 2020 at 7:27 AM Stephen Farrell <[email-masked]>
wrote

> with whatever is really meant in each case (or with nothing).

I also was somewhat put off by this text (though perhaps less because
"User Journey" is relatively common industry jargon).

It seems to me that in this case, however, the province of the LLC is
to ensure that the common tasks that participants need to do
(register for IETF, get the calendar, read drafts, author drafts, etc.)
are clearly documented and streamline. However, I don't think it;s
that helpful to try to get more macro than that.

> I'd suggest just deleting the offending statements would be

This I don't agree on. Although the precise composition of the I*
changes, my experience is that there actually is a fair amount of
strategic continuity (for instance, it's not like when new ADs come
in they just shut down all the work their predecessors approved).
I think that this text is appropriate and should stay.

-Ekr

Cheers,

---

From: Stephen Farrell <[email-masked]>
Date: Wed, 3 Jun 2020 20:34:45 +0100

Hiya,

> in they just shut down all the work their predecessors approved).

That's probably fair. However, it's not written down and
hence is liable to being very easily misunderstood, so is
not something from which the LLC can usefully extrapolate.
IOW, there is no definite e.g. IESG strategy as previously
stated.

The LLC can absolutely chat with e.g. the IESG-de-jure at
their retreat or whatever and see what that relates to the
IESG is good or bad about the LLC's plans for the year
ahead, but having the LLC try figure that out based on
divination, or, and perhaps worse, only talking to a few
incumbent ADs, isn't IMO a good plan.

Cheers,
S.

---

From: Jay Daley <[email-masked]>
Date: Thu, 4 Jun 2020 07:43:25 +1200

> On 4/06/2020, at 2:26 AM, Stephen Farrell <[email-masked]> wrote:
> 
> 
> Hiya,
> 

Added as https://github.com/ietf-llc/strategy-2020-consultation/issues/42   Note, that this needs to be done in reference to our Privacy Statement (as the applicable policy) and that has a strong focus on openness as well as privacy.

> with whatever is really meant in each case (or with nothing).

My answer may unintentionally come across as rude.  

It appears that you are unfamiliar with the concept of user journeys (which, as Ekr has pointed out, is renamed to "participant journey" to be more IETF specific).  These are an important tool in understanding how people interact with systems, whether those systems are organisational or technological.  The details of a user journey are quite simple, as explained in the strategy:

"a map of the different stages of participation (e.g. newcomer, leadership), at what stages people start their participation in the IETF, how they transition between them and at what stages they end their participation.  "

I do not think it is appropriate that we are limited in our strategy to concepts that every reader understands.

> I'd suggest just deleting the offending statements would be

First, I should note that the term "collectively" is something you have added and not something that comes form this document.  This is about the LLC aligning with the strategic objectives of those bodies, if they have them, and in whatever form they come.

Second, the IESG for one has been looking at strategic planning for some time

	https://www.ietf.org/blog/iesg-strategic-retreat/

If you want it formally recognised that those bodies cannot have strategic objectives, or cannot have collective strategic objectives, then you should really be taking that point of view to them and asking them to affirm that in a statement rather than trying to impose that view in a second order document such as this.

Jay

> <0x5AB2FAF17B172BEA.asc>

-- 
Jay Daley
IETF Executive Director
[email-masked]

---

From: Stephen Farrell <[email-masked]>
Date: Wed, 3 Jun 2020 21:10:17 +0100

Hiya,

On 03/06/2020 20:43, Jay Daley wrote:
> I do not think it is appropriate that we are limited in our strategy 
> to concepts that every reader understands.

Sorry, my point was not that I didn't understand but
that it was either waffly or indicative of over-reach.

> First, I should note that the term "collectively" is
> something you have added and not something that comes
> form this document.

Yes, you have implicitly made that (false) assumption.
I just called it out.

In my experience there is often a significant and real
difference between what some person perceives to be the
position/opinion/strategy of the IESG and the reality
of the situation. An IESG "strategy" could not be that
were it not the collective consensus of the IESG.

> If you want it formally recognised that those bodies cannot have 
> strategic objectives, or cannot have collective strategic
> objectives, then you should really be taking that point of view to
> them and asking them to affirm that in a statement rather than trying
> to impose that view in a second order document such as this.
That's actually a great example of why your text is wrong.
If the upshot of your text were that the IESG or IAB went
running about strategising to keep the LLC happy, then we
would be entirely in tail-wagging-dog territory. (I can
totally get why you may think exactly the opposite about
that though.) In any case, building on an assumption known
to be false is not only bad planning but also bad logic.

Cheers,
S.

---

From: "Pete Resnick" <[email-masked]>
Date: Wed, 03 Jun 2020 15:54:49 -0500

On 3 Jun 2020, at 9:26, Stephen Farrell wrote:

> moment in the sense meant here.

Surely there's a way to express that the LLC should make sure that what 
they're planning to do, even in the long term, stays in line with what 
the IESG, IRSG, and IAB say they're planning to do, over whatever term 
they happen to be planning for today. That's not controversial, is it? 
Can you propose some text?

pr
-- 
Pete Resnick https://www.episteme.net/
All connections to the world are tenuous at best

---

From: Brian E Carpenter <[email-masked]>
Date: Thu, 4 Jun 2020 09:03:36 +1200

> that it was either waffly or indicative of over-reach.

Yes, but I think it also set of your (and my) buzzword detector.
I think we should make an effort (and I mean "we", not Jay in
particular) to use plain English and not jargon terms like "journey"
in this sense, which might be unfamiliar to many people. It's not
as if the LLC has to impress shareholders and analysts by its
command of current business-speak.

> were it not the collective consensus of the IESG.

Right, and typically the IESG publishes its tactical and
strategic statements as "IESG Statements". The IAB and the
IRSG seem to do it by email when needed. I don't see a problem
here - when they feel the need to utter collectively, they do so.
 
> to be false is not only bad planning but also bad logic.

Huh? I think all the draft plan says is that the LLC will align
its strategy with whatever strategies the I* have. If they don't
have a strategy, there's nothing to align with. And if this does
in fact give them an incentive to do some strategic thinking,
wouldn't that be a good thing? Don't you think we are sometimes
a bit *too* tactical?

   Brian

---

From: Stephen Farrell <[email-masked]>
Date: Wed, 3 Jun 2020 22:04:02 +0100

On 03/06/2020 21:54, Pete Resnick wrote:
>> misunderstanding IMO. Those bodies cannot, collectively, have an
>> agreed set of such "strategic objectives" at any given moment in
>> the sense meant here.
> 
> Surely there's a way to express that the LLC should make sure that
> what they're planning to do, even in the long term, stays in line
> with what the IESG, IRSG, and IAB say they're planning to do, over
> whatever term they happen to be planning for today. That's not
> controversial, is it? Can you propose some text?

Sure, happy to try.

"The LLC will consult annually with the IESG, IAB and
IRSG to check whether or not changes to this document
are warranted. This is not intended to result in a full
rewrite (as doing so would require community consultation)
but rather as an opportunity to identify any necessary
course-correction."

Cheers,
S.

---

From: Stephen Farrell <[email-masked]>
Date: Wed, 3 Jun 2020 22:05:29 +0100

On 03/06/2020 22:03, Brian E Carpenter wrote:
> its strategy with whatever strategies the I* have.

No - it says the LLC with extrapolate to produce what
it (the LLC) thinks is e.g. the IESG's strategy.

S.

---

From: Eric Rescorla <[email-masked]>
Date: Wed, 3 Jun 2020 15:08:35 -0700

On Wed, Jun 3, 2020 at 12:44 PM Jay Daley <[email-masked]> wrote:

> It appears that you are unfamiliar with the concept of user journeys
> (which, as Ekr has pointed out, is renamed to "participant journey" to be
> more IETF specific).  These are an important tool in understanding how
> people interact with systems, whether those systems are organisational or
> technological.  The details of a user journey are quite simple, as
> explained in the strategy:
>
> "a map of the different stages of participation (e.g. newcomer,
> leadership), at what stages people start their participation in the IETF,
> how they transition between them and at what stages they end their
> participation.  "
>

Given that you named me I want to flag that I actually don't think that the
effort you describe here is particularly appropriate  in this case. Trying
to think of the entire spectrum of participation as a set of stages that
people go through is not helpful IMO. It's not really a linear process and
people want different things at different points in their careers and
that's fine, so I don't think that a map of this kind is going to generate
much insight.

As I said, I do think it's important to have clear maps for how the
individual tasks that people want to do work and where they go wrong, which
is sort of a small scale version of this.

-Ekr

---

From: Jay Daley <[email-masked]>
Date: Thu, 4 Jun 2020 16:41:21 +1200

> On 4/06/2020, at 8:10 AM, Stephen Farrell <[email-masked]> wrote:
> 
> 
> Hiya,
> 

It would be helpful to understand which of those you think it is as they are quite different criticisms.

> were it not the collective consensus of the IESG.

I think you misunderstood my misunderstanding of how you used the term "collectively".  I thought you meant the IESG, IAB etc getting together and collectively agreeing a set of strategic objectives, not each making a collective decision.

Yes I’m sure you’re right there’s a chance that the LLC might misperceive the IESG position/opinion/strategy and I’m equally sure the IESG will say so if that happens.

> to be false is not only bad planning but also bad logic.

To summarise your two objections, hopefully using your own words accurately:

You don’t think that the LLC strategy should reference the strategic objectives of the IESG, IAB etc because:

1.  By having this, the LLC might push the IESG/IAB into running about strategising

2.  Those bodies cannot, collectively, have an agreed set of such "strategic objectives" at any given moment in the sense meant here.

My response to 1 is that I understand why you think that, though from what little I know of the IESG and IAB they appear to have such a strong sense of purpose, strong personalities and full workload that tail-wagging-dog is a very, very low risk.  

My response to 2 is that we just disagree and I don’t detect any support for your position or other indication of a path to resolve this and so I think we need to leave it here.

Jay

-- 
Jay Daley
IETF Executive Director
[email-masked]

---

From: S Moonesamy <[email-masked]>
Date: Wed, 03 Jun 2020 23:06:07 -0700

Hi Jay,
At 09:41 PM 03-06-2020, Jay Daley wrote:
>My response to 2 is that we just disagree and I don't detect any 
>support for your position or other indication of a path to resolve 
>this and so I think we need to leave it here.

In my opinion, Stephen is right.  I didn't comment on his email 
because my perception is that I would have to provide evidence to 
support my claim.  I don't think that is a bad thing.  It is not 
worth investing time when I am not even a major internal customer.

Regards,
S. Moonesamy

---

From: Stephen Farrell <[email-masked]>
Date: Thu, 4 Jun 2020 11:13:03 +0100

Hiya,

On 04/06/2020 05:41, Jay Daley wrote:
>>> I do not think it is appropriate that we are limited in our
>>> strategy to concepts that every reader understands.
>> 
>> Sorry, my point was not that I didn't understand but that it was
>> either waffly or indicative of over-reach.
> 

If you read my mail, the comment was that all this
"journey" stuff was either waffly or over-reach and
that ditching the fashionista term and using clear
English would be needed to determine which. I think
that's a clear comment.

> 
>> 
>>> First, I should note that the term "collectively" is something
>>> you have added and not something that comes form this document.
>> 
>> Yes, you have implicitly made that (false) assumption. I just
>> called it out.
>> 
>> In my experience there is often a significant and real difference
>> between what some person perceives to be the 
>> position/opinion/strategy of the IESG and the reality of the
>> situation. An IESG "strategy" could not be that were it not the
>> collective consensus of the IESG.
> 
> I think you misunderstood my misunderstanding of how you used the
> term "collectively".  I thought you meant the IESG, IAB etc getting
> together and collectively agreeing a set of strategic objectives, not
> each making a collective decision.
> 
> Yes Iâ€™m sure youâ€™re right thereâ€™s a chance that the LLC might
> misperceive the IESG position/opinion/strategy and Iâ€™m equally sure
> the IESG will say so if that happens.

That's not the problem. The problem is that the LLC if
it "extrapolates" badly (which is always possible),
because of it's better stability, could end up determining
something the IESG ought have decided. Tail-wagging-dog
is the risk. That's made worse by how you've structured
the document to talk about the LLC extrapolating from a
non-existent thing.

>>> objectives, then you should really be taking that point of view
>>> to them and asking them to affirm that in a statement rather than
>>> trying to impose that view in a second order document such as
>>> this.
>> That's actually a great example of why your text is wrong. If the
>> upshot of your text were that the IESG or IAB went running about
>> strategising to keep the LLC happy, then we would be entirely in
>> tail-wagging-dog territory. (I can totally get why you may think
>> exactly the opposite about that though.) In any case, building on
>> an assumption known to be false is not only bad planning but also
>> bad logic.
> 

No. That summaries an example. The problem is with the
bad logic in the document, a point you have not addressed,
and that doesn't require support from others - the logic
is either good or bad not fuzzy.

Cheers,
S.

> 
> You donâ€™t think that the LLC strategy should reference the
> strategic objectives of the IESG, IAB etc because:
> 
> 2.  Those bodies cannot, collectively, have an agreed set of such
> "strategic objectives" at any given moment in the sense meant here.
> 
> My response to 1 is that I understand why you think that, though from
> what little I know of the IESG and IAB they appear to have such a
> strong sense of purpose, strong personalities and full workload that
> tail-wagging-dog is a very, very low risk.
> 
> My response to 2 is that we just disagree and I donâ€™t detect any
>> Cheers, S.

---

From: Jay Daley <[email-masked]>
Date: Fri, 5 Jun 2020 09:51:28 +1200

> On 4/06/2020, at 10:13 PM, Stephen Farrell <[email-masked]> wrote:
> 

Your responses so far suggest that you have no regard for the field of UX for which user journey mapping is a foundational technique, and as I’m not willing to abandon the use of those techniques to help us in our work I’m not sure how far we can go with this.  However I’ve had one last attempt by creating a new issue 

	https://github.com/ietf-llc/strategy-2020-consultation/issues/43 "More clarity around participant journey" 

and addressing that with this change

	https://github.com/ietf-llc/strategy-2020-consultation/commit/ddc0af3e2d5628a71ca6eaca8359c6187ac40b01#diff-ace2c9f1dd155e5220c2a50de0c79018

Jay

-- 
Jay Daley
IETF Executive Director
[email-masked]

---

From: Jay Daley <[email-masked]>
Date: Fri, 5 Jun 2020 09:53:52 +1200

> On 4/06/2020, at 10:08 AM, Eric Rescorla <[email-masked]> wrote:
> 
> As I said, I do think it's important to have clear maps for how the individual tasks that people want to do work and where they go wrong, which is sort of a small scale version of this.

Added issue 

	https://github.com/ietf-llc/strategy-2020-consultation/issues/44 "No mention of need to better understand user flows in order to inform the works of the Tools team and TAS" 

and addressed it by adding a new transformation and some accompanying text

	https://github.com/ietf-llc/strategy-2020-consultation/commit/b9841bb6b4c72515fb24c556ff6a49767cc5d1e5#diff-ace2c9f1dd155e5220c2a50de0c79018	

Jay

-- 
Jay Daley
IETF Executive Director
[email-masked]

---

From: Jay Daley <[email-masked]>
Date: Fri, 5 Jun 2020 10:03:32 +1200

> Added as https://github.com/ietf-llc/strategy-2020-consultation/issues/42 <https://github.com/ietf-llc/strategy-2020-consultation/issues/42>   Note, that this needs to be done in reference to our Privacy Statement (as the applicable policy) and that has a strong focus on openness as well as privacy.

Addressed with https://github.com/ietf-llc/strategy-2020-consultation/commit/a173cd466bbef8f8bb103b5b4d563d3fbe6252b1#diff-ace2c9f1dd155e5220c2a50de0c79018

Jay 

-- 
Jay Daley
IETF Executive Director
[email-masked]

---

From: Eric Rescorla <[email-masked]>
Date: Thu, 4 Jun 2020 15:11:35 -0700

Well, I think this is responsive to part of my comment, namely that we
should discuss common user tasks.

However, I don't think it's responsive to the other part -- which I also
take to be Stephen's point -- that we should remove the participant journey
text. I have reviewed your proposed change and while I think it's slightly
clearer, I simply don't agree that this is really something that should be
part of the LLC's strategy. It seems to me that one could think of this in
two ways:

- Defining/designing the participant journey. This is typically how this
shows up in discussions of the user journey in the UX context. This might
or might not be a good idea but seems pretty far from the LLC's remit and
much more like the IESG's (if anyone).

- Documenting some typical IETF career paths. I'm not sure how valuable
this is as a general matter. The surrounding text suggests that you think
of this primarily as a sales tool for potential funders. To the extent to
which this is true, I don't think that needs to be called out specially in
the strategy; the strategic objective is "recruit funders" and this is just
tactics.

In either case, I think this text should be removed.

-Ekr

On Thu, Jun 4, 2020 at 2:54 PM Jay Daley <[email-masked]> wrote:

>         https://github.com/ietf-llc/strategy-2020-consultation/issues/44
> "No mention of need to better understand user flows in order to inform the
> works of the Tools team and TAS"
>

---

From: Brian E Carpenter <[email-masked]>
Date: Fri, 5 Jun 2020 10:14:28 +1200

> 	https://github.com/ietf-llc/strategy-2020-consultation/commit/ddc0af3e2d5628a71ca6eaca8359c6187ac40b01#diff-ace2c9f1dd155e5220c2a50de0c79018

Better, but I still think that the phrase "the participant journey" suggests that there is only one typical path through the IETF labyrinth, and that isn't so. There are many alternative paths and destinations, not to mention many different motivations for participating. I'm not sure the "journey" concept captures that.

     Brian

---

From: Stephen Farrell <[email-masked]>
Date: Thu, 4 Jun 2020 23:39:47 +0100

On 04/06/2020 23:03, Jay Daley wrote:
> 
>>> - The word "privacy" doesn't appear. That needs to be fixed, to
>>> provide the proper balance vs. things like: "Sufficient 
>>> high-quality data on participants their activities, motivations,
>>> expectations, etc to support an evidence-led culture." I'd say
>>> the way to do that is to make a generic statement that the LLC
>>> aims to honor the privacy expectations of the IETF community -
>>> those vary a lot but we are and should be a picky crowd when it
>>> comes to this topic. (Sorry for not noticing this in my earlier
>>> review.)
>> 
>> Added as
>> https://github.com/ietf-llc/strategy-2020-consultation/issues/42
>> <https://github.com/ietf-llc/strategy-2020-consultation/issues/42>
>> Note, that this needs to be done in reference to our Privacy
>> Statement (as the applicable policy) and that has a strong focus on
>> openness as well as privacy.
> 
> 
> Addressed with
> https://github.com/ietf-llc/strategy-2020-consultation/commit/a173cd466bbef8f8bb103b5b4d563d3fbe6252b1#diff-ace2c9f1dd155e5220c2a50de0c79018
>

LGTM, thanks,
S.

---

From: Jay Daley <[email-masked]>
Date: Fri, 5 Jun 2020 11:00:20 +1200

> On 5/06/2020, at 10:14 AM, Brian E Carpenter <[email-masked]> wrote:
> 

It’s a term of art in the field of UX and in that context does indeed capture motivations and multiple paths (or no path at all). 

Jay

-- 
Jay Daley
IETF Executive Director
[email-masked]

---

From: Jay Daley <[email-masked]>
Date: Fri, 5 Jun 2020 11:18:14 +1200

> On 5/06/2020, at 10:11 AM, Eric Rescorla <[email-masked]> wrote:
> 
> Well, I think this is responsive to part of my comment, namely that we should discuss common user tasks.
> 
> However, I don't think it's responsive to the other part -- which I also take to be Stephen's point -- that we should remove the participant journey text. I have reviewed your proposed change and while I think it's slightly clearer, I simply don't agree that this is really something that should be part of the LLC's strategy. It seems to me that one could think of this in two ways:

Thank you, this is very helpful.

> 
> - Defining/designing the participant journey. This is typically how this shows up in discussions of the user journey in the UX context. This might or might not be a good idea but seems pretty far from the LLC's remit and much more like the IESG's (if anyone).

I agree, way out of the LLC remit.

> 
> - Documenting some typical IETF career paths. I'm not sure how valuable this is as a general matter. The surrounding text suggests that you think of this primarily as a sales tool for potential funders. To the extent to which this is true, I don't think that needs to be called out specially in the strategy; the strategic objective is "recruit funders" and this is just tactics.

Yes it is just tactics, but the LLC is trying to meet community expectations of exceptional levels of transparency and so sharing important tactics is necessary.  A good test for deciding if something is important enough to share is "if people find out about this from someone else other than us then will they feel they should have heard it from us first" and I think this passes that test.

> In either case, I think this text should be removed.

Thanks again, I’m going to stick with it though.

Jay

> 
> -Ekr
> 
> 
> On Thu, Jun 4, 2020 at 2:54 PM Jay Daley <[email-masked] <mailto:[email-masked]>> wrote:
> 
> 
> > On 4/06/2020, at 10:08 AM, Eric Rescorla <[email-masked] <mailto:[email-masked]>> wrote:
> > 
>         https://github.com/ietf-llc/strategy-2020-consultation/issues/44 <https://github.com/ietf-llc/strategy-2020-consultation/issues/44> "No mention of need to better understand user flows in order to inform the works of the Tools team and TAS" 
> 
>         https://github.com/ietf-llc/strategy-2020-consultation/commit/b9841bb6b4c72515fb24c556ff6a49767cc5d1e5#diff-ace2c9f1dd155e5220c2a50de0c79018 <https://github.com/ietf-llc/strategy-2020-consultation/commit/b9841bb6b4c72515fb24c556ff6a49767cc5d1e5#diff-ace2c9f1dd155e5220c2a50de0c79018>    
> 
> Jay
> 
> > 
> > -Ekr
> > 
> > 
> 
> -- 
> Jay Daley
> IETF Executive Director
> [email-masked] <mailto:[email-masked]>
> 

-- 
Jay Daley
IETF Executive Director
[email-masked]

---

From: Eric Rescorla <[email-masked]>
Date: Thu, 4 Jun 2020 16:22:09 -0700

On Thu, Jun 4, 2020 at 4:18 PM Jay Daley <[email-masked]> wrote:

Perhaps it's worth taking a step back here and asking what you think the
terms of engagement are on this consultation.

Your text above seems to imply that you are putting this out for comment
but are the ultimate decider on whether to accept those comments, as
opposed to this requiring community consensus. Is that in fact your
position?

-Ekr

---

From: Jay Daley <[email-masked]>
Date: Fri, 5 Jun 2020 11:54:09 +1200

> On 5/06/2020, at 11:22 AM, Eric Rescorla <[email-masked]> wrote:
> 
> 
> 
> On Thu, Jun 4, 2020 at 4:18 PM Jay Daley <[email-masked] <mailto:[email-masked]>> wrote:
> Perhaps it's worth taking a step back here and asking what you think the terms of engagement are on this consultation.
> 
> Your text above seems to imply that you are putting this out for comment but are the ultimate decider on whether to accept those comments, as opposed to this requiring community consensus. Is that in fact your position?

The question about consensus is a very complex one.  This consultation is clearly not a substitute for a community consensus process but then it’s not trying to establish a community consensus, it’s trying to find out what the community thinks and what changes need to be made to make it a better fit with community expectations.  Some very significant changes have been made to the draft as a result of the feedback received so far.

The pertinent difference here between a consultation and the community consensus process is that those that will accept that result are no longer actively engaged, whereas they remain so in a consensus process until the outcome and so outliers can be judged as such and rough consensus declared.

With a consultation we need to ask "do we have to address every issue raised to the satisfaction of the person who raised it?"  My answer is, ideally yes but sometimes no we don’t - there are boundaries and I think it is both transparent and honest to state when those are reached.  

The LLC board is the ultimate decider on this not me but I choose what I propose to them.  I will note that you and Stephen disagree and they will decide what to do with that information.

Jay

-- 
Jay Daley
IETF Executive Director
[email-masked]

---

From: Larry Masinter <[email-masked]>
Date: Thu, 4 Jun 2020 18:13:50 -0700

My take on the “participant journey” discussion is that the UX perspective brings along  a kind of paternalistic view of vendor/customer, manager/employee, that the LLC will determine and design the participant journey, rather than the sense that the IETF standards process defines various touchpoints and the LLC goal is to   facilitate, enable, address pain points of typical user experiences.. I think you can USE the concept of “participant journey” as a good analytical method without buying into the who

I think some of the wording around community and strength is fine at the core, but I’d like to see more about occasional users who have no desire for a journey, they’re just here for a limited engagement, to enable one feature or update an RFC-defined IANA value, where those users don’t need to be part of the “strong community”. 

You might consider calling for “using modern UX methods to help optimize the user experience” and call “analyzing and documenting (and maintaining) typical participant journeys” as a tactical choice.

I think in the end the “community” we’re trying to serve are Internet users everywhere, and the strategy of the LLC should somehow reflect that.

--

https://LarryMasinter.net   https://going-remote.info

---

From: Stephen Farrell <[email-masked]>
Date: Sat, 6 Jun 2020 03:01:44 +0100

On 05/06/2020 00:54, Jay Daley wrote:
>> Thanks again, Iâ€™m going to stick with it though.
>> 
>> Perhaps it's worth taking a step back here and asking what you
>> think the terms of engagement are on this consultation.
>> 
>> Your text above seems to imply that you are putting this out for
>> comment but are the ultimate decider on whether to accept those
>> comments, as opposed to this requiring community consensus. Is that
>> in fact your position?
> 
> The question about consensus is a very complex one. 

Hmm. Eric didn't ask for a definition but for an answer.
I think I objected on exactly the same basis when the
first email was sent on this topic. But I don't see a
clear answer below.

Nonetheless I take it from your last statement at the
end that you do consider that you are the one who decides
how to handle this text. I think that's a bad call and
an erroneous one.

Many parts of the putative strategy that are good. But
there are still bits that IMO require community consensus.
And for almost all such things, the IESG are the consensus
caller, not the LLC, nor the LLC board.

A bare assertion that that is not so (and that some other
things are complex) seems to me like a response that is
lacking.

Having stumbled into a bit of well-intentioned over-reach,
dealing with argumentative people like me calling that out
might well make it harder to pull back I guess. I'm sorry
if I've made that harder, but it's still the right thing to
do.

Cheers,
S.

> This
> consultation is clearly not a substitute for a community consensus
> process but then itâ€™s not trying to establish a community
> consensus, itâ€™s trying to find out what the community thinks and
> what changes need to be made to make it a better fit with community
> expectations.  Some very significant changes have been made to the
> draft as a result of the feedback received so far.
> 
> The pertinent difference here between a consultation and the
> community consensus process is that those that will accept that
> result are no longer actively engaged, whereas they remain so in a
> consensus process until the outcome and so outliers can be judged as
> such and rough consensus declared.
> 
> With a consultation we need to ask "do we have to address every issue
> raised to the satisfaction of the person who raised it?"  My answer
> is, ideally yes but sometimes no we donâ€™t - there are boundaries
> and I think it is both transparent and honest to state when those are
> reached.
> 
> The LLC board is the ultimate decider on this not me but I choose
> what I propose to them.  I will note that you and Stephen disagree
> and they will decide what to do with that information.
> 
> Jay
>

---

From: Jay Daley <[email-masked]>
Date: Sat, 6 Jun 2020 14:14:11 +1200

> On 6/06/2020, at 2:02 PM, Stephen Farrell <[email-masked]> wrote:
> 
> 
> 
> caller,

The only two elements of the draft strategy that I am aware of you still objecting to are

- the linkage to IESG/IRSG/IAB strategy; and
- the participant journey

(Notwithstanding your initial objection to the concept of the LLC having a strategy framed this way)

It would be very helpful if you could point to those other elements of the draft strategy where the role of the IESG in calling consensus needs clarification. 

Jay

-- 
Jay Daley
IETF Executive Director
+64 21 678840

> not the LLC, nor the LLC board.
>

---

From: Stephen Farrell <[email-masked]>
Date: Sat, 6 Jun 2020 03:28:42 +0100

On 06/06/2020 03:14, Jay Daley wrote:
> - the linkage to IESG/IRSG/IAB strategy; and - the participant 
> journey

The phrasing above indicates I've not explained my
objections clearly I guess. I've argued that there
really cannot be an "IESG strategy" and that the
use of the "journey" phrase is either waffle or else
over-reach. I don't therefore object to "the linkage
to X" where X is a non-existent thing. (Well, other
than it being an irritant on a purist logical basis:-)
I do object to "the LLC will extrapolate to decide what
that non-existent IESG strategy ought be" as I've tried
to explain, as that is what the latest text says. (I did
also suggest alternate wording to which I got no
response.)

> having a strategy framed this way)

My initial objection was not to how text was framed but
to the assumption that the LLC decide how to call consensus
on this. I continue to see that as a problem that has not
seen a response from the IESG.

> It would be very helpful if you could point to those other elements 
> of the draft strategy where the role of the IESG in calling
> consensus needs clarification.
Now I'm confused. I think my objections above are
sufficient and don't see why more are needed. If you
wanted to say that you have disregarded my objections
and are only willing to discuss if I find more then
saying that would be clearer;-)

S.

---

From: Jay Daley <[email-masked]>
Date: Sat, 6 Jun 2020 14:40:56 +1200

> On 6/06/2020, at 2:28 PM, Stephen Farrell <[email-masked]> wrote:
> 
> 
> 

My text above was not intended to (mis)represent your position, only to summarise the areas of the strategy you object to. 

The alternate wording you provided seemed to take this in a very different direction. I will look at the “extrapolate” phrase though to see if that can be sufficiently narrowed to a set of conditions that you would be comfortable with. 

> on this.

As explained in a previous message, the LLC will not be calling consensus on this strategy but will at some point decided that it’s good enough to work with. 
 
> I continue to see that as a problem that has not

No that’s not what I wanted to say - I thought your message implied there were additional issues that has not been identified. It is reassuring that you don’t have any. 

Jay

---

From: Jay Daley <[email-masked]>
Date: Thu, 18 Jun 2020 14:11:14 +1200

>> also suggest alternate wording to which I got no

To try to close this off:

1.  Changed the following to remove "extrapolate", from 

"Consequently, this strategic plan should ideally clearly reflect the strategies of the IETF/IRTF/IAB. However, as those are neither well understood nor well defined, these are extrapolated from IETF/IRTF/IAB expressed administrative needs and desires." 

to 

"Consequently, this strategic plan should ideally clearly reflect the plans and goals of the IETF/IRTF/IAB, where they exist."

2.  Amended transformation #1 to not assume that IESG/IRSG/IAB will have a strategy, from

"LLC strategy closely aligned with the strategic objectives of IESG, IRSG and IAB"

to

"LLC strategy closely aligned with the plans and goals, where they exist, of IESG, IRSG and IAB"

Also amended accompanying narrative to match.

Jay

-- 
Jay Daley
IETF Executive Director
[email-masked]