Subject: Re: Randomness sources for the IETF 2020-2021 Nomcom Selection

From: Michael StJohns <[email-masked]>
Date: Sun, 28 Jun 2020 20:29:48 -0400

Hi Barbara -  quick observation.

The challenge period runs until the 6th.   The numbers are all from the 
4th.   That means that as of the 4th we would have a list of selectees, 
which could be changed by a challenge that comes in on the 6th.   Or 
not.   One of the goals here is that once the numbers are picked we have 
our list and it's not subject to manipulation by having the list changed 
post selection.   This approach does not meet that goal.

Please
1) Announce the final list AFTER the challenge period expires.
2) Announce the list of sources and the date for those sources at that 
time to be AFTER the final list is published.
3) Finally, announce the selectees after the sources complete.

Thanks - Mike

ps - in the same vein, please list which companies you consider to be 
"the same" as soon as possible - e.g. now if possible.   Again, the all 
the selection criteria should be set in stone PRIOR to the process being 
run.  If there's a variable that affects the output of the selection 
process, a value needs to be set for it and made public.

On 6/28/2020 1:14 PM, NomCom Chair 2020 wrote:
> As per RFC 8713 and using RFC 3797 (Publicly Verifiable Nominations Committee (NomCom) Random Selection), the following are the seed selection that will be used on July 6, 2020 (2020-07-06).
>
> ** Random Source 1 - EuroMillions Lottery **
> ** Date - Friday July 3, 2020 **
> EuroMillions Lottery Results
> https://www.euro-millions.com/results
> Friday, July 3, 2020 Results:
> https://www.euro-millions.com/results/03-07-2020
>    (7 numbers, in drawn order, including the star balls: 5 numbers between 1 and 50 and 2 star balls between 1 and 12)
>
> ** Random Source 2 - US Power Ball **
> ** Date - Saturday July 4, 2020 **
> Powerball Lottery Results
> https://www.powerball.com/index.php/games/powerball
> Saturday, July 4, 2020 results:
>    (5 numbers, in drawn order, between 1 and 69 plus 1 number between 1 and 26)
>
> ** Random Source 3 - Australian TattsLotto **
> ** Date - Saturday July 4, 2020 **
> TattsLotto Results
> https://thelott.com/tattslotto/results
> Saturday July 4, 2020 results:
> (6 winning numbers, in drawn order, between 1 and 45; no Supps numbers)
>
> ** Random Source 4 - Emirates Loto **
> ** Date - Saturday July 4, 2020 **
> https://www.emiratesloto.com/loto/winningnumber/previous
> Saturday July 4 results:
> (6 winning numbers, in drawn order, between 1 and 49)
>
> Barbara Stark
> NomCom Chair 2020-21
> nomcom-chair-2020 at ietf dot org
>
> _______________________________________________
> IETF-Announce mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ietf-announce

---

From: Eric Rescorla <[email-masked]>
Date: Sun, 28 Jun 2020 18:15:21 -0700

> time to be AFTER the final list is published.

Mike, I generally agree with you here, and perhaps this is just a lack of
English clarity, but I think the requirement is that those sources have to
produce their output after the challenge period expires, not that they have
to be announced after. Do you disagree?

-Ekr

> > As per RFC 8713 and using RFC 3797 (Publicly Verifiable Nominations
> Committee (NomCom) Random Selection), the following are the seed selection
> that will be used on July 6, 2020 (2020-07-06).
> >
> >    (7 numbers, in drawn order, including the star balls: 5 numbers
> between 1 and 50 and 2 star balls between 1 and 12)
> >

---

From: Mike StJohns <[email-masked]>
Date: Sun, 28 Jun 2020 22:01:30 -0400

Hi Eric - generally yes, you can announce the sources and source dates before,  but if there’s a glitch in the process ( e.g. announced date is 7 July, but on the sixth of July something happens that requires more than a day to resolve..) you can find yourself having to scramble to make an announcement of the delay before the randomness sources start reporting.  Better to report the final list and the randomness sources and take dates at the same time I would think.  You could announce the randomness sources earlier if there was any question of their actual randomness, but hold off on announcing the date until you have the list finalized. 

Mike

Sent from my iPad

> On Jun 28, 2020, at 21:16, Eric Rescorla <[email-masked]> wrote:
> 
> 
> 
> 
>> On Sun, Jun 28, 2020 at 5:30 PM Michael StJohns <[email-masked]> wrote:
> Mike, I generally agree with you here, and perhaps this is just a lack of English clarity, but I think the requirement is that those sources have to produce their output after the challenge period expires, not that they have to be announced after. Do you disagree?
> 
> -Ekr
>