Subject: Postel's Principle and Layer 9 protocol engineering

From: Larry Masinter <[email-masked]>
Date: Sun, 6 Jun 2021 11:13:59 -0700

I wasn’t taking Postel’s Principle as a given, or saying others SHOULD follow it.

I was trying to offer a perspective for reasoning about content moderation

which I thought might be helpful to the protocol engineers amongst us.

IETF regularly engages in Layer 9 protocol engineering whenever we 
talk about harassment, NOTE WELLs, working group formation, choice
of technical infrastructure, etc. 

FB is faced with intense conflicting pressure to moderate
content or disallow content. 

But banning someone is very different from delaying their posting
for a reasonable length of time. Especially if the algorithm used
is clear enough that participants who value the ability to
communicate without delay can readily choose other ways
of expressing their perspective, without resorting to hyperbole.

--

 <https://LarryMasinter.net> https://LarryMasinter.net  <https://interlisp.org> https://interlisp.org

From: Emil Ivov <[email-masked]> 
Sent: Sunday, June 6, 2021 12:13 AM
To: Larry Masinter <[email-masked]>
Cc: Dean Willis <[email-masked]>; Jared Mauch <[email-masked]>; [email-masked]
Subject: Re: Why we really can't use Facebook for technical discussion.

Ironically, advising *others* how *they* should follow Postel’s principle is exactly the opposite of the principle.

On Sun, Jun 6, 2021 at 00:44 Larry Masinter <[email-masked] <mailto:[email-masked]> > wrote:

This is the argument about Postel's principle (conservative in what you send, liberal in what you accept) in layer 9.
It seems to me that Facebook is doing just fine slowing down (24 hours) the possible propagation of violence incitement without requiring a lot of judgement on what does or does not constitute thoughtful vs. inciteful speech.

"Kill them all and let TCP sort it out" can readily be expressed in other terms. A content moderation policy that slowed down frequent postings (by 24 hours) might temper heated conversations and lead to calmer considerations of the actual requirements. 

> I hereby propose we censor Facebook engineers in IETF meetings for promoting stupidity.

Can public forums improve the quality of discussion by delaying frequent, divisive posters?
Is trying to do so really  "promoting stupidity"? (Obligatory 😊)

--
https://LarryMasinter.net https://interlisp.org

-- 

sent from my mobile

---

From: Dean Willis <[email-masked]>
Date: Sun, 06 Jun 2021 18:48:06 +0000

-------- Original Message --------
On Jun 6, 2021, 1:13 PM, Larry Masinter < [email-masked]> wrote:
...

----

Larry, they didn't "delay my posting for a reasonable length of time. " They permanently blocked my comment, denied the appeal, and banned me from using Facebook for any purpose for 24 hours. As I understand it, they use an escalating scale, so the next time they make this mistake it's a week ban, then two, then a month...

Given that MY current employer (for better or worse) is an agency that literally runs on top of social media platforms, said 24 hour ban literally blocks my income stream and the business operations of my clients. Now, perhaps that's my problem and I have a business Facebook dependency to resolve, which I will do...

But my essential point is that given these sorts of risks the IETF MUST NOT rely on social media platforms -- in particular Facebook (because that's where we have an objective instance to analyze as a threat model) -- where said platform is likely to invoke automated censorship in such a way that users must self-censor commonly used terms of art in order to avoid being expelled from the platform.

Literally last month we were circulating a survey asking people about doing IETF work on social media platforms. And while we have had a few technical discussions on Facebook and other platforms, I don't think we've thought our way through the implications of working that way.

--
Dean

---

From: Fred Baker <[email-masked]>
Date: Sun, 6 Jun 2021 13:05:25 -0700

I’m curious what the average number of words are used in a FB post, and the average number of words are in a technical discussion. My belief is that FB would be difficult to use (as would Twitter) because comments are usually short.

Sent using a machine that autocorrects in interesting ways...

> On Jun 6, 2021, at 11:49 AM, Dean Willis <[email-masked]> wrote:
> 
>

---

From: Larry Masinter <[email-masked]>
Date: Sun, 6 Jun 2021 13:56:18 -0700

I disagree with your characterization of “kill them all” as “commonly used” or as a “term of art”. I’m assuming they use 
Sentiment analysis - Wikipedia <https://en.wikipedia.org/wiki/Sentiment_analysis>  , which is another area making use of AI.

I wrote about censorship last year

Masinter's Musings: The Epidemiology of Bad Ideas <https://masinter.blogspot.com/2020/05/the-epidemiology-of-bad-ideas.html> 

The back-off algorithm probably need not be exponential (as doubling the time delay would be) to be effective.

But I agree with your conclusion (“the IETF MUST NOT rely on social media platforms”), although for different reasons – I don’t think the IETF should rely on any communication platform where significant revenue of the platform comes from selling or using information about the preferences or behavior of the participants.  But also because “open source” is more than an implementation strategy, it also provides for transparency and faster evolution.

--

From: Dean Willis <[email-masked]> 
Sent: Sunday, June 6, 2021 11:48 AM
To: [email-masked]; [email-masked]
Cc: [email-masked]; [email-masked]
Subject: Re: Postel's Principle and Layer 9 protocol engineering

-------- Original Message --------
On Jun 6, 2021, 1:13 PM, Larry Masinter < [email-masked] <mailto:[email-masked]> > wrote:
...

----

--
Dean

---

From: "John Levine" <[email-masked]>
Date: 6 Jun 2021 17:14:53 -0400

It appears that Dean Willis  <[email-masked]> said:
>Larry, they didn't "delay my posting for a reasonable length of time. " They permanently blocked my comment, denied the appeal, and banned me from
>using Facebook for any purpose for 24 hours. As I understand it, they use an escalating scale, so the next time they make this mistake it's a week
>ban, then two, then a month...

Facebook like every large social media platform uses automated
filtering software, backed up by farms of poorly paid moderators most of
whom are not in the U.S.  I hear that Twitter gets 6000 posts per second,
and Facebook is a lot bigger.

I don't see that they have made a mistake. While I don't claim to be a
great fan of Facebook, blocking messages that could be interpreted as
death threats isn't surprising, and it is also unsurprising that
neither their software nor their offshore moderators recognized your
reference. I expect that some of the people who might have seen it
wouldn't have recognized it either. They blocked you for 24 hours, and
now you have a day to decide whether you want to play by their rules.
Sometimes when you use a free service, you get what you pay for.
 
>Given that MY current employer (for better or worse) is an agency that literally runs on top of social media platforms, said 24 hour ban literally
>blocks my income stream and the business operations of my clients. Now, perhaps that's my problem and I have a business Facebook dependency to
>resolve, which I will do...

To put it mildly, that is Not Their Problem.  If I were in your situation I would decide whether I wanted
to figure out how to maintain my FB access or else perhaps look for a job that was less aggravating.

R's,
John

PS: I tried to log into my FB account earlier today for the first time in over a month, and no matter what browser
I use, I don't get past the page that tells me that I have to log in.  i presume it's tripping over some of the
anti-adware configuration in my network, but after some thought I have concluded that is a feature, not a bug.

---

From: Dean Willis <[email-masked]>
Date: Sun, 06 Jun 2021 22:35:17 +0000

-------- Original Message --------
On Jun 6, 2021, 3:56 PM, Larry Masinter < [email-masked]> wrote:

I disagree with your characterization of “kill them all” as “commonly used” or as a “term of art”.

----

Like you never used a kill -9?

And the IESG never had conversations about killing working groups or even entire areas?

---

From: Lixia Zhang <[email-masked]>
Date: Sun, 6 Jun 2021 16:10:15 -0700

> On Jun 6, 2021, at 1:56 PM, Larry Masinter <[email-masked]> wrote:
> .....
> But I agree with your conclusion (“the IETF MUST NOT rely on social media platforms”), although for different reasons – I don’t think the IETF should rely on any communication platform where significant revenue of the platform comes from selling or using information about the preferences or behavior of the participants.  

I would like to second Larry's above comment.
I believe the standard term for FB-like business is "surveillance capitalism". I quit FB and do not plan to get back.

Lixia

---

From: Keith Moore <[email-masked]>
Date: Sun, 6 Jun 2021 23:24:01 -0400

> I’m curious what the average number of words are used in a FB post, and the average number of words are in a technical discussion. My belief is that FB would be difficult to use (as would Twitter)…

FB comments are constrained to be short, as is the case for several 
other social media channels.   I've long ago formed the opinion that 
such restrictions are intended to favor ranting text-bites over 
thoughtful discussion.   I agree that these media are entirely 
inappropriate for technical discussions, including IETF discussions.

Keith

---

From: "Bron Gondwana" <[email-masked]>
Date: Mon, 07 Jun 2021 15:58:27 +1000

> I disagree with your characterization of “kill them all” as “commonly used” or as a “term of art”. 

What about "nuke it from orbit, it's the only way to be sure"?

Bron.
--
  Bron Gondwana, CEO, Fastmail Pty Ltd
  [email-masked]

---

From: Christian Huitema <[email-masked]>
Date: Sun, 6 Jun 2021 23:07:44 -0700

On 6/6/2021 10:58 PM, Bron Gondwana wrote:

>> On Jun 6, 2021, 3:56 PM, Larry Masinter <[email-masked]> wrote:
>>

I, for one, try to avoid metaphors involving war, murder or dead bodies.

-- Christian Huitema

---

From: "Bron Gondwana" <[email-masked]>
Date: Mon, 07 Jun 2021 16:25:34 +1000

> I, for one, try to avoid metaphors involving war, murder or dead bodies.

I also do in technical discussions with mixed company, however I would use a joke like that in a private chat with my friends after a few drinks.

(and I use this example specifically because it's a common movie reference which I have heard multiple times in my professional life from a quite diverse set of people)

The big problem with current platforms is that flagging of something like that in a personal context can still lead to a platform-wide activity block.

Bron.